Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2511 Boot Issue

I recently bought a Cisco 2511 router to act as my access server for my home lab and it will not boot.  After initially setting up my lab, everything worked fine.  I configured the access server, saved the config, restarted it and now it is getting stuck on bootup.  Below is what I am getting from the console before it locks up.  In bold is the message that might be hinting at what could be wrong: "CONFIG_NEWER: Configurations from version 11.2 may not be correctly understood.  Any ideas?

System Bootstrap, Version 11.0(10c), SOFTWARE

Copyright (c) 1986-1996 by cisco Systems

2500 processor with 14336 Kbytes of main memory

%SYS-4-CONFIG_NEWER: Configurations from version 11.2 may not be correctly under


F3: 4253260+56428+236904 at 0x3000060

              Restricted Rights Legend

Use, duplication, or disclosure by the Government is

subject to restrictions as set forth in subparagraph

(c) of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

(c) (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

           cisco Systems, Inc.

           170 West Tasman Drive

           San Jose, California 95134-1706

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-I-L), Version 11.2(21), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Wed 15-Dec-99 22:13 by ccai

Image text-base: 0x0302320C, data-base: 0x00001000

cisco 2511 (68030) processor (revision M) with 14336K/2048K bytes of memory.

Processor board ID 19600414, with hardware revision 00000000

Bridging software.

X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

16 terminal line(s)

32K bytes of non-volatile configuration memory.

16384K bytes of processor board System flash (Read ONLY)

Hall of Fame Super Silver

Re: 2511 Boot Issue


That message is from the boot loader. In my experience where I have seen similar messages many times 99.9 % of the time the router boots fine and the config is understood. I doubt that this message is related to your problem.

When you configured the router, did you by any chance configure under line console 0 the command no exec? (perhaps as an abbreviation of no exec-timeout) Configuring no exec would produce the symptoms that you are describing.

Can you access the 2511 via the aux port? Depending on how you configured the router access through the aux port may be possible and changes to the configuration might be done to restore functionality to the console port.

Another possibility would be to go through the password recovery procedure where you change the config-register to ignore startup config and reboot. If your problem is the result of some configuration error this might be a way to recover from it.



New Member

Re: 2511 Boot Issue

Spot on, thanks!

line con 0

     no exec     <-- no good

     exec-timeout 0 0      <-- good

also, I wasn't able to access device via AUX port, had to use the password recovery.

Hall of Fame Super Silver

2511 Boot Issue

I am glad that my suggestion pointed you toward the solution. I learned the hard way that no exec is not an abbreviation for no exec-timeout. And my experience is that most of the time password recovery is the way out of this problem.

I am glad that you got it worked out.