Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

2522 Logging

I´m trying to setup a lab, i´m using a 2522 for a FR switch but i can´t see any messages on the output, no warnings or debug messages.

What am i doing wrong? Can someone help me with this?

FRSW.LAB#sh line

Tty Typ     Tx/Rx     A Modem  Roty AccO AccI  Uses    Noise   Overruns

   0 CTY               -    -      -    -    -     0        0        0/0

Line 1 is currently invalid

Line 2 is currently invalid

Line 3 is currently invalid

Line 4 is currently invalid

Line 5 is currently invalid

Line 6 is currently invalid

Line 7 is currently invalid

Line 8 is currently invalid

Line 9 is currently invalid

  10 AUX   9600/9600   -    -      -    -    -     0        0        0/0

* 11 VTY   9600/9600   -    -      -    -    -     4        0        0/0

  12 VTY   9600/9600   -    -      -    -    -     0        0        0/0

  13 VTY   9600/9600   -    -      -    -    -     0        0        0/0

  14 VTY   9600/9600   -    -      -    -    -     0        0        0/0

  15 VTY   9600/9600   -    -      -    -    -     0        0        0/0

FRSW.LAB#who

    Line     User      Host(s)               Idle Location

* 11 vty 0   admin     idle                     0 1.1.2.1

FRSW.LAB#

#########################################################################

FRSW.LAB#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 3000 Software (IGS-I-L), Version 11.0(8), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-1996 by cisco Systems, Inc.

Compiled Sat 27-Apr-96 01:23 by vprasad

Image text-base: 0x0301DE2C, data-base: 0x00001000

ROM: System Bootstrap, Version 5.2(8a), RELEASE SOFTWARE

ROM: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(8a), RELEASE SOFTWARE (fc1)

FRSW.LAB uptime is 23 hours, 34 minutes

System restarted by reload

System image file is "flash:ie1108", booted via flash

cisco 2522 (68030) processor (revision M) with 14336K/2048K bytes of memory.

Processor board ID 03850160, with hardware revision 00000002

Bridging software.

X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.

Basic Rate ISDN software, Version 1.0.

1 Ethernet/IEEE 802.3 interface.

2 Serial network interfaces.

8 Low-speed serial(sync/async) network interfaces.

1 ISDN Basic Rate interface.

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

####################################################

FRSW.LAB#sh logging

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)

    Console logging: level debugging, 124 messages logged

    Monitor logging: level debugging, 0 messages logged

        Logging to: vty11(0)

    Trap logging: disabled

####################################################

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

transport input all

line vty 0 4

exec-timeout 60 0

privilege level 15

password cisco

logging synchronous

Everyone's tags (5)
12 REPLIES
Hall of Fame Super Gold

2522 Logging

David

You have not told us where (and how) you are looking for syslog output. From the output that you posted it looks like logging to the console is enabled and has displayed 124 messages. Were you on the console while things were going on?

From the output that you posted it looks like monitor logging is enabled. Have you done terminal monitor on the session before you start testing?

From what you have posted it looks like buffered logging is not enabled. So the show log command would not display syslog messages.

HTH

Rick

New Member

2522 Logging

Richard,

thanks for the quick reply.

About the 124 messages i can´t see a single one. when i do show log the only output that i gives me it´s this:

FRSW.LAB(config)#logg

FRSW.LAB(config)#logging on

FRSW.LAB(config)#logging console debugging

FRSW.LAB(config)#logging buffered 20000

FRSW.LAB(config)#logging monitor debugging

FRSW.LAB#term mon

FRSW.LAB#

FRSW.LAB#sh log

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)

    Console logging: level debugging, 124 messages logged

    Monitor logging: level debugging, 0 messages logged

        Logging to: vty11(0)

nothing more. I have tried to configured in all forms but i simply can´t see messages from this router. From term mon to logging everything i just can´t see any type of messages.

Any more ideias? I doing something wrong... :X

Hall of Fame Super Gold

2522 Logging

David

You show this command as if you have entered it

FRSW.LAB(config)#logging buffered 20000

but the output that you posted implies that it has not been entered. Can you clarify this?

I would suggest this as a quick test:

- in global config mode enter the logging buffered command.

- if you are not on the console, then enter the terminal monitor command

- go into config mode

configure terminal

- exit config mode

exit

- the console or the terminal monitor show display a message about router configured ...

- show logging should now display the message about router configured

try that and let us know what happens.

HTH

Rick

New Member

2522 Logging

Richard,

FRSW.LAB#conf term

Enter configuration commands, one per line.  End with CNTL/Z.

FRSW.LAB(config)#loggi

FRSW.LAB(config)#logging buffered

FRSW.LAB(config)#

FRSW.LAB(config)#

FRSW.LAB#

FRSW.LAB#

FRSW.LAB#term mon

FRSW.LAB#

FRSW.LAB#

FRSW.LAB#conf term

Enter configuration commands, one per line.  End with CNTL/Z.

FRSW.LAB(config)#inter ser

FRSW.LAB(config)#inter serial 8

FRSW.LAB(config-if)#sh

FRSW.LAB(config-if)#

FRSW.LAB(config-if)#

FRSW.LAB(config-if)#no sh

FRSW.LAB(config-if)#

FRSW.LAB#

FRSW.LAB#

FRSW.LAB#sh logging

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)

    Console logging: level debugging, 124 messages logged

    Monitor logging: level debugging, 0 messages logged

        Logging to: vty11(0) vty12(0)

    Trap logging: disabled

FRSW.LAB#

and last but not the least,

FRSW.LAB#sh privilege

Current privilege level is 15

FRSW.LAB#

I  can´t see any thing . This is weird!

Hall of Fame Super Gold

2522 Logging

David

That is very strange. Thanks for showing exactly what you had done - and the lack of logging.

Can you post the complete config? Perhaps there is something there that I am not expecting?

HTH

Rick

New Member

2522 Logging

here´s the full configuration:

FRSW.LAB#sh run

Building configuration...

Current configuration:

!

version 11.0

service timestamps debug uptime

service timestamps log uptime

no service udp-small-servers

no service tcp-small-servers

!

hostname FRSW.LAB

!

aaa new-model

aaa authentication login default local

aaa authentication login none none

aaa authorization exec local

enable secret 5 $1$8e2H$Pp8XasdasdasdxaPFROxnwdasasd1

!

username admin nocallback-verify callback-dialstring "" password 7 *password removed*

username student nocallback-verify callback-dialstring "" password 7 *password removed*

no ip domain-lookup

frame-relay switching

!

interface Ethernet0

description !! NAO ALTERAR ESTE INTERFACE !!

ip address 1.1.1.5 255.255.255.0

!

interface Serial0

description Connected to R1

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay intf-type dce

frame-relay route 102 interface Serial1 201

frame-relay route 103 interface Serial2 301

frame-relay route 104 interface Serial4 401

frame-relay route 105 interface Serial5 501

frame-relay route 113 interface Serial3 311

!

interface Serial1

description Connected to R2

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay intf-type dce

frame-relay route 201 interface Serial0 102

frame-relay route 203 interface Serial2 302

frame-relay route 204 interface Serial4 402

frame-relay route 205 interface Serial5 502

frame-relay route 213 interface Serial3 312

!

interface Serial2

description Connected to R3 S1/0

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay intf-type dce

frame-relay route 301 interface Serial0 103

frame-relay route 302 interface Serial1 203

frame-relay route 304 interface Serial4 403

frame-relay route 305 interface Serial5 503

!

interface Serial3

description Connected to R3 S1/1

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay intf-type dce

frame-relay route 311 interface Serial0 113

frame-relay route 312 interface Serial1 213

frame-relay route 314 interface Serial4 413

frame-relay route 315 interface Serial5 513

!

interface Serial4

description Connected to R4

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay intf-type dce

frame-relay route 401 interface Serial0 104

frame-relay route 402 interface Serial1 204

frame-relay route 403 interface Serial2 304

frame-relay route 405 interface Serial5 504

frame-relay route 413 interface Serial3 314

!

interface Serial5

description Connected to R5

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay intf-type dce

frame-relay route 501 interface Serial0 105

frame-relay route 502 interface Serial1 205

frame-relay route 503 interface Serial2 305

frame-relay route 504 interface Serial4 405

frame-relay route 513 interface Serial3 315

!

interface Serial6

no ip address

encapsulation frame-relay

frame-relay intf-type dce

frame-relay route 611 interface Serial8 116

!

interface Serial7

encapsulation frame-relay

!

interface Serial8

description LIGADO R3 S0/0/1

no ip address

encapsulation frame-relay

clockrate 64000

frame-relay intf-type dce

frame-relay route 116 interface Serial6 611

!

interface Serial9

description LIGADO R5

no ip address

clockrate 64000

!

interface BRI0

no ip address

shutdown

!

ip route 0.0.0.0 0.0.0.0 1.1.1.1

ip route 1.1.2.0 255.255.255.0 1.1.1.1

logging buffered

no logging trap

banner motd ^C

****************************************************

**                                                **

****************************************************

^C

alias exec sir sh ip route

alias exec si sh ip int brief

alias exec showrun ere

privilege interface level 15 frame-relay

privilege interface level 15 description

privilege configure level 15 interface

privilege exec level 15 copy running-config startup-config

privilege exec level 15 copy running-config

privilege exec level 15 copy

privilege exec level 15 configure terminal

privilege exec level 15 configure

privilege exec level 15 clear line

privilege exec level 15 clear

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

transport input all

line vty 0 4

exec-timeout 60 0

privilege level 15

password cisco

logging synchronous

!

end

FRSW.LAB#

Hall of Fame Super Gold

2522 Logging

David

Thanks for posting the config. I would suggest trying this in the config

logging trap info

Give that a try and let us know if it changes things.

HTH

Rick

New Member

2522 Logging

Richard,

i´ve changed the configuration to

FRSW.LAB(config)#logging trap informational

FRSW.LAB#sh logging

Syslog logging: enabled (0 messages dropped, 0 flushes, 0 overruns)

    Console logging: level debugging, 124 messages logged

    Monitor logging: level debugging, 0 messages logged

    Trap logging: level informational, 128 message lines logged

same output as allways!! Nothing in sight.

Hall of Fame Super Gold

2522 Logging

David

Thank you for trying all of my suggestions. At this point I do not have a good explanation of what is causing the problem and am beginning to think about buggy behavior. I wonder if a router reboot would change the symptoms.

HTH

Rick

New Member

2522 Logging

I´ve done it!

Every time i change a setting in the logging configuration i have to reload the switch to take efect.

Case solved!

Hall of Fame Super Gold

2522 Logging

David

I am still puzzled at what is causing this.

But at this point I am happy to have a case solved

HTH

Rick

New Member

2522 Logging

Richard,

thanks for all but for know i don´t want to troubleshoot hardware to the max. I hope that everything else works correct

Thanks for all again!

460
Views
0
Helpful
12
Replies
CreatePlease to create content