Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

2611 no routing (long)

I have just got a few 2611 dual ethernet routers running IOS 12.2(17) and start setting up my home lab. But I am running into "no routing" problem.

I already have a home network 192.168.0.x/24 and the default gateway is 192.168.0.1. I set the E0/0 on 192.168.0.103/24, set name-server to 192.168.0.1 and default-gateway to 192.168.0.1 and been able to ping the internet and get NTP running.

So, being happy with that, I proceeded to setup E0/1 to 192.168.1.x/24 with DHCP server enable (default-router 192.168.1.1) and excluded this address from DHCP pool. My PC on 192.168.1.x network got 192.168.1.2/24 address with default gateway at 192.168.1.1. So, I thought "that's cool, let's ping yahoo.com" - Failed. I went back to the router and did a "show IP route" and figured out the I didn't do "ip routing" to enable it (it was turned off by default). After I did that, the "show IP route" displays both direct connected network but I can't ping internet from the router anymore. I dug a little more and put a default route to use 192.168.0.1 for internet and I can ping internet again from the router and NTP works again. So, I thought this should have fixed.

I went back to the PC and ping E0/1, no problems. Then ping E0/0, no problems. Then I can't ping anything else on the 192.168.0.x network by IP address or name.

The PC on 192.168.0.x network can also ping E0/0 and E0/1 but not the PC on the 192.168.1.x network.

Somehow, ping can talk to both E0/0 and E0/1 interfaces but nothing beyond. My show IP route shows both directly connected networks and I expected routing.

I have been already on it for 6 hours. I must have missed something simple? I thought the 192.168.x.x private address cannot be routed. But I read lots of examples using private address in cisco routers without problems. Could anyone give me some insights?

(When I turned on debug IP packets and did a ping from the 192.168.1.2 PC to 192.168.0.1, I don't see anything reference to trying to reach 192.168.0.1, that's strange !)

Thanks in advance ! - AC

Below is the configuration:

Router#sh run

Building configuration...

Current configuration : 955 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

enable secret xxx

enable password cisco

!

memory-size iomem 10

clock timezone est -5

ip subnet-zero

!

!

ip name-server 192.168.0.1

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool kids

!

ip dhcp pool 192.168.1.0/24

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 192.168.0.1

!

!

!

!

interface Ethernet0/0

ip address 192.168.0.103 255.255.255.0

no ip mroute-cache

half-duplex

no cdp enable

!

interface Ethernet0/1

ip address 192.168.1.1 255.255.255.0

no ip mroute-cache

half-duplex

no cdp enable

!

ip default-gateway 192.168.0.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip http server

!

!

line con 0

password cisco

login

line aux 0

line vty 0 4

exec-timeout 60 0

password cisco

login

!

ntp clock-period 17208164

ntp server 68.x.79.113

end

10 REPLIES
Hall of Fame Super Silver

Re: 2611 no routing (long)

Alexander

Based on what you have posted I am going to guess that the problem is that the router at 192.168.0.1 does not have a route for the 192.168.1.0 network. Can you check that router and verify what is in its routing table?

HTH

Rick

New Member

Re: 2611 no routing (long)

Hi Rick...The router at 192.168.0.1 is indeed NOT a Cisco router and does not have a route to 192.168.1.x network. But I do have a Brother printer at 192.168.0.98 and the PC on 192.168.1.x network cannot ping it either. Actually, the problem seems like the devices on one side of the router can't ping the devices on the other side and vice versa. The computers and devices are directly connected to E0/0 and E0/1. It's my first simple home lab and I think I may have missed something simple.

Thanks.= AC

Hall of Fame Super Silver

Re: 2611 no routing (long)

AC

I believe that what you have missed is the significance of the default gateway configured on the devices in the 192.168.0.0 network. I believe that they are configured with 192.168.0.1 as their default gateway.

So what happens is this:

- device in 192.168.1.x network sends a packet to some 192.168.0.y address and sends it to its gateway address on the router.

- the router forwards it directly to the destination device since the router is on the 192.168.0.0 network and can ARP for the destination address.

- the device receives the packet and responds. Since it is responding to a "remote" address it forwards to its default gateway at 192.168.0.1.

- the router at 192.168.0.1 does not have a route to the 192.168.1.0 network and drops the packet.

For your lab network to work you either need to get a route for 192.168.1.0 into the 192.168.0.1 router. Or you need to configure the devices in 192.168.0.0 network to have their default gateway set to your new router.

HTH

Rick

New Member

Re: 2611 no routing (long)

Rick, you are right !!!!!!! Your explanation makes perfect sense. All my devices on 192.168.0.x network have default gateway of 192.168.0.1.

My non-cisco router is actually a WinXP machine running internet connection sharing. I wish I can use something different (read: better) but I live in a remote area that I can ONLY get high speed internet via a Wireless device to cell phone tower. This can only be run on a Windows PC.

Now I have to research on how to add a route on the XP computer.

Again, thank you very much for answering my question !

- AC

Super Bronze

Re: 2611 no routing (long)

re: XP routing

Start with "route ?" at command prompt.

Silver

Re: 2611 no routing (long)

The route command can be used to add routes to a windows box. That will solve your problem of connectivity between your 2 lans. However you would most likely find that the 192.168.1.x subnet will not be able to reach the internet. You will need to configure NAT on the 2611 for this subnet to reach the internet.

Hall of Fame Super Silver

Re: 2611 no routing (long)

AC

It may work ok for you if you configure routing on the XP PC. But I would suggest that you also consider the option of configuring the devices in the 192.168.0.x network to have their default gateway point at the router instead of having the XP PC as their default gateway. The router will be more effective at intervlan routing than the XP would be. And the Cisco router can do things like address translation it you want it to and forward Internet traffic to the XP PC to get to the Internet.

HTH

Rick

New Member

Re: 2611 no routing (long)

Wow! Thanks for the ideas. Now I have a few more labs to do !!!

I'm going to try out all the ideas here as part of my learning curve.

I did more reading today. Definitely can create a route on the XP box for 192.168.1.x network. I believe this may allow PC to ping devices on 192.168.0.x network because the device receiving the ping will forward its reply to the XP box (default gateway), then in turn, the the XP box will forward to the E0/0 (192.168.0.103) and the router will forward the reply to 192.168.1.x network. I'm not sure if internet will work this way (XP box is doing NAT and the internal IP network is hard coded DHCP to be on 192.168.0.x with 192.168.0.1 as default gateway) but I'll find it out in the lab.

I'm waiting for my new cables and switches to arrive to setup a new subnet for testing, I have been putting my children's PC for this testing and they don't like it.

I will post results here after I have tried all these configurations within a few days.

Thanks all!

-AC

New Member

Re: 2611 no routing (long)

Results here:

LAB 1: Add a route in the XP box for 192.168.1.0 network.

- Can ping 192.168.0.1 now

- Has DNS (from 192.168.0.1)

- CANNOT ping internet therefore no internet access.

(I think the NAT in XP ICS is hardcoded to translate between all internet networks and ONLY 192.168.0.x. Therefore, anything originates from 192.168.1.x will not be routed through the XP box)

LAB 2: Delete the route in XP box from LAB 1. Then config NAT/PAT on 2611 router. E0/0 set to DHCP (lease address from the hard coded DHCP server on XP). Setup the IP NAT inside on E0/1 and outside on E0/1. Setup an standard access list to allow traffic from 192.168.1.x and enable NAT to overload interface e0/0 with this access list.

- Everything works !!!

- Can ping 192.168.0.x subnet devices and the internet.

- Has internet access.

*** I was about to try LAB 3 (to point D.G. of all devices on 192.168.0.x to the router but since XP's DHCP server is hard coded and there is no way to exclude IP addresses. I decided not to do it (many family members are using this network as production network/school etc). I'm thinking putting all inside hosts behind the 2611 router, i.e. All inside hosts will connect to internet via NAT/PAT on the 2611 router.

Again, thank you everyone for your help. I have learned a lot for this lab through your input.

- AC

Hall of Fame Super Silver

Re: 2611 no routing (long)

AC

I am glad that you got it worked out. While I like option 3 where all end stations use the router as their default gateway, I recognize the importance of the fundamental rule of networking that when you get something to work you should not go back and change it and possibly break it.

It was a good lab and I am glad that it was a good experience for you.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

166
Views
0
Helpful
10
Replies
CreatePlease to create content