Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2620xm SLOW ADSL when using the WIC-1ADSL

Hello..

I have a 2620xm router with AT&T DSL 6000/768 service....

When I setup pppoe using the WIC-1ADSL my speed is 2369Kbps... (DSL>>Router>>Lan)

When I setup pppoe with a DSL modem infront of the router my speed is 5460Kbps.... (DSL Modem>>Router>>Lan)

The 2620xm info:

IOS c2600-adventerprisek9-mz.124-19

48mb Flash/256mb Ram

2 FastEthernet interfaces

1 Serial interface

1 ATM interface

Current Config:

!

! Last configuration change at 15:27:30 CDT Tue Jan 6 2009

! NVRAM config last updated at 14:15:59 CDT Tue Jan 6 2009

!

version 12.4

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

!

hostname xxxxxxx

!

boot-start-marker

boot-end-marker

!

logging count

logging buffered 16000 debugging

logging console informational

enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxx

enable password 7 xxxxxxxxxxxxxxxxxxxx

!

no aaa new-model

clock timezone CDT -6

clock summer-time CDT recurring

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef

!

ip domain name xxxxxxxxxxxx

ip name-server xxxxxxxxxxxx

ip name-server xxxxxxxxxxxx

ip name-server xxxxxxxxxxxx

ip name-server xxxxxxxxxxxx

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

ip ddns update method sdm_ddns1

DDNS both

!

ip ddns update method sdm_ddns2

HTTP

add xxxxxx:xxxxxx-members.dyndns.org/nic/update?system=dyndns&hostname/nic/update?system=dyndns&hostname</A>=<h>&myip=<a>

!

remove xxxxxx:xxxxxx-members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

interval maximum 28 0 0 0

interval minimum 28 0 0 0

!

!

username xxxxxx privilege 15 view root secret 5 xxxxxxxxxxxxxxxxxxxxx

!

!

!

!

buffers tune automatic

!

!

!

interface FastEthernet0/0

description (LAN) xxxxxxxxx-ISA 2006 Server$ETH-LAN$

ip address xxxxxxxxxxxx xxxxxxxxxxxxxxx

ip access-group 100 in

ip helper-address xxxxxxxxxxxxx

ip mask-reply

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1460

speed 100

full-duplex

no mop enabled

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface ATM0/1

description (WAN) AT&T ADSL

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

dsl enable-training-log

hold-queue 224 in

!

interface ATM0/1.1 point-to-point

pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface FastEthernet1/0

description (DMZ)

ip address xxxxxxxxxxxx xxxxxxxxxxx

ip helper-address xxxxxxxxxxx

ip nat inside

ip virtual-reassembly

speed 100

full-duplex

!

interface Dialer0

description Virtual Dial Interface

ip ddns update hostname xxxxxxxxxxxxxxx

ip ddns update sdm_ddns2

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username xxxxxxxxxxxxx@xxxxxxxxxxxx password 7 xxxxxxxxxxxxxxxxx

ppp ipcp dns request

ppp ipcp route default

!

ip forward-protocol nd

!

!

ip http server

ip http access-class 1

no ip http secure-server

ip nat inside source list 2 interface Dialer0 overload

*** NAT INFO REMOVED BECAUSE OF SIZE ***

!

logging trap debugging

logging xxxxxxxxxxxx

logging xxxxxxxxxxxx

***ACL LIST REMOVED BECAUSE OF SIZE ***

dialer-list 1 protocol ip permit

snmp-server community public RW

!

!

!

control-plane

!

!

!

!

!

!

!

!

!

!

line con 0

transport preferred none

speed 115200

line aux 0

line vty 0 4

access-class 101 in

password 7 xxxxxxxxxxxxxx

login

transport preferred none

!

ntp logging

ntp clock-period 17180358

ntp server xxxxxxxxxxx source FastEthernet0/0 prefer

!

end

I have attached some of the SHOW INTERFACE commands......

I know this is a huge post but I am posting all information possible......

Thanks.......I am just not sure if I missed a command somewhere....

I would be thankful for ANY help or information.....

Dave

  • WAN Routing and Switching
2 REPLIES
New Member

Re: 2620xm SLOW ADSL when using the WIC-1ADSL

Well seeing how I got many suggestions and help.....I was persistent in solving the issue......so I dug deep into every bit of Cisco documentation I could find...

The speed issue is resolved...

- Using the WIC-1ADSL

- No DSL modem in front of the router...

- Both Upload/Download speed and latency is actually BETTER than it was before....

Thanks once again.......

New Member

Re: 2620xm SLOW ADSL when using the WIC-1ADSL

Hi Scorpion,

I have run into this problem before on 2600XM devices running the C2600-ADVENTERPRISEK9-M IOS. I've run into this on a couple of occasions configuring the 2600XM devices. The way I worked around it was to install a standard IOS image. This gave correct speeds with 2 AT&T installs that I have done.

I would be very interested in how you solved this problem on your install. Please post and let's compare notes.

Regards,

Sam

204
Views
0
Helpful
2
Replies
This widget could not be displayed.