Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

2621XM - Issue with SegV exception

Hi all,

I have one issue with my 2621XM router.

When a tried to insert "interface mfr" command, router just reloded and repported following error message:

System returned to ROM by error - a SegV exception, PC 0x80468584

Cisco says

ERROR: This router was restarted by a Segmentation Violation Exception (SegV). This is caused by a software related problem. The most common software issues that can cause a Segmentation Violation Exception are: - Access to an invalid memory address - Write access to a read-only memory region - A jump to an invalid PC (often 0x0)

I tried to software upgrade router but i have still same issue

I want to configure some MFR interfaces and frame-relay encapsulation.

Here follows some more details from sh tech:

Sh ver:

Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(13)T, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2002 by cisco Systems, Inc.

Compiled Sat 16-Nov-02 23:00 by ccai

Image text-base: 0x80008098, data-base: 0x8183511C

ROM: System Bootstrap, Version 12.2(7r) [cmong 7r], RELEASE SOFTWARE (fc1)

NO001550NROU01 uptime is 1 day, 20 hours, 49 minutes

System returned to ROM by error - a SegV exception, PC 0x80468584

System restarted at 18:28:11 SUM Tue Apr 15 2008

System image file is "flash:c2600-is-mz.122-13.T.bin"

cisco 2620XM (MPC860P) processor (revision 0x100) with 94208K/4096K bytes of mem ory.

Processor board ID JAE07300121 (364871735)

M860 processor: part number 5, mask 2

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

32K bytes of non-volatile configuration memory.

32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

------------------ show stacks ------------------

Minimum process stacks:

Free/Size Name

5600/6000 SPAN Subsystem

2588/3000 allegro libretto init

8216/12000 Init

5440/6000 RADIUS INITCONFIG

8976/12000 Virtual Exec

Interrupt level stacks:

Level Called Unused/Size Name

1 47156100 8356/9000 Network interfaces

2 0 9000/9000 Timebase Reference Interrupt

3 0 9000/9000 PA Management Int Handler

6 4 8916/9000 16552 Con/Aux Interrupt

7 39886646 8920/9000 MPC860 TIMER INTERRUPT

System was restarted by error - a SegV exception, PC 0x80468584

C2600 Software (C2600-IS-M), Version 12.2(13)T, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Compiled Sat 16-Nov-02 23:00 by ccai

Image text-base: 0x80008098, data-base: 0x8183511C

Stack trace from system failure:

FP: 0x82C0D100, RA: 0x804691EC

FP: 0x82C0D118, RA: 0x80468758

FP: 0x82C0D138, RA: 0x803BEC54

FP: 0x82C0D168, RA: 0x815EAB54

FP: 0x82C0D190, RA: 0x815EADDC

FP: 0x82C0D1A0, RA: 0x815EC784

FP: 0x82C0D1C8, RA: 0x80942D80

FP: 0x82C0D200, RA: 0x8001C2B0

1 REPLY

Re: 2621XM - Issue with SegV exception

A SegV exception can be almost anything, but almost invariably a bug. For example, I had one in my lab over the weekend due to an IPv6 access list that it did not like ... that was on 12.4(2)T, also on a 2611XM as it happens.

I found this in the bug database that might be relevant, but I don't know whether you have traffic shaping anywhere:

CSCdz38482 Bug Details Bug #3 of 6 | < Previous | Next >

Router crashes with SegV exception

Symptoms: A Cisco router that is configured for Multilink Frame Relay (MFR)

may reload when traffic shaping is enabled on an MFR interface.

Conditions: This symptom is observed only when one of the MFR bundle links is

configured after traffic shaping has been enabled.

Workaround: There is no workaround.

The only thing I can suggest is save the config to a file, clear down the config completely, configure the MFR first, then gradually introduce the rest of the config until you find the bit it is clashing with. That's the way I found my IPv6 access-list bug.

Kevin Dorrell

Luxembourg

302
Views
0
Helpful
1
Replies
CreatePlease login to create content