Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

2691 Router ADSL WIC configuration for Internet through DSL ISP help

Hey everyone,

     So this will be my first discussion post on the Cisco Support Community. Just a small insight into what I know. I've been studying to get my CCNA through college, and I have general knowledge of Static/Dynamic Routing(EIGRP/OSPF/RIP), VLANs, NAT(overload), DHCP, Inter-vlan routing(on Layer 3 Switches as well), and that is all I can think of off the top of my head.

     I've been looking around for a while on how one would properly configure an ADSL WIC for Internet service from a ISP(TDS Telecom) without a static IP address(can't spare the money for Business Service for the static IP). It's quite possible that at one point or another I have found what I need but when configuring the ADSL interfaces it goes beyond what I know so far. As well as the fact of how to obtain my IP address from my ISP without using their Standard Issue Router to find out. I assume that if their router can do it, why can't I configure my router to do the same? This is all really just a home project to get ourselves away from the ISP's router and have our own house setup. I've already figured out the routing and vlans, but I just can't get my head around the NAT operation for the ADSL wics and obtaining an Internet connection from it.

     I'll answer any querys for information about what I am using, as this is my first discussion post, I'm not exactly sure what I should include. I'm also willing to read up on anything posted on this(probably will have to). May as well learn something, which is really the best part I'll get out of accomplishing this. I also really have the option to try anything, as the router is currently doing nothing besides being a playground for testing things out.

     I look forward to help/responces!

  • WAN Routing and Switching
Everyone's tags (3)
3 REPLIES

Re: 2691 Router ADSL WIC configuration for Internet through DSL

Hi Ian.
First of all welcome to the Support Community :)

Now.. please attach your current config here so we can suggest you the correct way to make it work.

Than, usually you should configure a PVC under your ATM interface specifying the encapsulation (pppoa usually is aal5mux)
then assing this pvc to a dialer pool which will be the same of the dialer interface that you will configure to setup the ppp link to your ISP and to obtain a public IP address dynamically.

EG

interface ATM0
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1


interface dialer0
encapsulation ppp
dialer pool 1
ip address negotiated
ip nat out
ppp authentication pap callin <--- this depends on your ISP
ppp pap sent username user password password




HTH

Regards

Carlo

Sent from Cisco Technical Support iPhone App

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: 2691 Router ADSL WIC configuration for Internet through DSL

     Thanks for the reply and welcome Carlo! 

Alright, well my current running configuration is;

Current configuration : 3036 bytes

!

! Last configuration change at 22:46:46 PCTime Mon Feb 10 2014 by Smith

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname SEdge

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$/8VP$k/12RtCrjbh84fMhUV1vv.

enable password 7 03085A05050A

!

no aaa new-model

clock timezone PCTime -8

ip cef

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

crypto pki trustpoint TP-self-signed-3368344326

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3368344326

revocation-check none

rsakeypair TP-self-signed-3368344326

!

!

crypto pki certificate chain TP-self-signed-3368344326

certificate self-signed 01

  3082023D 308201A6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33333638 33343433 3236301E 170D3032 30333031 32333434

  32385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 33363833

  34343332 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100ACD1 544F0D32 10F5A500 F78C37AB 540680AB A881DA1F 1AEFEED0 39426FD2

  0127C5D1 420B4032 607343DD 07D06D7A 39960ECB 50E7B360 FE7AE3A8 39EFA4AA

  EC27E548 71ACD948 F11392CB 59D2B92D 15BF707D 01978875 2D9ABF67 9F91B672

  8DF7D6CF 3C7E3E5A 5FB23698 632BF677 C62D5732 7735F2B6 BB4696C6 589FDCE1

  CE750203 010001A3 65306330 0F060355 1D130101 FF040530 030101FF 30100603

  551D1104 09300782 05534564 6765301F 0603551D 23041830 1680148E 80876FA3

  10B2DD33 8973FEA1 7DF966AE E9D17430 1D060355 1D0E0416 04148E80 876FA310

  B2DD3389 73FEA17D F966AEE9 D174300D 06092A86 4886F70D 01010405 00038181

  008BECE3 AE5814A8 CB2C5A53 A744AD7C 30405B0F 0B05EC3F DB414650 2E832CC6

  0A276ACD CA8F1F8F B9FA6849 A6856611 9AB98BFE 03D421E4 6322AA4D 39DBD223

  9B421E36 FDD8CFE9 46992B5E 99EFDA0F 9EC5E795 4B7D7258 60F4FDF4 881BCB99

  D32651D6 0741F60F 595348A6 477AB9A8 515C11E1 8AF7CA7C 01C18FD0 D6CAACD1 E3

  quit

username Smith privilege 15 secret 5 $1$BFRN$uiHDCDHO5v5o8XgHUlgph.

!

!

!

!

!

interface Loopback0

no ip address

!

interface ATM0/0

no ip address

shutdown

atm restart timer 300

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0/0

ip address 192.168.0.150 255.255.255.0

duplex auto

speed auto

!

interface ATM0/1

no ip address

shutdown

atm restart timer 300

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet0/1

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

control-plane

!

!

!

!

!

!

!

banner motd ^C

Unauthorized Access is strictly prohibited!

^C

!

line con 0

privilege level 15

password 7 04570A080C24

logging synchronous

login

line aux 0

line vty 0 4

privilege level 15

password 7 050707012249

logging synchronous

login local

transport input all

!

!

end

As said before it is a Cisco 2691 Multi-access Router. With 2 ADSL WICs.

     Pretty empty as I said(just for consoling and telnet/ssh), the router wont be doing nearly as much as the Layer 3 switch I have will be doing, pretty much just NAT. A few things that I know about my ISP. The router they leased to us states they are using LLC encapsulation. And I forget which field it is under, but I believe they use RFC 1483 over DHCP. And I have two questions;

For ppp authentication pap callin, what exactly does it depend upon? What information to I need?

And with ppp pap sent username user password password, can they just be what I choose?

Sincerely,

Ian

Re: 2691 Router ADSL WIC configuration for Internet through DSL

Hello Ian.

PPP authentication is used to exchange authentication with your ISP and PAP or CHAP depends upon what your provider accept as method (usually they accept both)

Username and password ar provided by ISP only if they need you to authenticate.

HTH

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
305
Views
0
Helpful
3
Replies
This widget could not be displayed.