Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Bronze

2811 reload - startup config not loading

When I execute the reload command on my 2811 it loads the correct bin file based on my startup config (see below), however the rest of my config doesn't load.

     boot-start-marker
     boot system flash:c2800nm-advsecurityk9-mz.124-24.T2.bin
     boot-end-marker

I can see it loading the bin file successfully but then rather than loading the rest of my startup-config it takes me to the initial setup. I don't see any errors. If I do a show start I can see the config I want. Of course, when I do a show run I just see the generic config on a new router. My only workaround now in case the router reboots is to copy the config over the top. Any ideas why it wouldn't fully load my config? By the way, I'm admittedly no network guy but have been tasked with some lab work so excuse me if this is extremely elementary. Thanks!

Everyone's tags (3)
3 REPLIES
Hall of Fame Super Gold

Re: 2811 reload - startup config not loading

Ensure that your config-registry is 0x2102.

Bronze

Re: 2811 reload - startup config not loading

That may be my issue then. My config-registry is currently set to 0xDE. Any idea on that value?

Hall of Fame Super Gold

Re: 2811 reload - startup config not loading

The config-registry should be 0x2102.

Go to configuration mode and enter the command "config-register  0x2102".

To verify, enter "sh version" and look at the end.  This registry will be used after a router reboot.

Hope this answers your question.

3651
Views
5
Helpful
3
Replies