Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

2911 - %SMC-2-BAD_ID_HW and license lost after rommon upgrade

Hi,

First of all I had a 2911 with IOS c2900-universalk9-mz.SPA.151-4.M4 and ROMMON Version 15.0(1r)M6. The following licenses were installed as permanent: ipbasek9, securityk9.

Router#show version

(...)

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

              Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      Permanent      ipbasek9

security      securityk9    Permanent      securityk9

When trying to upgrade to IOS c2900-universalk9-mz.SPA.152-4.M5 I received the following error message during boot:

*** Bus Error (Load) Exception ***

Access address = 0xffffffba

  PC = 0x80000a68, SP = 0x8efffd40, RA = 0x80000844

  Cause Reg = 0x4000801c, Status Reg = 0x504080e3

monitor: command "boot" aborted due to exception

I tried this on several 2911 routers, same result: All routers with ROMMON Version 15.0(1r)M6 failed to load IOS 152-4.M5. Routers with ROMMON Version 15.0(1r)M15 loaded the new IOS without any problem.

So i tried to upgrade the ROMMON on the first 2911 to the latest downloadable version from Cisco:

Router#upgrade rom-monitor file flash0:C1900_2900_RM2.srec.SPA.150-1r.M16

Platform Field Upgradeable ROMMON LOAD test

___________________________________________

RSA Signature Verification Passed ...

ROM: Digitally Signed Production Software

This command will result in a  'power-on reset' of the router!

Continue? [yes/no]: yes

ROMMON image upgrade in progress.

Erasing boot flash eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee

Programming boot flash pppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppppp

Now Reloading

After the reboot I now receive the following error messages:

%SMC-2-BAD_ID_HW: Failed Identification Test in 0/-1/-1 [7/0]

       The module in 0/-1/-1 in this router may not be a genuine

       Cisco product.  Cisco warranties and support programs only

       apply to genuine Cisco products.  If Cisco determines that

       your insertion of non-Cisco memory, WIC cards, AIM cards,

       Network Modules, SPA cards, GBICs or other modules into a

       Cisco product is the cause of a support issue, Cisco may

       deny support under your warranty or under a Cisco support

       program such as SmartNet.

And my ipbasek9 and securityk9 licenses are lost:

Router#show version

(...)

-----------------------------------------------------------------

Technology    Technology-package           Technology-package

              Current       Type           Next reboot

------------------------------------------------------------------

ipbase        ipbasek9      None           ipbasek9

security      None          None           None

Show diag shows me a failed identification test:

Router#sh diag

Slot 0:

        Failed Identification Test [ 7/0 ]

        C2911 Mother board 3GE, integrated VPN and 4W Port adapter, 3 ports

        Port adapter is analyzed

        Port adapter insertion time 01:41:01 ago

        EEPROM contents at hardware discovery:

        PCB Serial Number        : FOC171*****

        Hardware Revision        : 1.0

        Part Number              : 73-11833-11

        Top Assy. Part Number    : 800-30797-06

        Board Revision           : A0

        Deviation Number         : 130603

        Fab Version              : 03

        Product (FRU) Number     : CISCO2911/K9

        Version Identifier       : V07

        CLEI Code                : CMMJD00ARA

        Processor type           : C1

        Chassis Serial Number    : FCZ163*****

        Chassis MAC Address      : bc16.654a.****

        MAC Address block size   : 80

        Manufacturing Test Data  : 00 00 00 00 00 00 00 00

        EEPROM format version 4

        EEPROM contents (hex):

          0x00: 04 FF C1   (...)

So I tried to downgrade ROMMON back to Version 15.0(1r)M6. The problem stays the same.

--> What can I do to recover this router to normal operation?

--> How can I upgrade a 2911 with ROMMON Version 15.0(1r)M6 safely to IOS 152-4.M5 ?

Everyone's tags (4)
3 REPLIES
Community Member

i know it is a veeeery old

i know it is a veeeery old post, i am having the exact same issue and TAC can't figure it out either. I am wondering if the user managed to fixed and how.

 

cheers

 

Community Member

No, this wasn't fixed

No, this wasn't fixed unfortunately. The routers went back to our distributor...

Community Member

well thanks heaps to replying

well thanks heaps to replying on this...that does not sound promising! 

826
Views
0
Helpful
3
Replies
CreatePlease to create content