Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

2960S Not Forwarding Traffic for Specific VLAN

Hey all,

I have a Cisco 2960S-PST-L 48 port switch that will either not forward traffic for one of our VLANs completely or it will forward a very small amount of traffic and then stop.  When I connect a laptop directly to the switch, it takes a while to pull DHCP information and my network connection icon (Windows 7) will either show as if it has a connection to the Internet or it'll show as if it has limited connectivity.  When I run ipconfig /all, I obtain all the necessary information needed to communicate locally and to the internet.  I can't ping by host name to a local machine or out to the Internet from my laptop.  From the switch I can ping out to the Internet via hostname, however.  If I put the switch port in a different vlan such as VLAN 1, I can get IP info and browse the LAN & Internet with no problems.  To ensure that it's not an issue with the DHCP server, Web filter, or Firewall, I've had a laptop tested at another switch of the same model and all works fine regardless of the VLAN; even the VLAN in question on this switch.  In troubleshooting, I've checked CPU history, STP, and interface errors.  No high CPU utilization, no loops, and no input/output errors, etc.  I have also deleted my vlan.dat file to wiipe out VTP, rebooted the switch, and let it re-learn VTP info.  It sounds software related and I haven't upgraded the IOS yet.  The current version of IOS is version 12.2(55)SE5.  The only change I made to this switch is adding all 48 ports to VLAN 60 on our network and removing the auto qos command from the interfaces as well as any lines added from using the auto qos command.  No other changes were made.  What could be the problem?  I can post a copy of the config if needed.

Regards,

Terence

14 REPLIES
New Member

2960S Not Forwarding Traffic for Specific VLAN

please post running config

New Member

2960S Not Forwarding Traffic for Specific VLAN

sh run
Building configuration...

Current configuration : 16140 bytes
!
! No configuration change since last restart
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
boot-start-marker
boot-end-marker
!
logging buffered informational
!
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication login console local
aaa authentication enable default enable
aaa authorization console
aaa authorization exec default group tacacs+
aaa authorization exec console local
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
!
!
!
aaa session-id common
clock timezone EST -5
clock summer-time EDT recurring
system mtu routing 1500
!
!
ip name-server 10.1.20.161
ip name-server 10.1.20.162
!
!
crypto pki trustpoint TP-self-signed-3531270272
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3531270272
revocation-check none
rsakeypair TP-self-signed-3531270272
!
!
crypto pki certificate chain TP-self-signed-3531270272
certificate self-signed 01
  3082024E 308201B7 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33353331 32373032 3732301E 170D3133 30383031 31383434
  32385A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 35333132
  37303237 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CB96 0589509D 75BAB789 5883DDC4 6440BD12 49C83CC2 2185F2ED 07E759F8
  FA58F0E5 A25FC96D 58447BB2 6F83E874 027FC388 2DB754DB E31BE124 A9E891A9
  0E6A43C2 D0FA868E 31155296 AE1B73E2 4C56745A 8E60BA73 2DB7144F D4BA4F2A
  729CB3E2 1B2289EF 45EC69D7 173B1B72 0D5490E4 6679240E 54348E5C 6A7AE9C0
  8F030203 010001A3 76307430 0F060355 1D130101 FF040530 030101FF 30210603
  551D1104 1A301882 16736377 70366573 7731322E 73686570 6374722E 6F726730
  1F060355 1D230418 30168014 CABA5093 BE78956D CC986DFC 2BB324E7 826EF6E5
  301D0603 551D0E04 160414CA BA5093BE 78956DCC 986DFC2B B324E782 6EF6E530
  0D06092A 864886F7 0D010104 05000381 8100C534 74768831 F912AD93 60A2FB58
  96E3F648 878066FD C1A0888B 9D0EFD68 FACFB06F 2B1EF394 4B3C69E4 59F05A0C
  1C1A0BBD F66E8428 BF480561 265F0465 4EB16BF1 E2174186 97A679C8 B3ED12D4
  25432E77 E274E425 9D06600D 897687E2 20482187 9AF1CCFB C620566D 388A34BD
  146AB836 3D949D86 606335E4 50056701 E8E0
  quit
!
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree uplinkfast
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/2
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/3
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/4
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/5
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/6
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/7
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/8
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/9
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/10
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/11
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/12
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/13
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/14
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/15
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/16
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/17
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/18
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/19
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/20
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/21
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/22
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/23
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/24
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/25
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/26
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/27
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/28
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/29
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/30
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/31
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/32
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/33
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/34
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/35
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/36
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/37
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/38
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/39
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/40
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/41
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/42
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/43
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/44
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/45
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/46
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/47
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface FastEthernet0/48
description *** Patient Network ***
switchport access vlan 60
switchport mode access
switchport nonegotiate
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/1
description *** TRUNK LINK TO CORE SWITCH ***
switchport mode trunk
switchport nonegotiate
spanning-tree portfast disable
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
description *** TRUNK LINK TO CORE SWITCH ***
switchport mode trunk
switchport nonegotiate
spanning-tree portfast disable
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/3
description *** BACKUP TRUNK LINK ***
switchport mode trunk
switchport nonegotiate
spanning-tree portfast disable
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/4
description *** BACKUP TRUNK LINK ***
switchport mode trunk
switchport nonegotiate
spanning-tree portfast disable
spanning-tree link-type point-to-point
!
interface Vlan1
ip address 10.1.226.12 255.255.0.0
!
ip default-gateway 10.1.0.1
no ip http server
no ip http secure-server
logging 10.1.129.86
snmp-server community snmpcomm RO
snmp-server community snmpcommore RW
snmp-server location Woodruff 6th Floor Comm Closet
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps transceiver all
snmp-server enable traps tty
snmp-server enable traps cluster
snmp-server enable traps entity
snmp-server enable traps cpu threshold
snmp-server enable traps rep
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps flash insertion removal
snmp-server enable traps port-security
snmp-server enable traps auth-framework sec-violation
snmp-server enable traps dot1x auth-fail-vlan guest-vlan no-auth-fail-vlan no-guest-vlan
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps power-ethernet group 1
snmp-server enable traps power-ethernet police
snmp-server enable traps fru-ctrl
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps config-ctid
snmp-server enable traps energywise
snmp-server enable traps rtr
snmp-server enable traps vstack
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
snmp-server enable traps syslog
snmp-server enable traps mac-notification change move threshold
snmp-server enable traps vlan-membership
snmp-server enable traps errdisable
line con 0
line vty 0 4
line vty 5 15
end

2960S Not Forwarding Traffic for Specific VLAN

What's doing the routing for your vlans? Do you have a router-on-a-stick configuration?

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
New Member

2960S Not Forwarding Traffic for Specific VLAN

I assume the trunks to the core are pushing the traffic to be routed. whats your show int trunk output show?

Re: 2960S Not Forwarding Traffic for Specific VLAN

What does the switchport config on the core routers look like? Is it the same as the other switches that are working correctly?

Also, have you tried "sh vlan brief" on the switch that is not working? If the vlan is not getting created within the switch properly the ports won't show on the vlan the way they should be. I know you said VTP was working but it doesn't hurt to double-check.

Sent from Cisco Technical Support iPad App

New Member

Re: 2960S Not Forwarding Traffic for Specific VLAN

Guys,

My core is fine because all my other 2960s & 4500s are forwarding traffic for this VLAN just fine.  Our 6500s are responsible for routing but it's important to know that VLAN 60 is an unrouted VLAN which has it's own firewall & Web filter.  It's only when a device is connected to this 2960 switch that I'm experiencing this issue.  All VLANs on both trunk ports are allowed and I do have pruning enabled on all my trunk ports.  I've also placed devices that was connected to this 2960 on our new 4510E switch in that same closet and I can communicate to the LAN & the Internet on VLAN 60 with no problems.

New Member

2960S Not Forwarding Traffic for Specific VLAN

Hi,

Make sure that VLAN 60 is allowed on the ports from the CORE side, also check if the core switch is the root bridge for that vlan.

I would use a portchannel between the 2 switches.

Regards,

Tudor

New Member

2960S Not Forwarding Traffic for Specific VLAN

VLAN 60 is allowed on the trunks going to the core and we don't use port channel on the trunks going to the core because each trunk is going to a different core switch.  The backup trunk links are preconfigured in the event that the one or both the primary physical ports fail or go bad.

New Member

Re: 2960S Not Forwarding Traffic for Specific VLAN

Hi,

have you tried to install wireshark on your laptop and check sniff the packets , if not , could you please install it and try to ping using hostname , do ipconfig/release ipconfig/renew and upload the file ?

I don't have a 2960 switch in front of me now , but there is a command that will show you if the switch is forwarding the packets in hardware correctly or not , it is "show platform forward" you need to specifiy the vlan , src mac and dst mac.

could you please try it and post the output ?

Thanks,

Ahmad.

New Member

Re: 2960S Not Forwarding Traffic for Specific VLAN

Thanks guys,

As stated above, no changes to this switch was made except for removing auto qos and changing all the access ports to VLAN 60.  Nothing on the trunk ports or the core switch port that this switch is connected to has changed and shouldn't need to change.

My sh vlan brief command shows all 48 ports in VLAN 60.  Here is the output of the show platform forward command:

sh platform forward gi0/1 vlan 60 04da.d27a.e8b1 0023.eb13.66b0

Ingress:

Global Port Number: 49, lpn: 1 Asic Number: 0

Source Vlan Id: Real 60, Mapped 8. L2EncapType 0, L3EncapType 3

Hashes: L2Src 0x00 L2Dst 0x0F L3Src 0x00 L3Dst 0x0F

Lookup                   Key-Used                  Index-Hit    A-Data

Classify 68_0C700023_EB1366B0-00_000004DA_D27AE8B1     00BFC   00000000

InputACL 20_0C700023_EB1366B0-00_000004DA_D27AE8B1     00BF8   01000000

L2LrnMsk FF_03FFFFFF_FFFFFFFF-00_000003FF_00000000

L2Learn  83_000804DA_D27AE8B1-C3_00002031_00000000     01D90   00000060

L2FwdMsk FF_03FFFFFF_FFFFFFFF

L2Fwd    83_00080023_EB1366B0                          0138F   000000C1

Station Descriptor: F031F008, DestIndex: F031, RewriteIndex: F008

==========================================

Egress: Asic 0, switch 1

Source Vlan Id: Real 60, Mapped 8. L2EncapType 0, L3EncapType 3

portMap 0x2, non-SPAN portMap 0x2

Output Packets:

------------------------------------------

GigabitEthernet0/1 Packet 1

Lookup                   Key-Used                  Index-Hit    A-Data

OutptACL 30_0C700023_EB1366B0-00_000004DA_D27AE8B1     00BFC   01000000

Dropped due to failed deja vu check.

Here is the output of the show interface trunk on my STP forwarding port:

sh int gi0/1 trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi0/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk

Gi0/1       1-4094

Port        Vlans allowed and active in management domain

Gi0/1       1-3,7-8,10,30,60,70,88,103,111,128,200,202-203,206,208,650,666,999

Port        Vlans in spanning tree forwarding state and not pruned

Gi0/1       1-3,7-8,10,30,60,70,88,103,111,128,200,202-203,206,208,650,666,999

Let me also say that this switch has never had any of its ports in VLAN 60; they were either in VLAN 1 or a trunk port for APs with multiple SSIDs.

New Member

Re: 2960S Not Forwarding Traffic for Specific VLAN

You might try taking anoher 2960 with the exact same ios/config to that exact same location and plug in the smae uplink connections and plug into a vlan60 port to see if you get the same issues.

Once you do receive an ip - do you have unusual latency when you try to ping say your dhcp server? Does a tracert produce expected results?

Re: 2960S Not Forwarding Traffic for Specific VLAN

Also, it wouldn't hurt to upgrade to the latest release of 12.2(58).

Sent from Cisco Technical Support iPad App

New Member

2960S Not Forwarding Traffic for Specific VLAN

So no one has any idea as to why this may be happening?  I can give you another piece of information that I've just noticed.  I happened to remove auto qos voip trust on these ports for the 2960s after placing the ports in VLAN 60.  When I do that, this is when the problem seems to occur.  I did this on another switch and the same thing happened (not passing traffic consistently on VLAN 60).  When I put it in any other VLAN it works fine.  I then went to another switch and only placed all the ports in VLAN 60; I didn't remove any of the auto qos configs.  I got an IP address instantly and was able to browse any Web site with no problems.  So it only seems when I remove auto qos voip trust from the interfaces along with any of the global config lines that auto qos generates when enabled.  Should I open a TAC case for this issue at this point?

Regards,

Terence

Re: 2960S Not Forwarding Traffic for Specific VLAN

Hello

1) Is mls qos  still enabled - On the 3560 switches ( not sure about 2960's) I am aware if  mls qos is enabled the srr shceduler will shaped and share each interface and I think its is queue 1 that will be policed down to a specific BW value and the rest of the queues share the remaining BW.

2) Put an access port back to default and try reconfiguring it.

3) on the core switch is the svi for this vlan  process or fast switching?

Just baisic stuff but it worth a try?

sh mls qos

conf t

no mls qos

default interface xx

intxx

switchport host

switchport access vlan 60

no shut

on the core switch
sh int vlan 60 stats

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.

Please don't forget to rate any posts that have been helpful. Thanks.
1264
Views
0
Helpful
14
Replies
CreatePlease to create content