Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3560 and mls qos drops

We have a problem with our WS-C3560V2-24TS running IOS c3560-ipservicesk9-mz.122-53.SE2.bin.

The equipment keep dropping packets for no apperent reason.

This is what we are seeing:

LAN-port

Router0#sh interfaces fastEthernet 0/2 | include drops:

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 20595

WAN-port

Router#sh interfaces GigabitEthernet0/1 | include drops

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 2460

Port configuration:

Router#sh running-config interface gigabitEthernet 0/1

Building configuration...

Current configuration : 339 bytes

!

interface GigabitEthernet0/1

description unused

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 3596,3597

switchport mode trunk

bandwidth 1000000

speed nonegotiate

srr-queue bandwidth share 1 19 79 1

srr-queue bandwidth shape 4 0 0 0

srr-queue bandwidth limit 10

priority-queue out

mls qos trust dscp

end

Router#sh running-config interface fastEthernet 0/2

Building configuration...

Current configuration : 168 bytes

!

interface FastEthernet0/2

switchport access vlan 901

switchport mode access

bandwidth 100000

speed 100

duplex full

priority-queue out

mls qos vlan-based

end

QoS/MLS

We have tried to increase the queue-set values to the following:

Router#show mls qos queue-set 1

Queueset: 1

Queue     :       1       2       3       4

----------------------------------------------

buffers   :      20      40      20      20

threshold1:     400    2000    1500    1500

threshold2:     400    2000    1500    1500

reserved  :     100     100     100     100

maximum   :     400    2000    1500    1500

But we dont see any improvment.

The QoS/MLS config is as follows:

mls qos map dscp-cos  8 9 10 12 14 16 17 18 to 3

mls qos map dscp-cos  20 22 32 33 34 36 38 48 to 3

mls qos srr-queue output dscp-map queue 1 threshold 1 9 10 12 14

mls qos srr-queue output dscp-map queue 2 threshold 1 17 18 20 22

mls qos srr-queue output dscp-map queue 3 threshold 1 33 34 36 38

mls qos queue-set output 1 threshold 1 400 400 100 400

mls qos queue-set output 1 threshold 2 2000 2000 100 2000

mls qos queue-set output 1 threshold 3 1500 1500 100 1500

mls qos queue-set output 1 threshold 4 1500 1500 100 1500

mls qos queue-set output 1 buffers 20 40 20 20

mls qos

class-map match-all ef.2001

match access-group 2001

class-map match-all af3.ldp.2006

match access-group 2006

class-map match-all df.ldp.2011

match access-group 2011

!

!

policy-map qoslan_vlan901_in

class ef.2001

  set dscp ef

class af3.ldp.2006

  set dscp af31

class df.ldp.2011

  set dscp default

Router#sh ip access-lists 2011

Extended IP access list 2011

    10 permit ip any any (518944 matches)

Router#sh ip access-lists 2001

Extended IP access list 2001

    10 permit ip any any precedence critical

    20 deny ip any any (518944 matches)

Router#sh ip access-lists 2006

Extended IP access list 2006

    10 permit ip any any precedence flash

    20 deny ip any any (518944 matches)

Interface counters

ti280486534j580#sh interfaces counters errors | include Port|Fa0/2 |Gi0/1

Port        Align-Err     FCS-Err    Xmit-Err     Rcv-Err  UnderSize  OutDiscards

Fa0/2               0           0           0           0          0        20952

Gi0/1               0           0           0           0          0         2460

We are shaping the gig uplink to 100Mbps, the equipment is dropping pakets randomly and not because the shaper kicks in and starts to drop pakets.

We really need some help on how to fix this as we are seeing the same thing on many of our routers.

If we turn off the mls qos the problem goes away so it is definitly connected to the mls qos in some way.

Best regards

Magnus

Everyone's tags (4)
1 REPLY
Super Bronze

3560 and mls qos drops

Disclaimer

The   Author of this posting offers the information contained within this   posting without consideration and with the reader's understanding that   there's no implied or expressed suitability or fitness for any purpose.   Information provided is for informational purposes only and should not   be construed as rendering professional advice of any kind. Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In   no event shall Author be liable for any damages whatsoever (including,   without limitation, damages for loss of use, data or profit) arising  out  of the use or inability to use the posting's information even if  Author  has been advised of the possibility of such damage.

Posting

It's possible the reason you see the drops when QoS is enabled, but not when disabled, 3560s (and 3750s) allocate one queue's buffer resources to four queues when QoS is enabled.  If that's the issue, you might be able to mitigate by buffer tuning.

If you haven't seen it, you might want to look over: https://supportforums.cisco.com/docs/DOC-8093

795
Views
0
Helpful
1
Replies