Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3560 using 802.1q to 1841 routing question

4402 Wireless Controller (p1 to 24P G0/2)

3560- 24 port POE (G0/1 to 48P G0/2)

3560-48Port (G0/1 to 1841 F0/0)

Cisco 1841 router (F0/1 to core net)

The 4402 uses 3 dot1q vlans. I want to use the 1841 to route between the vlans as the 1841 has a firewall which is a requirement that must be used in this design. I thought I could use dot1q on the gi0/x interfaces up to the router and then utilize the firewall on the router to route traffic between the VLANS. I configured the wireless network without the router and everything works fine. I remove all the int vlan entries, install the dot1q encapsulation on the G0/x ints, create the 1841 subinterfaces and NO GO. I could be way off base on how I think this should work and since it DOESN'T work I'm looking forward to any assistance you can provide.

3560 Switches

48 port - G0/1 and G0/2

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

24 port -

g0/1

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

g0/2 Wireless 4402

switchport trunk encapsulation dot1q

switchport mode trunk

Cisco 1840 with K9-Sec Image

created sub intefaces on 1841 int f0/0

assigned dot1q vlan to each sub int

assigned ip address to each sub int

Example:

int f0/0.5

encaspulation dot1Q 3

ip address 172.31.115.1 255.255.255.0

ip helper-address 172.29.115.1

When I run a trace on the 24P G0/2 I can see an arp request go out when I attempt to ping from the wireless controller console and thats it. Your help is greatly appreciated!

Note: I have attached the configs for your viewing pleasure.

Thanks,

Scott

  • WAN Routing and Switching
261
Views
0
Helpful
0
Replies
This widget could not be displayed.