Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

3750 multicasting

I am having a problem with multicasting on 2 3750 switches, here is the Topology:

2 cisco 7200 routers configured with hsrp connected to 2 3750's running hrsp (The router interfaces are connected to vlan 202). I have another vlan configured (vlan 63) which has a server with 2 nic interfaces , configured as fault tolerant team members, connected to vlan 63.

Now that you know the topology, here is the problem:

The 7200 routers are forwarding 3 multicast groups which I am joining on both vlan int 202 and 63, pim is also enabled on both interfaces. I can see the multicast traffic on vlan 63, however, i am sporadically dropping packets. The feed appears to simply die for a few seconds then start again. If i plugged the servers directly into vlan 202 I have no problems. There seems to be a configuration issue within the 3750s. If someone has any advice I'd really appreciate it. I have copied relevant info from configs on 3750's ( the routers are managed by an extranet so I can't paste config).

I also Have a route back to the transmission source on both routers!

Switch A

interface Vlan202

ip address 192.168.203.2 255.255.255.0

ip access-group radianz in

ip pim sparse-dense-mode

ip igmp join-group 224.0.10.100

ip igmp join-group 224.0.10.101

ip igmp join-group 224.0.10.102

no ip mroute-cache

standby 202 ip 192.168.203.1

standby 202 priority 110

interface Vlan63

ip address 192.168.198.2 255.255.255.0

ip pim sparse-dense-mode

ip igmp join-group 224.0.10.100

ip igmp join-group 224.0.10.101

ip igmp join-group 224.0.10.102

ip igmp static-group 224.0.10.100

ip igmp static-group 224.0.10.101

ip igmp static-group 224.0.10.102

ip igmp query-interval 10

ip mroute-cache distributed

standby 63 ip 192.168.198.1

standby 63 priority 110

Switch B

interface Vlan202

ip address 192.168.203.3 255.255.255.0

ip access-group radianz in

ip pim sparse-dense-mode

ip igmp join-group 224.0.10.101

ip igmp join-group 224.0.10.102

ip igmp join-group 224.0.10.100

ip igmp static-group 224.0.10.102

ip igmp static-group 224.0.10.101

ip igmp static-group 224.0.10.100

ip mroute-cache distributed

standby 202 ip

standby 202 preempt

interface Vlan63

ip address 192.168.198.3 255.255.255.0

ip pim sparse-dense-mode

ip igmp join-group 224.0.10.100

ip igmp join-group 224.0.10.101

ip igmp join-group 224.0.10.102

ip igmp static-group 224.0.10.100

ip igmp static-group 224.0.10.101

ip igmp static-group 224.0.10.102

ip igmp query-interval 10

ip mroute-cache distributed

standby 63 ip

standby 63 preempt

2 REPLIES
Bronze

Re: 3750 multicasting

The issue may due to PIM may not be configured on interface ,where the interface is an source.

for example the loopback interface may be the source and the PIM enabling may be carried out on ethernet interface.

to resolve this configure the interface with the following command

(config)#IP PIM sparse-dense

Community Member

Re: 3750 multicasting

I figured out what the problem was, the IGMP query interval was set to high. I changed it to 11 and everything works perfectly. Thanks for you response.

407
Views
0
Helpful
2
Replies
CreatePlease to create content