Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3750 not passing EIGRP learned routes

Background:

|-----SITE RTR---|

| |

MPLS IMA/ATM

| |

| |

3845 2611

| |

-------3750--------

|

SERVERS

I am trying to setup an EIGRP mesh network across our MPLS network and ATM network. We have moved the ATM network off the 3845 and onto it's own router to provide greater redundancy. The problem is, the 3750 is not passing all of the routes it has learned to the 2611. This is making some odd behavior. For example, at one site that does not have a redundant ATM link I can ICMP from the remote site to the 2611 but not from the 2611 to the remote site. I am also not seeing all the networks that I should see in the routing table.

I have posted the config portions of the 3845, 3750 and 2611:

3845:

router eigrp 10

redistribute connected

redistribute static

network 10.6.6.0 0.0.0.3

network 10.10.10.8 0.0.0.3

network 10.10.10.24 0.0.0.3

network 10.10.10.32 0.0.0.3

network 10.10.10.96 0.0.0.3

network 10.10.10.100 0.0.0.3

network 10.11.11.40 0.0.0.3

network 10.11.11.44 0.0.0.3

network 10.11.11.48 0.0.0.3

network 10.11.11.52 0.0.0.3

network 10.11.11.56 0.0.0.3

no auto-summary

2611:

router eigrp 10

redistribute connected

redistribute static

network 10.6.6.4 0.0.0.3 <- Ethernet to 3750

network 10.10.10.96 0.0.0.3 <- ATM to remote site

no auto-summary

3750:

router eigrp 10

redistribute connected

redistribute static

network 10.6.6.0 0.0.0.3

network 10.6.6.4 0.0.0.3

no auto-summary

eigrp stub connected static redistributed

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: 3750 not passing EIGRP learned routes

Hello Dylan,

in your C3750 EIGRP config:

>> eigrp stub connected static redistributed

this means the device cannot pass routes to another device.

EIGRP stub = leaf router without any other device behind it.

verify if you can run EIGRP in normal mode in your C3750 (it may be possible or not depending on IOS image and SDM template on the C3750)

Hope to help

Giuseppe

14 REPLIES
Hall of Fame Super Silver

Re: 3750 not passing EIGRP learned routes

Hello Dylan,

in your C3750 EIGRP config:

>> eigrp stub connected static redistributed

this means the device cannot pass routes to another device.

EIGRP stub = leaf router without any other device behind it.

verify if you can run EIGRP in normal mode in your C3750 (it may be possible or not depending on IOS image and SDM template on the C3750)

Hope to help

Giuseppe

New Member

Re: 3750 not passing EIGRP learned routes

Giuseppe-

I think the stub is the problem as well. I cannot remove it though as my 3750 license is restricted to stub routing.

So, what do you think my options are?

Thanks

Hall of Fame Super Silver

Re: 3750 not passing EIGRP learned routes

Hello Dylan,

upgrading to an IOS image that support full EIGRP has a cost.

However, I would consider to bypass the L3 role of C3750:

you can create a L2 path that interconnects the C2611 with the upstream router so that the C2611 can receive the missing routes directly from upstream router(s).

you can use an existing vlan or you can use a new one.

Hope to help

Giuseppe

New Member

Re: 3750 not passing EIGRP learned routes

Giuseppe-

Thanks for the reply. I was thinking on the same lines. I came up with three options and have rated them by impact (greatest downtime)

1. Upgrade the 3750 image.

2. Create a new VLAN on the 3750 stack and move both upstream router ports to this vlan. Then the routers should learn EIGRP routes from eachother and from the 3750.

3. Place a cross connect between the 2611 and 3845 and add them to the eigrp 10 group.

Here are my thoughts on the three options:

Option 1 has lots of benefits (especially because I would like to upgrade the image on the swtich stack to support ssh). It should be possible to do this with little impact because all critical servers on the stack are using etherchannel. Upgrading the switch stack will make our edge devices freak as we are interface tracking them on the switch stack side. This may cause my vpn tunnels to collapse, which would be undesireable.

I am not sure if option two is a good idea. Do you know if their will be a routing imact if I am using a vlan instead of a routed switchport? Will their be any possibilites of some kind of eigrp routing loop?

Option 3 is undesireable because it uses up an interface on my routers, however it may be the best option.

Thanks for your input.

Hall of Fame Super Silver

Re: 3750 not passing EIGRP learned routes

Hello Dylan,

option 2 : L2 vlan

you create a vlan like 555 and you put on it two subinterfaces on C2611 and C3845

stop : no possibilities of loop if only two ports are in this vlan and are connected to the two routers.

this can be a temporary fix waiting for IOS upgrade.

Hope to help

Giuseppe

New Member

Re: 3750 not passing EIGRP learned routes

Would using a vlan be any slower than a routed interface though?

New Member

Hello Giuseppe Larosa

Hello Giuseppe Larosa

Please can you help regarding this.

R1--R2---R3---R4

Between R1-R2-------Area 0

R2--R3------------------Area1------- Stub area also

R3--R4------------------Eigrp-------- Redistribute applied.

on R1 --------- i can not get any Eigrp route ------------------------correct ?

now i connected 1 other router

R5---R1----------Rip

R1--------------- Redistribute also

now i am checking on R4 ------------- i am getting default route but i am not able to ping loopback on R5

Please can you tell me what is the problem here.

Re: 3750 not passing EIGRP learned routes

Hello.

Personally I think your EIGRP stub config should work fine.

What could be the problem is the lack of a redistribution metric. EIGRP needs one for most redistributions to work. Try configuring the following on the 3750:

router eigrp 10

default-metric 1544 1000 255 1 1500

Simon

New Member

Re: 3750 not passing EIGRP learned routes

I tried adding a defauly metric and that did not help.

Thanks for the tip though

Hall of Fame Super Silver

Re: 3750 not passing EIGRP learned routes

Hello Simon,

>> The problem is, the 3750 is not passing all of the routes it has learned to the 2611.

is not this a good description of an EIGRP stub router?

Hope to help

Giuseppe

Re: 3750 not passing EIGRP learned routes

Hi Giuseppe.

I did not want to appear to contest what you have written as you always seem to give out very good advice.

From the way the original description is written 'learned to the 2611' I believe EIGRP stub should work fine. As long as the 3750 is not trying to pass on any routes.

If the description was 'learned FROM the 2611' then I could understand why the EIGRP stub would be the problem.

Dylan. Can you clear it up? Does the 3750 have to pass on routes it has learned from the 2611? If so the stub is a problem.

If the 3750 ONLY has to pass on routes it is learning itself. EIGRP stub should work fine.

Simon

New Member

Re: 3750 not passing EIGRP learned routes

The 3750 is currently only passing on the vlan's on the switch and it's default route. I am not seeing anything that the 3750 has learned from other eigrp neighbors.

I am seeing the 3750 learn routes from the 2611.

Re: 3750 not passing EIGRP learned routes

Hi Dylan.

So Giuseppe is correct.

You cannot expect the 3750 to pass on routes which it has learnt from another EIGRP neighbor when it has the stub option. The reason you can't remove it is because you are only running the standard image.

You could check to see if your standard image supports route leaking, if it does this will work for your but I am doubtful the standard image will, you will know if you see the 'leak' option in the stub command:

eigrp stub connected redistributed static leak-map LEAK

Other than that you will have to think about upgrading your 3750 image, using static routing or changing the design.

Simon

New Member

I use eigrp leak maps to get

I use eigrp leak maps to get around the limitation. It works great. I wish i could figure out how to do it in ospf though!

2002
Views
0
Helpful
14
Replies