Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

3750 TCP retransmit problem

I have a problem with TCP retransmits between a server on a 4507 and clients on 3750 24 port POE.

Previously I had the following setup

Server (fibre gig connected) ->1000-> 4507 (6 port gig card) ->100-> WS-C3550-24 ->100->7204 (NPE200)->100->WS-C2924C-XL->100->PC

This ran fine, the users are uploading big Excel SS's from the server and they could open a SS in 2 mins. Sniffers on the network showed no TCP retransmits

I now have

Server (fibre gig connected) ->1000-> 4507 (6 port gig card) ->1000-> WS-C3750-24P ->100->PC

The users now take 20 mins to open the same SS and the sniffer shows 10 -30 TCP retransmits / second

When I put a sniffer on each end of the fibre between the 4500 and 3700 (mirrored to 100Mb copper ports), it indicates that I am losing packets over the link

I have check for duplex issues and there are none

I cannot see any errored packets or queue drops

I have routed the traffic over different interfaces and fibres and get the same issues

If I connect the PC to a 100mb port on the same 4500 as the server it works fine

1 REPLY
Hall of Fame Super Silver

Re: 3750 TCP retransmit problem

Chris

If the PC connected to a 100 mb port on the 4500 works fine, then it sure sounds like the issue is on the link between the 4500 and the 3750 or is in the 3750. I know that you state that you have checked for duplex issues and did not find any. But the symptoms sure do sound like a duplex mismatch - or maybe congestion in 3750. Could you post the output of show interface for the link on the 4500 and the 3750?

HTH

Rick

275
Views
0
Helpful
1
Replies