Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

3845 configuring E1

Hello,

I have to configure a router 3845 with one NM-HDV2-2T1/E1 and two PVDM2-64. I have typed the following commands:

(router-config)# card type e1 1 1

(router-config)# controller e1 1/0

(config-controller)# pri-group timeslots 1-31

And the router shows the following message in console:

% Not enough DSP resources available to configure pri-group on controller E1 1/0

% The remaining dsp resources are enough for 0 time slots.

% For current codec complexity, 2 extra dsp(s) are required to create this voice port.

Does anyone know what can I do? The only solution is to add more DSPs?

Thanks in advance and best regards.

Luis Elvira

1 ACCEPTED SOLUTION

Accepted Solutions

Re: 3845 configuring E1

You will need to configure dspfarm under the appropriate voice-card for DSP sharing.

Configuration of the dspfarm command enters DSP resources into a DSP resource pool. Those DSP resources are then available to process voice traffic on a different network module or voice/WAN interface card (VWIC).

voice-card 0

dspfarm

Try configuring the pri-group one you have enabled dsp resource sharing as above.

HTH

Allan.

3 REPLIES

Re: 3845 configuring E1

Hi Luis,

If you have 128 DSP channels, and only 30 timeslots to be configured, you should have plenty of DSP resources available.

I would guess that you've got a lot of analog ports (FXS, FXO, or E&M), which use 1 DSP channel each - or maybe you have a DSP Farm set up for conferencing on the router, and you've just allocated all the DSP resources already.

Could you post your configuration here so that I can have a look through it?

Kind regards

Graeme

New Member

Re: 3845 configuring E1

BETAR01#sh run

Building configuration...

Current configuration : 2659 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BETAR01

!

boot-start-marker

boot-end-marker

!

card type e1 1 1

logging buffered 100000 informational

enable password cisco

!

no network-clock-participate slot 1

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

no ip domain lookup

ip domain name yourdomain.com

isdn switch-type primary-qsig

isdn voice-call-failure 0

voice-card 0

no dspfarm

!

voice-card 1

no dspfarm

!

!

!

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco

h323

!

!

voice class codec 1

codec preference 2 g729r8

!

!

!

!

!

!

!

!

voice translation-rule 1

rule 1 reject /^.*/

!

!

voice translation-profile call_block_profile

translate calling 1

!

!

!

!

username cisco password 0 cisco

!

!

controller E1 1/0

framing NO-CRC4

description ENLACE Q.SIG

!

controller E1 1/1

!

!

!

interface Loopback0

description Interface IP VoIP

ip address 172.27.127.2 255.255.255.255

no ip redirects

no ip proxy-arp

h323-gateway voip interface

h323-gateway voip id MAAgk1 ipaddr 172.26.0.41 1719

h323-gateway voip h323-id BETAR01@repsol.com

h323-gateway voip tech-prefix 1#

h323-gateway voip bind srcaddr 172.27.127.2

!

interface GigabitEthernet0/0

ip address 172.27.88.9 255.255.252.0

no ip redirects

no ip proxy-arp

duplex auto

speed auto

media-type rj45

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

media-type rj45

!

router eigrp 1

network 172.27.0.0

auto-summary

no eigrp log-neighbor-changes

!

ip classless

!

!

no ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

control-plane

!

!

!

!

!

dial-peer cor custom

!

!

!

dial-peer voice 10 pots

call-block translation-profile incoming call_block_profile

call-block disconnect-cause incoming call-reject

incoming called-number 634[0,2]T

direct-inward-dial

!

dial-peer voice 85 pots

incoming called-number .

direct-inward-dial

!

dial-peer voice 100 voip

destination-pattern 6T

voice-class codec 1

session target ras

dtmf-relay h245-alphanumeric

!

dial-peer voice 200 voip

voice-class codec 1

incoming called-number .

dtmf-relay h245-alphanumeric

!

gateway

timer receive-rtp 1200

!

!

!

line con 0

login local

stopbits 1

line aux 0

stopbits 1

line vty 0 4

exec-timeout 100 0

privilege level 15

login local

transport input telnet ssh

escape-character 18

line vty 5 15

exec-timeout 100 0

privilege level 15

login local

transport input telnet ssh

escape-character 18

!

scheduler allocate 20000 1000

!

end

BETAR01#

Re: 3845 configuring E1

You will need to configure dspfarm under the appropriate voice-card for DSP sharing.

Configuration of the dspfarm command enters DSP resources into a DSP resource pool. Those DSP resources are then available to process voice traffic on a different network module or voice/WAN interface card (VWIC).

voice-card 0

dspfarm

Try configuring the pri-group one you have enabled dsp resource sharing as above.

HTH

Allan.

300
Views
0
Helpful
3
Replies
CreatePlease to create content