Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

3G as back up link for the MPLS network

Dear All,

This is with reference to 3G as backup link over MPLS network,we have to configure the 3G as back up for the MPLS leased line.So we have already configured the necessary configurations in router and
configuration form ISP side also is done.This secondary link is became up once the primary is down. But it is not connecting to our MPLS-VPN network and it is connecting to internet. The negotiated IP have to assign as a private    for the cellular interface but
it is assigned as a public ip address.We have attached the output cellular interface configuration of "" and "sh cellular ". 
Please help us to resolve the issue.

cellular interface configuration

-------------------------------------------------------

interface Cellular0/3/0

ip address negotiated

encapsulation ppp

dialer in-band

dialer idle-timeout 10

dialer string gsm

dialer-group 1

async mode interactive

ppp chap hostname (username)

ppp chap password 0 (Password)

!

interface Dialer0

ip address negotiated

encapsulation ppp

dialer pool 1

dialer idle-timeout 10

dialer string gsm

dialer-group 1

ppp chap hostname (username)

ppp chap password 0 (Password)

!

ip forward-protocol nd

!

!

i

ip route 0.0.0.0 0.0.0.0 172.19.98.26

ip route 0.0.0.0 0.0.0.0 Cellular0/3/0 200

ip route 10.0.0.0 255.0.0.0 172.19.98.26

!

----------------------------------------------------------

Router#sh cellular 0/3/0 all

Hardware Information

====================

Modem Firmware Version = K1_0_2_18AP C:/WS/F

Modem Firmware built = 12/29/08

Hardware Version = 1.0

International Mobile Subscriber Identity (IMSI) = 404663200059012

International Mobile Equipment Identity (IMEI) = 011955000045676

Factory Serial Number (FSN) = D66089014071021

Modem Status = Online

Current Modem Temperature = 38 deg C, State = Normal

Profile Information

====================

Profile 1 = INACTIVE*

--------

PDP Type = IPv4

Access Point Name (APN) = bsnlvpn(APN name)

Authentication = CHAP

Username: (username).in, Password: (password)

Profile 2 = INACTIVE

--------

PDP Type = IPv4

Access Point Name (APN) = bsnlvpn

Authentication = CHAP

Username: (username).in, Password: (password)

* - Default profile

Regards

Gopal

3 REPLIES
Silver

3G as back up link for the MPLS network

If I understand correctly, your issue is that the cellular interface got a public IP address, instead of the private one?

When you configure 'ip address negotiated', the interface will accept the IP address sent by the ISP.

If you want to use the cellular interface as secondary link, you will have to agree with your ISP on the private IP address to assign. The ISP will also have to associate the IP with your MPLS network.

In alternative, you can create a tunnel over the cellular interface (with the public IP) where you can assign the private address.

Regards

Marco

New Member

3G as back up link for the MPLS network

Hi

Thanks for your update.!

Is there any configuration changes required on router side for 3G back up? .

What are the configuration changes required for tunnel over the cellular interface (with the public IP).

Regards

Gopal

Silver

3G as back up link for the MPLS network

Gopal, I think you need to discuss this with your ISP.

What you are trying to do can be done, but it requires specific configuration on ISP side.

Scenario 1: The ISP will assign you a private address that you previously agreed on.

In this case, no configuration changes are needed on your router.

Scenario 2: The IP will not be automatically assigned.

You will have to configure manually the IP under the dialer/cellular interface.

Scenario 3: A public IP will be assigned by the ISP. You want to build a tunnel to a remote router.

On your router, you will have to define a tunnel that use the public IP of the cellular interface, and a public IP of your remote router.

The tunnel can be GRE or VPN, depending on your needs.

Note: in your config, you are using both cellular and dialer interface.

Usually this is not needed, the whole configuration can be done on the cellular interface itself.

However, you can use the dialer interface, but it's not a good practice to add commands in both interfaces, e.g. 'ip address negotiated'

716
Views
0
Helpful
3
Replies