Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

50/50 Dropped Pkts

Here is the scenario: dropping excactly every other ping from default gateway to L3 directly connected server, but there is a switch between the server and the router. All Cisco devicse are hybrid 6500's. No load balancing or Ether Channel is configured in any switches or routers, or on the dual-threaded servers. Servers have redundant links to two switch with PFC's, to two with MSFC's running HSRP between them. The topology could best be described as a box. I have determined that the server's default gateway is pointed to the wrong vlan for the HSRP Virtual IP and have directed to reconfigure this to the appropriate Virtual IP for their Vlan.

The question is that I am attempting to explain the exact symmetery to the packet loss that I am experinencing with the incorrect default gateway on the servers. Seems to me that the server would not require a default gateway to return my ICMP requests, given that we are on the same subnet, and would return all pings. Anybody got a feasible explanation?

1 ACCEPTED SOLUTION

Accepted Solutions
Blue

Re: 50/50 Dropped Pkts

Steven,

The other explanation for this symptom would be a switch port configured as an etherchannel that should not be. The switch is load balancing the traffic out a pair of ports, but only one is actually connected to the correct server.

Dave

3 REPLIES
Blue

Re: 50/50 Dropped Pkts

Steven,

You are correct, no default gateway is needed for same subnet traffic.

I would suspect that the server is set for load balancing between the NICs, and that one of your cables is working one way. Try disconnecting the NICs one at a time, and check ping response.

Dave

New Member

Re: 50/50 Dropped Pkts

No, the second nic is set for a standby mode. I agree though, that was my very first thought as well, because we do also have teamed nic's in this environment and that behavior seems consistent with that theory.

The other problem is that these nics connect to two L2 ports on a pair of 6500's, who in turn connect to two more 6500's w/msfc's. All NICs and connected are in the same subnet and wouldnt have any reason (barring a server mis-configuration) to drop any pings.

Blue

Re: 50/50 Dropped Pkts

Steven,

The other explanation for this symptom would be a switch port configured as an etherchannel that should not be. The switch is load balancing the traffic out a pair of ports, but only one is actually connected to the correct server.

Dave

106
Views
5
Helpful
3
Replies