Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

6to4 tunneling issues

have the following setup:

PC---fa0/0-Router1-fa0/1---fa0/0-Router2-fa0/1---PC

and am trying to get 6to4 tunnels happening between the two routers but

to no avail. I believe its something in the route in place but for the

life of me I cant spot the error, as the error I get when I try to ping

from a PC to the non-directly attached router I get "request timed out"

errors

It might be a tunnel problem as the destination comes up as "UNKNOWN"

Can someone please help!!! Ive got GRE tunneling and manual tunnels

working, but need to test this config (6to4 tunnels) as well.

Configs as follows:

Router1#sh run

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router1

!

boot-start-marker

boot-end-marker

!

memory-size iomem 10

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

!

ip cef

ipv6 unicast-routing

!

interface Tunnel0

no ip address

no ip redirects

ipv6 address 2002:C0A8:6301::1/64

tunnel source FastEthernet0/1

tunnel mode ipv6ip 6to4

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

ipv6 address 2002:C0A8:6301:1::1/64

ipv6 enable

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

ip address 192.168.99.1 255.255.255.0

duplex auto

speed auto

ipv6 enable

!

interface Serial0/1

no ip address

shutdown

!

ip http server

no ip http secure-server

ip classless

!

ipv6 route 2002::/16 Tunnel0

!

line con 0

line aux 0

line vty 0 4

!

end

Router2#sh run

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router2

!

boot-start-marker

boot-end-marker

!

!

memory-size iomem 10

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

!

ip cef

ipv6 unicast-routing

!

interface Tunnel0

no ip address

no ip redirects

ipv6 address 2002:C0A8:2101::1/64

tunnel source FastEthernet0/0

tunnel mode ipv6ip 6to4

!

interface FastEthernet0/0

ip address 192.168.33.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface BRI0/0

no ip address

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

ipv6 address 2002:C0A8:2101:1::1/64

ipv6 enable

!

interface Serial0/1

no ip address

shutdown

!

ip http server

no ip http secure-server

ip classless

!

ipv6 route 2002::/16 Tunnel0

!

line con 0

line aux 0

line vty 0 4

!

end

Configs attached include the sh route and sh int tunnel 0 commands as well as the router configs

1 REPLY
Cisco Employee

Re: 6to4 tunneling issues

The issue is that fa0/1 on router1 and fa0/0 on router2 are not on the same ipv4 subnet. Bear in mind that ipv4 connectivity must be established for ipv6 traffic to be transported in an ipv4 tunnel.

Since the two routers are back to back, change the ip address on fa0/0 of router2 to 192.168.99.2 and the ipv6 address of tu0 to ipv6 address 2002:C0A8:6302::1/64.

You will also need to change the ipv6 address of fa0/1 to 2002:C0A8:6302:1::1/64 on router2 and the connected PC.

Hope this helps,

Harold Ritter
Sr. Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México 
Paseo de la Reforma 222 Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
174
Views
0
Helpful
1
Replies