Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

7200 NPE-G1 boot loader crashes

Hi

I have a pair of old c7200s with NPE-G1/256MB ram. I tried to install IOS 15.2(4)S4 on them. The bootloader (c7200-kboot-mz.152-4.S4.bin) crashes. After this the router boots the actual IOS image which seems to work fine.

The routers are only used in the lab so this is not a big problem, but I'm just curious of why does this happen. Should I skip the bootloader entirely and point the "boot bootldr" to ios image instead?

The bootldr and ios are located on disk2 (cf card) because the bootloader does not fit into bootflash and I don't want to delete the old bootloader.

Excerpt from bootloader errors at boot (from console):

Readonly ROMMON initialized

Self decompressing the image : #################################################################################################################### [OK]

%ALIGN-1-FATAL: Illegal access to a low address 12:45:11 UTC Wed Feb 26 2014
addr=0x2A, pc=0x607D169Cz , ra=0x607D18C0z , sp=0x6E2D1C40

%ALIGN-1-FATAL: Illegal access to a low address 12:45:11 UTC Wed Feb 26 2014
addr=0x2A, pc=0x607D169Cz , ra=0x607D18C0z , sp=0x6E2D1C40


12:45:11 UTC Wed Feb 26 2014: TLB (store) exception, CPU signal 10, PC = 0x607D169C

--------------------------------------------------------------------
   Possible software fault. Upon recurrence, please collect
   crashinfo, "show tech" and contact Cisco Technical Support.
--------------------------------------------------------------------


This continues until:


No warm reboot Storage
*** System received a Bus Error exception ***
signal= 0xa, code= 0x40c, context= 0x619acf94
  PC = 0x607d169c, SP = 0x6e2d1c40, RA = 0x607d18c0
  Cause Reg = 0x0000040c, Status Reg = 0x3400e103

System Bootstrap, Version 12.3(4r)T1, RELEASE SOFTWARE (fc1)
TAC Support: http://www.cisco.com/tac
Copyright (c) 2003 by cisco Systems, Inc.
C7200 platform with 262144 Kbytes of main memory


Readonly ROMMON initialized

Self decompressing the image : ################################################################################################################################################################################################################################################################################################################################################################################################################################################# [OK]

And the IOS boots fine.


Thanks

Everyone's tags (3)
369
Views
0
Helpful
0
Replies
CreatePlease to create content