Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

ar
New Member

7200 NPE-G1 Built -in GE interface LLQ Problem

Hi Guys.

I   am trying to attach an LLQ policy to my 7200 Gigabit Ethernet   sub-interface. I cant seem to attach the policy and giving me an  error.

Im using NPE-G1  GE interface:

Im getting the error below:

(config-subif)#service-policy output  8M

user-defined classes with queueing features are not allowed in a service-policy at sub-interface/pvc

in conjunction with session based queueing policy

policy-map 8M

  class class-default

    shape average 8000000

   service-policy QOS

policy-map QOS

  class VOICE

    priority percent 60

  class  NET-MGMT

    bandwidth remaining percent 5

  class MISSION-CRITICAL

    bandwidth remaining percent 20

But I can apply this policy on a different sub-interface.

Weird problem.

Need your input.

thanks

4 REPLIES

7200 NPE-G1 Built -in GE interface LLQ Problem

please show the running configuration for the main interface and a subif.

ar
New Member

Re: 7200 NPE-G1 Built -in GE interface LLQ Problem

Main interface:

scription Nextep Interconnect 10M [SL01316W]
mtu 1600
bandwidth 10000
no ip address
load-interval 30
media-type rj45
speed auto
duplex auto
no negotiation auto

interface GigabitEthernet0/2

mtu 1600
bandwidth 10000
no ip address
load-interval 30
media-type rj45
speed auto
duplex auto
no negotiation auto

Target sub-interface facing LAC which has an error:

interface GigabitEthernet0/2.1500
bandwidth 8000
encapsulation dot1Q 1500

no cdp enable

RTR01(config-subif)#service-policy output 8M      
user-defined classes with queueing features are not allowed in a service-policy at sub-interface/pvc
in conjunction with session based queueing policy

Tested with other sub-interface and no error:

interface GigabitEthernet0/2.1518
  bandwidth 1000
encapsulation dot1Q 1518

ip mtu 1500
ip flow ingress
ip flow egress
flow-sampler netflow-sampling
no cdp enable
service-policy output 8M

RTR01(config-subif)#do sho policy-map int gi0/2.1518
GigabitEthernet0/2.1518

  Service-policy output: 8M

    Class-map: class-default (match-any)
      2313 packets, 216535 bytes
      30 second offered rate 28000 bps, drop rate 0 bps
      Match: any
        2313 packets, 216535 bytes
        30 second rate 28000 bps
      Queueing
      queue limit 2000 packets
      (queue depth/total drops/no-buffer drops) 0/0/0
      (pkts output/bytes output) 2313/216535
      shape (average) cir 8000000, bc 32000, be 32000
      target shape rate 8000000

      Service-policy : QOS

        queue stats for all priority classes: 

Re: 7200 NPE-G1 Built -in GE interface LLQ Problem

I can imagine that your subif GigabitEthernet0/2.1500 had earlier  a different configuration, then you deleted it completely, and then re-created again with a new configuration. Some configuration can be still applied to this subif bit it will not be shown in a configuration.

ar
New Member

7200 NPE-G1 Built -in GE interface LLQ Problem

My setup here is:

LNS has individual QOS for authenticated subscribers.

Then one GE interface on that LNS is connected to the LAC.

Then I am applying a different aggregate shaper on this interface aside from the individual connected subs on LNS.

My guess is:

You cant really do QOS on the interfacing LAC on the same router together with subs shaper policy.

I hope someone can confirm it.

494
Views
0
Helpful
4
Replies
CreatePlease to create content