Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

7206 vxr throttle counts increase and input drops - what does THROTTLE mean

slot0:c7200-ds-mz.121-18.bin

============================

FastEthernet2/1 is up, line protocol is up

Hardware is i82543 (Livengood), address is 0003.31da.3439 (bia 0003.31da.3439)

Description: Core Connect IP only

Internet address is 10.192.135.36/27

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 1w0d

Input queue: 6/75/467587/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 652000 bits/sec, 244 packets/sec

5 minute output rate 276000 bits/sec, 322 packets/sec

109320553 packets input, 1637571015 bytes

Received 0 broadcasts, 0 runts, 0 giants, 445166 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

134931783 packets output, 3817728594 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

======================

This interface is connected to a CAT 3750 Gi1/0/22 and it's counters are fine:

GigabitEthernet1/0/22 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 000d.293b.7a96 (bia 000d.293b.7a96)

Description: IP Access Link to CCF7206 Fa2/1

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:31, output 00:00:02, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 302000 bits/sec, 279 packets/sec

5 minute output rate 631000 bits/sec, 213 packets/sec

2645840927 packets input, 196628550 bytes, 0 no buffer

Received 1503641 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 1487147 multicast, 0 pause input

0 input packets with dribble condition detected

1982685323 packets output, 795701522 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

8 REPLIES

Re: 7206 vxr throttle counts increase and input drops - what doe

Hi Friend,

The throttles counter increments when a system buffer is available, but the interface already has the maximum number of packets waiting to be processed in the input hold queue The router temporarily disables the interface to give the interface time to catch up and process the already enqueued packets.

You can troubleshoot throttles by determining the root cause of why a high number of packets are being process switched.

HTH, if yes please rate the post.

Ankur

New Member

Re: 7206 vxr throttle counts increase and input drops - what doe

Ankur,

1. Which information did you look at to say that a high number of packets are process switced?

2. Can you give some pointers / links . urls where I can find out procedure to troubleshoot why a high number of packets are being process switched.

Re: 7206 vxr throttle counts increase and input drops - what doe

Hi Friend,

Throttles could be one of the results of process switched which I tried to put in my previous post but looking at the output which you posted cannot be sure if the packtes are process switched.

Can you post the output of "show interfaces switching " from the interface where you see high throttles counters?

Regards,

Ankur

New Member

Re: 7206 vxr throttle counts increase and input drops - what doe

I am yet to get the output of show interface fa2/1 switching:

=====================================================

========================

Partial config for fa2/1:

========================

interface FastEthernet2/1

description Core Connect IP only

ip address 10.192.135.36 255.255.255.224

ip access-group 109 in

ip access-group blockblaster-SH-1 out

no ip unreachables

ip route-cache policy

ip route-cache flow

ip ospf cost 20

ip ospf priority 100

ip policy route-map from-iims

speed 100

full-duplex

====================================================

route-map from-iims permit 10

match ip address 166

set ip next-hop 10.255.194.2

!

route-map from-iims permit 20

match ip address 167

set ip next-hop 10.255.194.2

!

route-map from-iims permit 50

match ip address 170

set ip next-hop 10.255.194.2

!

route-map from-iims permit 70

match ip address 172

set ip next-hop 10.255.194.2

!

route-map from-iims permit 80

match ip address 173

set ip next-hop 10.255.194.2

!

route-map from-iims permit 90

match ip address 174

set ip next-hop 10.255.194.2

!

route-map from-iims permit 110

match ip address 176

set ip next-hop 10.255.194.2

!

route-map from-iims permit 130

match ip address 179

set ip next-hop 10.255.194.2

!

route-map from-iims permit 140

match ip address 180

set ip next-hop 10.255.194.2

!

route-map from-iims permit 150

match ip address 181

set ip next-hop 10.255.194.2

!

route-map from-iims permit 160

match ip address 182

set ip next-hop 10.255.194.2

!

route-map from-iims permit 170

match ip address 183

set ip next-hop 10.255.194.2

!

route-map from-iims permit 180

match ip address 184

set ip next-hop 10.255.194.2

!

route-map from-iims permit 190

match ip address 185

set ip next-hop 10.255.194.2

!

====================================================

access-list 109 deny ip host 48.51.48.48 any

access-list 109 deny ip any host 48.51.48.48

access-list 109 permit ip any any

Re: 7206 vxr throttle counts increase and input drops - what doe

Hi Friend,

I see some route map configured can you please confirm if your cpu utilization is also high?

You can check that from "sh proc cpu" and if possible paste the output.

Have you disabled CEF by anychance on your router?

Regards,

Ankur

New Member

Re: 7206 vxr throttle counts increase and input drops - what doe

SHOW PROC CPU and SHOW RUNNING_CONFIG attached. CPU utilisation is low.

New Member

Re: 7206 vxr throttle counts increase and input drops - what doe

CCF7206#show interface fastethernet 2/1 switching

FastEthernet2/1 Core Connect IP only

Throttle count 445579

Drops RP 468012 SP 0

SPD Flushes Fast 0 SSE 0

SPD Aggress Fast 0

SPD Priority Inputs 1644 Drops 0

Protocol Path Pkts In Chars In Pkts Out Chars Out

Other Process 0 0 266439 15986340

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

IP Process 1462884 600345083 1531106 640448817

Cache misses 0

Fast 488498902 3603015881 611791220 3096983339

Auton/SSE 0 0 0 0

DEC MOP Process 4362 335874 4423 340571

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

Spanning Tree Process 1304956 69162668 0 0

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

ARP Process 376 22560 3646 218760

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

CDP Process 43830 17970300 44406 14121108

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

CCF7206#

====================================================

CCF7206#show interface fastethernet 2/1 switching

FastEthernet2/1 Core Connect IP only

Throttle count 454800

Drops RP 477695 SP 0

SPD Flushes Fast 0 SSE 0

SPD Aggress Fast 0

SPD Priority Inputs 1644 Drops 0

Protocol Path Pkts In Chars In Pkts Out Chars Out

Other Process 0 0 266743 16004580

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

IP Process 1464419 601013236 1533200 641195796

Cache misses 0

Fast 490457765 4232593974 614359216 3520781845

Auton/SSE 0 0 0 0

DEC MOP Process 4367 336259 4428 340956

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

Spanning Tree Process 1306453 69242009 0 0

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

ARP Process 378 22680 3655 219300

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

CDP Process 43879 17990390 44457 14137326

Cache misses 0

Fast 0 0 0 0

Auton/SSE 0 0 0 0

Re: 7206 vxr throttle counts increase and input drops - what doe

Hi Friend,

I see lot of process switching in the interface switching output you posted

For example

IP Process 1464419 601013236 1533200 641195796

Now as far as the configuration goes I think "ip route-cache cef" is already enabled on your interface as I do not see in the configuration which means it is enabled bydefault but still you can apply this commands on this interface and see if it reduces the process switching.

Also have a look at this link as how to verify CEF

http://www.cisco.com/warp/public/105/cef_whichpath.html#backinfo

Regards,

Ankur

608
Views
13
Helpful
8
Replies
CreatePlease login to create content