Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

7600 ES card shaping on VLAN

i am trying to apply Hierarchical policymap under a inter vlan it gives an error:

PE4(config)#int vlan 299

PE4(config-if)#service-policy output testce

Hierarchical policymap is not supported for this interface. Configuration failed!

here is the policy-map:

policy-map testce

class class-default

police 450000000

service-policy pe-ce-450m

Nested policy map:

policy-map pe-ce-450m

class pe-ce-450m-s

bandwidth percent 4

random-detect

random-detect precedence 0 300 1000 1

random-detect precedence 1 300 1000 1

class pe-ce-450m-p

bandwidth percent 30

random-detect

random-detect precedence 2 100 150 1

random-detect precedence 3 750 1000 1

random-detect precedence 6 750 1000 1

random-detect precedence 7 750 1000 1

class pe-ce-450m-nrt

police cir 292496000 bc 146248 be 4470 conform-action transmit exceed-action drop violate-action drop

*********************

is i use shaping than it says it is not supported.

policy-map testce

class class-default

shape average 450000000

service-policy pe-ce-450m -> same as above...

PE4(config)#int vlan 299

PE4(config-if)#service-policy output testce

shape average command is not supported in output direction for this interface

Configuration failed!

how can we apply shaping on VLAN interface... subinterface configuration it works but not on VLAN interface.

5 REPLIES
Hall of Fame Super Bronze

Re: 7600 ES card shaping on VLAN

You are limited on features by applying the service-policy under the SVI

This document explains what features are available under the SVI and which aren't

http://www.cisco.com/en/US/docs/routers/7600/install_config/ES40_config_guide/es40_chap7.html#wp1352261

HTH,

__

Edison.

New Member

Re: 7600 ES card shaping on VLAN

Thanks.

Which card will offer H-QoS with SVI?

I have a situation where there are 2 trunk ports, connected two VPN Conc (active/backup), with SVI switchover is automatic, but need H-QoS to work, an card that car support it? IOS?

Hall of Fame Super Bronze

Re: 7600 ES card shaping on VLAN

Any configuration made outside the 'specialty' module would be using the PFC QoS which is quite limited:

http://www.cisco.com/en/US/docs/routers/7600/ios/12.2SR/configuration/guide/qos.html

You need to come up with a design by using subinterfaces on the line card.

__

Edison.

New Member

Re: 7600 ES card shaping on VLAN

ok.

following is what i think of, i don't like it but it may work:

two identical interfaces, 1 is shut down like primary is up and backup is down.

using EEM i track (using IP SLA) the primary as soon as it goes down i bring g2/16 up, and if EEM tracking disvocers 2/15 is backup it shouts down the g2/16 (which is backup).

cons: identical IP's on the two different interfaces, one is always shutdown.

let me know your thoughts. appereciate your help !~

interface GigabitEthernet2/15

description primary interface

no ip address

speed 1000

interface GigabitEthernet2/15.3455

encapsulation dot1Q 3455

ip vrf forwarding CPE-MGT

ip address 10.218.160.1 255.255.255.254

interface GigabitEthernet2/16

description backup interfaces

no ip address

shutdown

!

interface GigabitEthernet2/16.3455

encapsulation dot1Q 3455

ip vrf forwarding CPE-MGT

ip address 10.218.160.1 255.255.255.254

!

Hall of Fame Super Bronze

Re: 7600 ES card shaping on VLAN

For this kind of design, you should be using 'service instance'.

This URL should provide information on the subject

http://www.cisco.com/en/US/docs/routers/7600/install_config/ES40_config_guide/es40_chap4.html#wp1433480

HTH,

__

Edison.

261
Views
14
Helpful
5
Replies
CreatePlease to create content