Cisco Support Community
Community Member

802.1p on 3750G-24TS

Hi all,

I have some problems for the configuration SW 3750 support 802.1p. Please help me

I have 3 VLAN (10,20,30) on this switch and i want to apply 3 values CoS on them, for example 6 for VLAN10, 5 for VLAN 20 and 4 for VLAN30 but i don't know how to build it.

Please tell me any suggestion or any helps.



Re: 802.1p on 3750G-24TS

you can do something like this

ip access-list extended vlan10

permit ip any

ip access-list extended vlan20

permit ip any

ip access-list extended vlan30

permit ip any

class-map match-all VLAN10

match access-group name vlan10

class-map match-all VLAN20

match access-group name vlan20

class-map match-all VLAN30

match access-group name vlan30

policy-map set-cos

class VLAN10

set precendence 6

class VLAN20

set precendence 5

class VLAN30

set precendence 4

Apply this policy on the interfaces

interface fa0/1

service-policy input set-cos

HTH, rate if it does


Community Member

Re: 802.1p on 3750G-24TS

Thanks so much for your solution but I have also a question for you:

I want to work on 802.1p, it means apply COS to .1Q or ISL header but why you used "set precedence" that in IP header.

Thanks for your time and your answer

CreatePlease to create content