Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

802.1q native VLAN

Is this configuration okay or do I need an ip address assigned to the native vlan on the main interface?

interface Ethernet0/0

encapsulation dot1q 151 native

!

interface FastEthernet0/0.1

description LAN

encapsulation dot1Q 10

ip address 10.160.1.1 255.255.240.0

!

interface FastEthernet0/0.2

description Voice

encapsulation dot1Q 31

ip address 10.160.32.1 255.255.252.0

!

interface FastEthernet0/0.3

description B&G

encapsulation dot1Q 32

ip address 10.160.36.1 255.255.252.0

!

interface FastEthernet0/0.4

description Management

encapsulation dot1Q 150

ip address 10.160.224.1 255.255.240.0

2 REPLIES
Hall of Fame Super Silver

Re: 802.1q native VLAN

Patrick

You need an IP address for traffic in the native VLAN. I believe that if you are going to use the encapsulation ... native command, that you should create a subinterface, move the encapsulation ... native to the subinterface, and assign an appropriate IP address to the subinterface.

I assume that it is a typo but I notice that you specified Ethernet0/0 for the physical interface but specified FastEthernet0/0 for the subinterfaces.

HTH

Rick

New Member

Re: 802.1q native VLAN

That is what I thought but I couldn't verify.

91
Views
5
Helpful
2
Replies