Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

827 ADSL Config

I need to connect 827 to ADSL with a static WAN IP. I am having a problem with NAT. I need to nat private scope to one public. Bellow is my config.

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname r1

!

enable secret 5 *******

!

ip subnet-zero

ip name-server 216.165.129.157

ip name-server 134.215.200.126

!

!

!

!

interface Ethernet0

ip address 192.168.35.1 255.255.255.0

ip nat inside

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description *** To WR ***

ip address 60.10.32.90 255.255.255.252

pvc 0/35

encapsulation aal5snap

!

!

ip nat inside source list 1 interface ATM0.1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 60.10.32.89

ip http server

!

!

access-list 1 permit 192.168.35.0 0.0.0.255 log

!

line con 0

stopbits 1

line vty 0 4

exec-timeout 0 0

password 7 *********

login

!

scheduler max-task-time 5000

end

3 REPLIES
VIP Purple

Re: 827 ADSL Config

Hello,

your config looks ok, you are just missing one thing:

interface ATM0.1 point-to-point

description *** To WR ***

ip address 60.10.32.90 255.255.255.252

-->ip nat outside

pvc 0/35

encapsulation aal5snap

Can you add this to your configuration and see if that works ?

Regards,

GP

New Member

Re: 827 ADSL Config

You are right, I left that out. I will put this and let you know. Thanks.

New Member

Re: 827 ADSL Config

GP, That was it. Thanks a bunch.

95
Views
0
Helpful
3
Replies
CreatePlease to create content