Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

827 gets ip and dns from server but interface does not work

I have an 827 (I know its old)  I have everything working from the router its self, I can ping out to ip and to domain names everything works it get the ip and dns dynamicly from the isp (verizon.)

However the interfaces do not get the dns server info i can't ping out to a domain name though it.  I can ping out to an outside ip address.

What did i miss in this, I know i am so close to getting this working.

The config follows (edited for password removal and i will secure it once this is working):

version 12.4
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
vpdn enable
!
!
!
!
!
interface Ethernet0
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0.35 point-to-point
pvc 0/35
  pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname (removed)
ppp chap password (removed)
ppp pap sent-username (removed)
ppp ipcp dns request accept
ppp ipcp wins request accept
ppp ipcp route default
ppp ipcp address accept
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
ip nat inside source list 10 interface Dialer1 overload
!
access-list 10 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line con 0
logging synchronous
stopbits 1
line vty 0 4
login
!
scheduler max-task-time 5000
scheduler interval 5000
end

this is what i get if i ping from another device through it

Internet-Router#ping www.google.com
Translating "www.google.com"...domain server (192.168.0.1)
% Unrecognized host or address, or protocol not running.

but if i go from the router its self it works fine

Everyone's tags (6)
2 REPLIES
New Member

Re: 827 gets ip and dns from server but interface does not work

Never mind, silly me was missing the ip dns server command

New Member

Re: 827 gets ip and dns from server but interface does not work

try addint the IP name-server command to point to another DNS server from global configuration mode:

en

config t

ip name-server 4.1.1.1

end

689
Views
0
Helpful
2
Replies
CreatePlease login to create content