Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

837 and DNS/Routing Problem

Hello everybody,

I try to connect a 837 Router by an ADSL connection via a DSLAM to a 2610. (using PPPoA) On the network side I have a separate DNS running which can be reached from the 2610 (working as NAS) The ADSL connection seems to work properly. When I test the connection with the integrated tool in SDM I get the following error message:

"No configured DNS server(s) are routable through the selected interface. "

In details I can see that providing the IP from the NAS by IPCP seems to work. So it looks like a routing problem ?

Here is the config of the 837:

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ADSL-Router

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret xxxxx

enable password xxxxx

!

no aaa new-model

ip subnet-zero

no ip routing

!

!

ip dhcp excluded-address 10.10.10.1

ip dhcp excluded-address 10.10.10.6 10.10.10.254

!

ip dhcp pool Local

import all

network 10.10.10.0 255.255.255.0

lease infinite

!

!

ip domain lookup source-interface ATM0.2

ip ips po max-events 100

no ftp-server write-enable

!

!

no crypto isakmp ccm

!

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.0

no ip route-cache

hold-queue 100 out

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.2 point-to-point

no ip route-cache

pvc 1/32

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface FastEthernet1

speed auto

full-duplex

!

interface FastEthernet2

shutdown

duplex auto

speed auto

!

interface FastEthernet3

shutdown

duplex auto

speed auto

!

interface FastEthernet4

shutdown

duplex auto

speed auto

!

interface Dialer0

ip address negotiated

ip nat inside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname xxxxxx

ppp chap password 0 xxxxxx

ppp ipcp dns request

!

ip classless

ip route 0.0.0.0 0.0.0.0 ATM0.2

!

ip http server

no ip http secure-server

!

!

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

password xxxxx

login

transport input telnet

transport output telnet

!

scheduler max-task-time 5000

end

Here is the config of the 2610:

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

no service dhcp

!

hostname NAS-Router

!

boot-start-marker

boot-end-marker

!

enable secret 5 xxxxx

enable password xxxxx

!

no aaa new-model

ip subnet-zero

ip cef

!

!

ip domain lookup source-interface Ethernet0/0

ip domain name mydomain.com

ip name-server 192.168.14.2

!

!

!

!

username xxxxx password 0 xxxxx

username xxxxx password 0 xxxxx

!

!

controller E1 0/0

mode atm

!

!

interface Ethernet0/0

ip address 192.168.14.1 255.255.255.0

half-duplex

no cdp enable

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp Virtual-Template1

!

!

interface Virtual-Template1

ip unnumbered Ethernet0/0

peer default ip address pool kunden_isp1

ppp authentication chap

ppp ipcp dns 192.168.100.2

!

ip local pool kunden_isp1 192.168.100.3 192.168.100.254

ip http server

ip classless

ip route 192.168.100.0 255.255.255.0 ATM0/0

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password xxxxx

login

!

!

end

I would really appreciate your help.

Regards,

Chris

3 REPLIES
Hall of Fame Super Silver

Re: 837 and DNS/Routing Problem

Chris

I believe that SDM is expecting a configured DNS server and perhaps a configured domain name on the remote router similar to what you have configured on the head end router.

ip domain name mydomain.com

ip name-server 192.168.14.2

HTH

Rick

New Member

Re: 837 and DNS/Routing Problem

Hi Rick,

thanks for the answer.

But I would like to simulate a client who is not provided with any DNS information at all by his ISP. So maybe it would make sense to use DHCP on the NAS rather than IPCP ?

Chris

New Member

Re: 837 and DNS/Routing Problem

It seems to be a problem related to SDM, when I do everything straight in IOS it seems to work ... I get the propper IP address and DNS by IPCP ...

Still I can not ping anything on the remote side in no direction. What do I miss in the above settings ? I can not get the thing done.

I would highly appreciate your help.

Regards,

Chris

104
Views
0
Helpful
3
Replies