Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

837 setup.

I'm configuring a cisco 837 router for use with Eircom broadband in Ireland.

The details I have from the service provider are the following:

Broadband Line: 01-8000004

IP Address: 83.x.x.119

Subnet Mask: 255.255.255.255

Username: username

Password: password

Encapsulation: PPPoE

Multiplexing is LLC Based

VPI = 8 & VCI = 35

DNS1: 213.x.190.194

DNS2: 213.x.190.236

Authentication Chap.

I am having problems entering that subnet mask while setting the IP, which is why in the below config the subnet mask is 255.255.255.240.

That is definately what I was informed the subnet mask should be. And in my limited experience it looks wrong that the subnet mask indicates no host portion to the ip address.

Another problem is that I am setting this router up for Irish adsl (PPPoE) while I am in the UK and cant test it. As we use PPPoA adsl.

Does the below config, apart from the subnet mask, look ok for PPPoE adsl with the above settings?

!

version 12.3

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret 5 <edited>

!

username <edited> privilege 15 password 7 <edited>

no aaa new-model

ip subnet-zero

ip dhcp excluded-address 192.168.1.1

ip dhcp excluded-address 192.168.1.1 192.168.1.29

!

ip dhcp pool CLIENT

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

dns-server 213.x.x.194 213.94.190.236

lease 0 2

!

!

ip name-server 213.x.190.194

ip name-server 213.x.190.236

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

no scripting tcl init

no scripting tcl encdir

!

!

!

no crypto isakmp enable

!

!

!

!

interface Ethernet0

description LAN

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

hold-queue 100 out

!

interface ATM0

no ip address

atm vc-per-vp 64

no atm ilmi-keepalive

pvc 8/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

duplex auto

speed auto

!

interface FastEthernet3

no ip address

duplex auto

speed auto

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer1

ip address 83.x.x.119 255.255.255.240

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname username

ppp chap password 7 <edited>

ppp pap sent-username username password 7 <edited>

!

ip nat inside source list 102 interface Dialer1 overload

ip nat inside source static tcp 192.168.1.2 3389 83.70.207.119 60000 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

ip http authentication local

ip http secure-server

!

!

access-list 23 permit 192.168.1.0 0.0.0.255

access-list 23 permit 10.10.10.0 0.0.0.255

access-list 102 permit ip 192.168.1.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

control-plane

!

!

line con 0

exec-timeout 120 0

no modem enable

transport preferred all

transport output all

stopbits 1

line aux 0

transport preferred all

transport output all

line vty 0 4

exec-timeout 120 0

login local

length 0

transport preferred all

transport input telnet ssh

transport output all

!

scheduler max-task-time 5000

!

end

Any help is appreciated.

Thanks.

3 REPLIES
New Member

Re: 837 setup.

I've contacted the ISP and the subnet mask is indeed 255.255.255.255.

How would I go about giving the wan connection the static ip address of: 83.70.207.119/32? As the CLI and SDM will not accept that as a valid subnet mask.

New Member

Re: 837 setup.

"I've contacted the ISP and the subnet mask is indeed 255.255.255.255."

255.255.255.255 is a Broadcast address, I'm not sure why they gave you that...

Try enter the IP as "ip address 83.70.207.119 /32"

New Member

Re: 837 setup.

David,

When configuring PPPoE with ISP provided /32's I use 'ip address negotiated' on the dialer interface. That will allow the router to receive the IP from the provider after successfully logging in (authenticating).

HTH,

Jarred

123
Views
0
Helpful
3
Replies
CreatePlease to create content