Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

857 ADSL Problems

I am having problems getting the ADSL interface to connect. Is anyone elese havving issues? I am using Demon.

Below are the relevant configs I am using,

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.2 point-to-point

description $ES_WAN$$FW_OUTSIDE$

no ip redirects

no ip unreachables

no ip proxy-arp

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 2

interface Dialer1

description $FW_OUTSIDE$

ip address xxxxxxxxxxxx

ip access-group 101 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip inspect fwrule out

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

dialer pool 2

dialer-group 2

no cdp enable

ppp authentication chap callin

ppp chap hostname xxxxxxxxx

ppp chap password xxxxxxxxx

6 REPLIES
Bronze

Re: 857 ADSL Problems

Hello,

try ´dsl operating-mode ansi-dmt´ instead of ´auto´. Also, are you connecting to an ISP ? Try PAP authentication:

ppp authentication pap callin

ppp pap sent-username user@demon.com password password

The username and password need to be what your provider has given you...

Can you try this and see if it helps ?

Regards,

Nethelper

Community Member

Re: 857 ADSL Problems

I changed the ATM interface from dsl operating-mode 'auto' with ansi-dmt as suggested.This seemed to improve connectivity as the CO led remained solid for 30s before dropping off.

debug logs below. Dialer debugs look most promising

Thanks for your help.

debug ppp neg

000124: *Jan 6 18:58:37.007 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to up

000125: *Jan 6 18:58:41.223 GMT: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up

000126: *Jan 6 18:58:41.223 GMT: %DIALER-6-BIND: Interface Vi2 bound to profile Di1

000127: *Jan 6 18:58:41.223 GMT: Vi2 PPP: Using dialer call direction

000128: *Jan 6 18:58:41.223 GMT: Vi2 PPP: Treating connection as a callout

000129: *Jan 6 18:58:41.223 GMT: Vi2 PPP: Phase is ESTABLISHING, Active Open

000130: *Jan 6 18:58:41.223 GMT: Vi2 PPP: No remote authentication for call-out

000131: *Jan 6 18:58:41.223 GMT: Vi2 LCP: O CONFREQ [Closed] id 32 len 14

000132: *Jan 6 18:58:41.223 GMT: Vi2 LCP: MRU 1478 (0x010405C6)

000133: *Jan 6 18:58:41.223 GMT: Vi2 LCP: MagicNumber 0x14FD518E (0x050614FD518E)

000134: *Jan 6 18:58:42.279 GMT: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

000135: *Jan 6 18:58:42.279 GMT: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1

000136: *Jan 6 18:58:42.279 GMT: Vi2 PPP: Sending Acct Event[Down] id[11]

000137: *Jan 6 18:58:42.279 GMT: Vi2 LCP: State is Closed

000138: *Jan 6 18:58:42.279 GMT: Vi2 PPP: Phase is DOWN

000139: *Jan 6 18:58:43.295 GMT: %LINK-3-UPDOWN: Interface ATM0, changed state to down

000140: *Jan 6 18:58:44.295 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down

Debug ATM Events

000245: *Jan 6 19:02:11.143 GMT: ATM0: vcd = 1, safe_start called from periodic

000246: *Jan 6 19:02:12.115 GMT: atmsar_vc_tx_start(81C0A260).

000247: *Jan 6 19:02:12.115 GMT: ATM0:atmsar_dequeue_pak, dequeued a pak = 0x81

B19518

000248: *Jan 6 19:02:12.115 GMT: atmsar_transmit_pak_wrapper: deq(81B19518). vc

d: 1.atmsar_transmit_pak_wrapper : encap = Data

000252: *Jan 6 19:02:15.143 GMT: ATM0: vcd = 1, safe_start called from periodic

000253: *Jan 6 19:02:16.143 GMT: ATM0: vcd = 1, safe_start called from periodic

000254: *Jan 6 19:02:17.143 GMT: ATM0: vcd = 1, safe_start called from periodic

000256: *Jan 6 19:02:18.955 GMT: ATM0: atmsar_atm_get_stats,vcinfo = 0x0

000257: *Jan 6 19:02:19.143 GMT: ATM0: vcd = 1, safe_start called from periodic

000258: *Jan 6 19:02:20.143 GMT: ATM0: vcd = 1, safe_start called from periodic

000259: *Jan 6 19:02:21.143 GMT: ATM0: vcd = 1, safe_start called from periodic

000260: *Jan 6 19:02:22.131 GMT: atmsar_vc_tx_start(81C0A260).

000261: *Jan 6 19:02:22.131 GMT: ATM0:atmsar_dequeue_pak, dequeued a pak = 0x82

0A57BC

000262: *Jan 6 19:02:22.131 GMT: atmsar_transmit_pak_wrapper: deq(820A57BC). vc

d: 1.atmsar_transmit_pak_wrapper : encap = Data

000263: *Jan 6 19:02:22.143 GMT: ATM0: vcd = 1, safe_start called from periodic

000264: *Jan 6 19:02:23.143 GMT: ATM0: vcd = 1, safe_start called from periodic

Debug atm state

000306: *Jan 6 19:03:13.123 GMT: Changing vc 0/38vc-state to ATM_VC_SHUTTING_DOWN

000307: *Jan 6 19:03:13.123 GMT: Changing vc 0/38vc-state to ATM_VC_NOT_IN_SERVICE

debug dialer events

000327: *Jan 6 19:05:12.747 GMT: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down

000328: *Jan 6 19:05:12.747 GMT: %DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1

000329: *Jan 6 19:05:13.823 GMT: %LINK-3-UPDOWN: Interface ATM0, changed state to down

000330: *Jan 6 19:05:14.823 GMT: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down

000331: *Jan 6 19:05:15.239 GMT: Di1 DDR: Cannot place call, no dialer string set

000332: *Jan 6 19:05:15.239 GMT: Di1 DDR: Cannot place call, no dialer string set

000333: *Jan 6 19:05:27.747 GMT: Vi2 DDR: re-enable timeout

Community Member

Re: 857 ADSL Problems

Could you please post your "show ver" output?

I would like to see if you are using a 12.3 or a 12.4 IOS.

Community Member

Re: 857 ADSL Problems

IOS is v12.3(10.3)T2 as per below

#sh ver

Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.3(8)YI2, RE

LEASE SOFTWARE (fc1)

Synched to technology version 12.3(10.3)T2

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2005 by Cisco Systems, Inc.

Compiled Tue 14-Jun-05 20:08 by ealyon

ROM: System Bootstrap, Version 12.3(8r)YI2, RELEASE SOFTWARE

ROM: Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.3(8)YI

2, RELEASE SOFTWARE (fc1)

esolutions uptime is 2 minutes

System returned to ROM by power-on

System image file is "flash:c850-advsecurityk9-mz.123-8.YI2.bin"

Cisco 857W (MPC8272) processor (revision 0x200) with 59392K/6144K bytes of memor

y.

Processor board ID FHK09502426

MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10

4 FastEthernet interfaces

1 ATM interface

1 802.11 Radio

128K bytes of non-volatile configuration memory.

20480K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102

Community Member

Re: 857 ADSL Problems

I have just upgraded it to

c850-advsecurityk9-mz.124-4.T1.bin (latest release v12.44 T1)

And sadly it has made no difference.

Community Member

Re: 857 ADSL Problems

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

logging queue-limit 100

!

ip subnet-zero

!

ip cef

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

!

--More-- !

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

interface Ethernet0

ip address 192.5.17.15 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

hold-queue 100 out

!

interface ATM0

no ip address

--More-- ip mtu 1492

ip tcp adjust-mss 1452

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

!

interface ATM0.1 point-to-point

ip mtu 1492

pvc 1/33

!

!

interface Dialer1

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname xxxxert

ppp chap password 0 xxxxx

ppp pap sent-username xxxx password 0 xxxxx

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

--More-- ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

!

access-list 1 permit 192.5.17.0 0.0.0.255

access-list 101 permit tcp any any eq 443

call rsvp-sync

please try out this configuration.

Regds

Binoy.

Please rate if it helps:

176
Views
0
Helpful
6
Replies
CreatePlease to create content