Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

857w - "Configuration Failed" On startup

Hey guys. New to all this Cisco stuff so please treat me as an absolute newb - I don't even want to have to admin this router but I'm the only one here who knows how to use a keyboard it seems.

Router is an 857w, which was working fine until I wanted to make a simple change. Made the change in SDM and tested that it worked properly (the change was just a port redirect). I then used hyperterminal to get in and save the change on a permanent basis.

Using the instructions I was given by our ISP, i executed these commands:

en

(password entered)

conf term

line vty 0 4

privilege level 15

login local

transport input ssh

exit

exit

write mem

The change was applied and all appeared to be working well. I then restarted the router to make sure the change stuck and now I get this on startup

------------

Cisco 857W (MPC8272) processor (revision 0x200) with 59392K/6144K bytes of memor
y.
Processor board ID FHK1105155Y
MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
4 FastEthernet interfaces
1 ATM interface
1 802.11 Radio
128K bytes of non-volatile configuration memory.
20480K bytes of processor board System flash (Intel Strataflash)


Configuration failed!


Press RETURN to get started!

-------------

If I do nothing, I can't access the internet through it. However if i then go through and enter EXACTLY the same commands I listed above, after the "write mem" step it works again. However on reboot it gets the same error

I feel like I'm going around in circles - it works until I have to reboot it but then I have to write the memory each time. I've also copied running-config to startup-config but that doesn't help. Any suggestions? Thanks!

7 REPLIES
VIP Super Bronze

Re: 857w - "Configuration Failed" On startup

Hi Justin,

First, when you make those changes on your router, you do not need to reboot it.

Second, can you issue this command and post the output here?

"sh ver"

Reza

New Member

Re: 857w - "Configuration Failed" On startup

Hi Reza, thanks for the reply.

I know I didn't need to reboot, but i wanted to make sure it would startup correctly after a power failure

Here's the data you requested:

TB_BB_Package>sh ver
Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(11)T2, RE
LEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Tue 01-May-07 08:56 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI3, RELEASE SOFTWARE

TB_BB_Package uptime is 2 hours, 25 minutes
System returned to ROM by power-on
System image file is "flash:c850-advsecurityk9-mz.124-6.T6.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 857W (MPC8272) processor (revision 0x200) with 59392K/6144K bytes of memor
y.
Processor board ID FHK1105155Y
MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
4 FastEthernet interfaces
1 ATM interface
1 802.11 Radio
128K bytes of non-volatile configuration memory.
20480K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102

Re: 857w - "Configuration Failed" On startup

hi,

your confreg (0x2102) looks fine. try a router upgrade or delete some files to have enough memory on it. i've observed your 64 MB is almost used up.

Cisco 857W (MPC8272) processor (revision 0x200) with 59392K/6144K bytes of memory.

New Member

Re: 857w - "Configuration Failed" On startup

I shouldn't have to upgrade or free up space - all I did was change one setting. No additional files were created or anything, just a single setting change.

Does anyone else have any suggestions please?

New Member

Re: 857w - "Configuration Failed" On startup

Bump - anyone got any advice on this?

Re: 857w - "Configuration Failed" On startup

Hi Justin,

The version of the IOS that you are running on this router has been Deferred  by Cisco for various software issues, I dont know if you have access to Cisco.com or not but I just checked and it says that your are required to update your IOS.

Thanks

Manish


Cisco Employee

Re: 857w - "Configuration Failed" On startup

The "Configuration failed!" messages look like CSCsj26722 - Configuration failed error message on boot up.

You can see the bug here on CCO.

That bug is just cosmetic, so the "can't get to the internet after loading" problem must be something else.

Can you post "show ip interface brief", "show ip route" and "show ip nat stat" after the reload and then again after you apply your workaround?

672
Views
0
Helpful
7
Replies
CreatePlease login to create content