Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

871W and dual ISP connectivity

OK, I thought I had everything figured out with object tracking on a dhcp interface... Well I still have issues. I have cable modem on port Fa4 of the 871 and dsl on a Westell router connected to a switchport off of the 871. Tracking and routing looks good on the console with one small problem. Even though the DHCP learned route is the first route listed (S*) and the DSL static route is listed next (both routes having metric of 254), Internet sites show my public address as the DSL routers side. Another issue is when I unplug the cable modem to simulate a ISP failure, the primary route shifts to the DSL router like a good boy; however, when I plug the cablemodem back up give it a little bit, my router never shifts back to the other route. I know this does not work because when I do an extenede ping from that interface, I get no reply. I have to shut and no shut the interface for this to "work" again. I am thinking this "works" because I am forcing it to a DHCP request again... Any ideas or insight?

2 REPLIES
Silver

Re: 871W and dual ISP connectivity

Do you have c870-advipservicesk9-mz.123-8.YI3.bin IOS??

If yes than it has BUG.

If NOt than issue command " Service DHCP " See if it can help you.

If you can upgrade IOS with " c870-advipservicesk9-mz.124-11.T.bin " than you will see good result.

Revert to me if in case you have any queries.

Regards,

Dharmesh Purohit

Community Member

Re: 871W and dual ISP connectivity

Thanks for your reply. I am running c870-advipservicesk9-mz.124-11.T.bin already. I tinkered a little while longer after I posted my request and I might have it resolved. It seems to have worked the couple of times I tested it tonight. What I did was remove the statement from my Fa4 interface "ip dhcp client route track 123" and add "ip route 0.0.0.0 0.0.0.0 Fastethernet 4 DHCP" instead. It seems when I would fail back over to the primary route, my DHCP learned gateway was not keeping. Since I added the default route, it has worked so far; however, I am unsure how or if it needs to be, still tracking since the only statement I had linking the two (interface and track number) was removed.

Any ideas?

127
Views
0
Helpful
2
Replies
CreatePlease to create content