Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

876 Series atm0 configuration

Hi everyone,

I have 876 Series router with atm0 int., and have ADSL with static ip address.

Can you tell me how to configure this interface to work properly..

I try some procedures from Cisco site but with no success.

Thx

9 REPLIES
Hall of Fame Super Gold

Re: 876 Series atm0 configuration

Is your Isp using PPPoE or what encapsulation? What is the configuration that you have and does not work ?

New Member

Re: 876 Series atm0 configuration

I dont have a config for atm0, i was try some basic procedures from cisco site but with no success.

Now i have configured vlan, and use modem to go outside, PPPoE, and this work properly. But I want to know how can i configure atm0 without use of modem.

P.S. I was contact my ISP, and they say me that they don know which encapsulation use.

ha ha ha, funny, isnt it?

Thx

Hall of Fame Super Gold

Re: 876 Series atm0 configuration

Hehe, at least your ISP is more honest than the telco that tells you "we fixed it" and then isn't true.

Here's a config for PPPoE:

http://cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a008071a6c3.shtml

Note, some commands are not necessary as per blue comments. Note also, the example configuress atm0.1 subinterface, in reality that is not necessary and you can put all the interface commands under atm0 directly.

Let us know if it works, then call back the ISP and fax the config to them (they probably can't use email).

Re: 876 Series atm0 configuration

Hi Amar.

Just add some information for you.

I hope you are using pppoe routing mode.

Just try this :

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description Connected to ISP

pvc X/Y --> Ask your ISP for this params.

pppoe-client dial-pool-number 1

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address

ip nat inside

interface Dialer1

ip address < PUBLIC IPADDRESS>

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname xxxx

ppp chap password 0 yyyyy

ppp pap sent-username xxxx password 0 yyyyy

ip route 0.0.0.0 0.0.0.0 Dialer1

dialer-list 1 protocol ip permit

!

ip nat inside source list Internal interface Dialer1 overload

ip access-list extended Internal

remark goto Internet

permit ip A.B.C.D 255.255.255.0 any

Don't tell me your ISP provides bridge mode for you. ;-)

Hope this helps

Thot

New Member

Re: 876 Series atm0 configuration

Thx,

but i have adsl packet with static ip addresses. this mean, no username, and no password. the solution with dialer drop for now.

New Member

Re: 876 Series atm0 configuration

Thx, i will try this...

But i dont have username and pass for dialer, i have static ip address. i think i was try something like this but with no success.

have more ideas?

Re: 876 Series atm0 configuration

Hi Amar.

Back at one. Could you ask your ISP for more detail about adsl configuration.I hope you already tried the link as paolo stated.

For testing the bridge mode as follows:

bridge irb

interface Vlan1

ip address

ip nat inside

interface ATM0/0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0/0.1 point-to-point

no snmp trap link-status

bridge-group 1

pvc X/Y

encapsulation aal5snap

!

!

interface BVI1

ip address

ip nat outside

ip route 0.0.0.0 0.0.0.0 bvi1

ip nat inside source list Internal interface bvi1 overload

ip access-list extended Internal

remark goto Internet

permit ip A.B.C.D 255.255.255.0 any

bridge 1 protocol ieee

bridge 1 route ip

Hope this helps

Thot

Hall of Fame Super Gold

Re: 876 Series atm0 configuration

Then is not PPPoE (dialer). It's likely bridged 1483, this is the example:

http://cisco.com/en/US/products/hw/routers/ps380/products_configuration_example09186a0080093e50.shtml

Also the configuration given you by thotsaphon should work and actually I like it better for certain minors aspects.

After that the only remaining choice is routed 1483, but unlikely.

Good luck!

New Member

Re: 876 Series atm0 configuration

Thx guys.

I?ll try this today and post the results.

i hope this will work.

481
Views
0
Helpful
9
Replies
CreatePlease to create content