Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

877 and HSRP

Hello,

Want to be known if there is some problem between 877 with 12.4(2) IOS and HSRP protocol. In HSRP, this router has the standby role, but when the interface atm0 on master router fails, this router does not answer to the pings that do to themselves the IP of HSRP.

I review all bugs from this IOS and don't found any that resolve this question.

All configurations in both Cisco877 and cisco 1841 routes are correct.

Thanks for your help

6 REPLIES
VIP Purple

Re: 877 and HSRP

Hola Augustín,

just to be sure, can you post the configurations of both routers ?

Regards,

GP

New Member

Re: 877 and HSRP

Hello,

Yes I'm sure, but the administrators have configured the standby HSRP in Vlan1 interface. Is possible this is the problem?

Thanks

agusti

New Member

Re: 877 and HSRP

If the vlan 1 is configured as Layer 3 VLAN it should be ok....can u post he config?

New Member

Re: 877 and HSRP

hello,

I only can attach a partial configuration

- 877 -

interface Vlan1

description FHK094413F8

ip address 10.5.35.202 255.255.255.0

standby 1 ip 10.5.35.1

standby 1 priority 90

standby 1 preempt

standby 1 track ATM0 40

-1841 -

interface FastEthernet0/0

description "FCZ0938252M"

ip address 10.5.35.201 255.255.255.0

duplex auto

speed auto

standby 1 ip 10.5.35.1

standby 1 priority 110

standby 1 preempt

standby 1 track BVI1 40

The only option I have dubt is add "decrement" before 40 in the "standby 1 track BVI1 40" line.

thanks for your help

agusti

New Member

Re: 877 and HSRP

There seems to be a problem with the Active HSRP router listening for the virtual MAC address on vlan interfaces on the c877.

A workaround is to configure "standby use-bia" on the vlan interface so that HSRP uses the interface MAC address.

Also, the "decrement" keyword is optional.

Ian

Re: 877 and HSRP

Hi,

Just want to stick my head in here and say that i had this issue too. When i used the "Standby use-bia" on both routers. it workied just fine.

Regards

Stephen

========================== http://www.rconfig.com A free, open source network device configuration management tool, customizable to your needs! - Always vote on an answer if you found it helpful
602
Views
5
Helpful
6
Replies
CreatePlease to create content