Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

877 ATM point-to-point can't ping myself

Hi, I'm installing an 877 on an ADSL line. The config is as follows:

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

ip address 100.0.2.2 255.255.255.252

ip virtual-reassembly

no snmp trap link-status

atm route-bridged ip

pvc 0/40

protocol ip 100.0.2.1 broadcast

encapsulation aal5snap

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.1.253 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 100.0.2.1

The DSL line is up, protocol up, interfaces are all green.

ping atm interface atm0.1 0 40

Type escape sequence to abort.

Sending 5, 53-byte end-to-end OAM echoes, timeout is 2 seconds:

!!!!!

BUT, I cannot ping myself!!!

ping 100.0.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 100.0.2.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Tried several configs, consulted with the DSL line provider, doesn't work. Can't ping myself and can't ping the gateway..

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: 877 ATM point-to-point can't ping myself

Hi, try that:

int atm0.1

no ip address

no atm route-bridged ip

bridge-group 1

pvc 0/40

no protocol ip 100.0.2.1 broadcast

int bvi1

ip address 100.0.2.2 255.255.255.252

ip nat outside

bridge irb

bridge 1 route ip

Hope this helps, please rate post if it does!

7 REPLIES
Hall of Fame Super Gold

Re: 877 ATM point-to-point can't ping myself

Hi, try that:

int atm0.1

no ip address

no atm route-bridged ip

bridge-group 1

pvc 0/40

no protocol ip 100.0.2.1 broadcast

int bvi1

ip address 100.0.2.2 255.255.255.252

ip nat outside

bridge irb

bridge 1 route ip

Hope this helps, please rate post if it does!

Community Member

Re: 877 ATM point-to-point can't ping myself

Thanks, that helped to see my own IP!

Nevertheless, now I cannot ping the gateway (100.0.2.1) - the other end of the point to point link. The physical connection exists, the line is OK, the ISP checked their side, the gateway is OK. They can't ping me also.

Is there some kind of feature that needs to be turned on on the bridge interface? Besides the "bridge 1 route ip"?

Thanks

Hall of Fame Super Gold

Re: 877 ATM point-to-point can't ping myself

Not really. Please send again the config, and output of "show atm pvc 0/40", "show bride 1 detail".

Community Member

Re: 877 ATM point-to-point can't ping myself

Config:

version 12.4

bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

ip virtual-reassembly

no snmp trap link-status

pvc 0/40

encapsulation aal5snap

!

bridge-group 1

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 192.168.1.253 255.255.255.0

!

interface BVI1

ip address 100.0.2.2 255.255.255.252

!

ip route 0.0.0.0 0.0.0.0 100.0.2.1

ip route 172.16.0.0 255.255.0.0 100.0.0.2

ip route 172.16.0.0 255.255.0.0 192.168.1.254

!

no ip http server

no ip http secure-server

!

access-list 100 permit ip 192.168.1.0 0.0.0.255 172.16.0.0 0.0.255.255

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

Output:

Router#show atm pvc 0/40

Description: N/A

ATM0.1: VCD: 1, VPI: 0, VCI: 40

UBR, PeakRate: 121 (286 cps)

AAL5-LLC/SNAP, etype:0x0, Flags: 0xC20, VCmode: 0x0, Encapsize: 12

OAM frequency: 0 second(s), OAM retry frequency: 1 second(s)

OAM up retry count: 3, OAM down retry count: 5

OAM END CC Activate retry count: 3, OAM END CC Deactivate retry count: 3

OAM END CC retry frequency: 30 second(s),

OAM SEGMENT CC Activate retry count: 3, OAM SEGMENT CC Deactivate retry count: 3

OAM SEGMENT CC retry frequency: 30 second(s),

OAM Loopback status: OAM Disabled

OAM VC Status: Not Managed

ILMI VC status: Not Managed

InARP frequency: 15 minutes(s)

InPkts: 0, OutPkts: 607, InBytes: 0, OutBytes: 30608

InPRoc: 0, OutPRoc: 607

InFast: 0, OutFast: 0, InAS: 0, OutAS: 0

InPktDrops: 0, OutPktDrops: 0/0/0 (holdq/outputq/total)

CrcErrors: 0, SarTimeOuts: 0, OverSizedSDUs: 0, LengthViolation: 0, CPIErrors: 0

Out CLP=1 Pkts: 0

OAM cells received: 5

F5 InEndloop: 5, F5 InSegloop: 0,

F5 InEndcc: 0, F5 InSegcc: 0, F5 InAIS: 0, F5 InRDI: 0

F4 InEndloop: 0, F4 InSegloop: 0, F4 InAIS: 0, F4 InRDI: 0

OAM cells sent: 5

F5 OutEndloop: 5, F5 OutSegloop: 0,

F5 OutEndcc: 0, F5 OutSegcc: 0, F5 OutRDI: 0

F4 OutEndloop: 0, F4 OutSegloop: 0, F4 OutRDI: 0

OAM cell drops: 0

Status: UP

command "show bridge 1 detail" is not accespted, only "show bridge 1".

Hall of Fame Super Gold

Re: 877 ATM point-to-point can't ping myself

Hi,

you never receive any packet on PVC 0/40, check with ISP that it is correctly provisioned. Have them ping your address, if counter doesn't increase, something is wrong.

Community Member

Re: 877 ATM point-to-point can't ping myself

The ISP had an error. Now everything works.

Thank you for your help!

Hall of Fame Super Gold

Re: 877 ATM point-to-point can't ping myself

Yes, routers don't lie.

Good luck and Season Greetings!

670
Views
0
Helpful
7
Replies
CreatePlease to create content