Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

877 no connection to Internet. CD and PPP lights are steady on

Hi. I am trying to connect my 877 to my ISP for internet. The PPP light and the CD light is steady on. I contacted my ISP and they say that I am Syncing successfully, but I am still unable to connect to the internet. See below my config and some debugs. The sh ip route were taken shortly after each other. I am getting the IP and route from the ISP, but it just disappears from the routing table. I have tried updating the dsl firmware but the problem is still the same. Thanks for any assistance.

CONFIG

Current configuration : 3833 bytes

!

! No configuration change since last restart

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname MYROUTER

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret 5 $1$lCyH$IIt0sEL8Ib5gDO7dRzxjD1

!

no aaa new-model

!

dot11 syslog

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 172.16.1.1 172.16.1.20

!

ip dhcp pool INTERNAL_NET

   network 172.16.1.0 255.255.255.0

   default-router 172.16.1.1

   lease 7

!

!

ip domain name aknet.net

ip name-server 196.48.34.190

ip name-server 196.48.53.190

!

!

ip ssh version 2

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 8/35

  oam-pvc manage

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

ip address 172.16.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

!

interface Dialer0

ip address dhcp hostname MYROUTER

ip mtu 1452

ip nat outside

ip virtual-reassembly

no cdp run

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username <username> password 7 <password>

ppp ipcp route default

ppp ipcp address accept

!

no ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

ip http server

ip http authentication local

ip http secure-server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 172.16.1.0 0.0.0.255

dialer-list 1 protocol ip permit

!        

!

!

control-plane

PPP DEBUG

Sep 28 15:11:13.696: Di0 LCP: Not allowed on a Dialer Profile

Sep 28 15:11:13.700: Di0 PPP: Phase is DOWN, Setup

Sep 28 15:11:44.035: %DIALER-6-BIND: Interface Vi1 bound to profile Di0

Sep 28 15:11:44.035: Vi1 PPP: Phase is DOWN, Setup

Sep 28 15:11:44.035: Vi1 PPP: Using dialer call direction

Sep 28 15:11:44.035: Vi1 PPP: Treating connection as a callout

Sep 28 15:11:44.035: Vi1 PPP: Session handle[46000004] Session id[0]

Sep 28 15:11:44.035: Vi1 PPP: Phase is ESTABLISHING, Active Open

Sep 28 15:11:44.035: Vi1 PPP: Authorization required

Sep 28 15:11:44.039: Vi1 PPP: No remote authentication for call-out

Sep 28 15:11:44.051: Vi1 LCP: O CONFREQ [Closed] id 1 len 10

Sep 28 15:11:44.051: Vi1 LCP:    MagicNumber 0x64493F29 (0x050664493F29)

Sep 28 15:11:44.051: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

Sep 28 15:11:44.063: Vi1 LCP: I CONFACK [REQsent] id 1 len 10

Sep 28 15:11:44.063: Vi1 LCP:    MagicNumber 0x64493F29 (0x050664493F29)

Sep 28 15:11:46.020: Vi1 LCP: Timeout: State ACKrcvd

Sep 28 15:11:46.020: Vi1 LCP: O CONFREQ [ACKrcvd] id 2 len 10

Sep 28 15:11:46.020: Vi1 LCP:    MagicNumber 0x64493F29 (0x050664493F29)

Sep 28 15:11:46.024: Vi1 LCP: I CONFREQ [REQsent] id 2 len 18

Sep 28 15:11:46.028: Vi1 LCP:    MRU 1492 (0x010405D4)

Sep 28 15:11:46.028: Vi1 LCP:    AuthProto PAP (0x0304C023)

Sep 28 15:11:46.028: Vi1 LCP:    MagicNumber 0x62B78C3B (0x050662B78C3B)

Sep 28 15:11:46.028: Vi1 LCP: O CONFNAK [REQsent] id 2 len 8

Sep 28 15:11:46.028: Vi1 LCP:    MRU 1500 (0x010405DC)

Sep 28 15:11:46.032: Vi1 LCP: I CONFACK [REQsent] id 2 len 10

Sep 28 15:11:46.032: Vi1 LCP:    MagicNumber 0x64493F29 (0x050664493F29)

Sep 28 15:11:46.040: Vi1 LCP: I CONFREQ [ACKrcvd] id 3 len 18

Sep 28 15:11:46.040: Vi1 LCP:    MRU 1500 (0x010405DC)

Sep 28 15:11:46.040: Vi1 LCP:    AuthProto PAP (0x0304C023)

Sep 28 15:11:46.040: Vi1 LCP:    MagicNumber 0x62B78C3B (0x050662B78C3B)

Sep 28 15:11:46.040: Vi1 LCP: O CONFACK [ACKrcvd] id 3 len 18

Sep 28 15:11:46.040: Vi1 LCP:    MRU 1500 (0x010405DC)

Sep 28 15:11:46.044: Vi1 LCP:    AuthProto PAP (0x0304C023)

Sep 28 15:11:46.044: Vi1 LCP:    MagicNumber 0x62B78C3B (0x050662B78C3B)

Sep 28 15:11:46.044: Vi1 LCP: State is Open

Sep 28 15:11:46.044: Vi1 PPP: No authorization without authentication

Sep 28 15:11:46.044: Vi1 PPP: Phase is AUTHENTICATING, by the peer

Sep 28 15:11:46.044: Vi1 PAP: Using hostname from interface PAP

Sep 28 15:11:46.044: Vi1 PAP: Using password from interface PAP

Sep 28 15:11:46.044: Vi1 PAP: O AUTH-REQ id 1 len 38 from "username"

Sep 28 15:11:46.144: Vi1 PAP: I AUTH-ACK id 1 len 5

Sep 28 15:11:46.148: Vi1 PPP: Phase is FORWARDING, Attempting Forward

Sep 28 15:11:46.148: Vi1 PPP: Phase is ESTABLISHING, Finish LCP

Sep 28 15:11:46.148: Vi1 PPP: Phase is UP

Sep 28 15:11:46.148: Vi1 IPCP: O CONFREQ [Closed] id 1 len 10

Sep 28 15:11:46.148: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)

Sep 28 15:11:46.148: Vi1 CDPCP: O CONFREQ [Closed] id 1 len 4

Sep 28 15:11:46.148: Vi1 PPP: Process pending ncp packets

Sep 28 15:11:46.148: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10

Sep 28 15:11:46.148: Vi1 IPCP:    Address 105.224.80.1 (0x030669E05001)

Sep 28 15:11:46.152: Vi1 IPCP: O CONFACK [REQsent] id 1 len 10

Sep 28 15:11:46.152: Vi1 IPCP:    Address 105.224.80.1 (0x030669E05001)

Sep 28 15:11:46.160: Vi1 IPCP: I CONFNAK [ACKsent] id 1 len 10

Sep 28 15:11:46.160: Vi1 IPCP:    Address 105.227.81.157 (0x030669E3519D)

Sep 28 15:11:46.160: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 4

Sep 28 15:11:46.164: Vi1 LCP: I PROTREJ [Open] id 4 len 10 protocol CDPCP (0x820701010004)

Sep 28 15:11:46.164: Vi1 CDPCP: State is Closed

Sep 28 15:11:46.164: Vi1 CDPCP: State is Listen

Sep 28 15:11:46.176: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 4

Sep 28 15:11:46.176: Vi1 IPCP: State is Open

Sep 28 15:11:46.176: Di0 IPCP: Install route to 105.224.80.1

Sep 28 15:11:46.176: Vi1 IPCP: Add link info for cef entry 105.224.80.1

Sep 28 15:11:47.148: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

MYROUTER#

SH IP ROUTE 1

MYROUTER#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is 105.224.80.1 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, Vlan1

     105.0.0.0/32 is subnetted, 1 subnets

C       105.224.80.1 is directly connected, Dialer0

S*   0.0.0.0/0 [1/0] via 105.224.80.1

               is directly connected, Dialer0

SH IP ROUTE 2


MYROUTER#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, Vlan1

S*   0.0.0.0/0 is directly connected, Dialer0

SH IP ROUTE 3

MYROUTER#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.1.0 is directly connected, Vlan1


1 ACCEPTED SOLUTION

Accepted Solutions
New Member

877 no connection to Internet. CD and PPP lights are steady on

Andre,

Use "ip address negotiated" instead of "ip address dhcp hostname MYROUTER" under the Dialer0 interface

3 REPLIES
New Member

877 no connection to Internet. CD and PPP lights are steady on

Andre,

Use "ip address negotiated" instead of "ip address dhcp hostname MYROUTER" under the Dialer0 interface

New Member

877 no connection to Internet. CD and PPP lights are steady on

Thank you Daniel. I will try that. Any idea why the route is disappearing from the routing table?

New Member

877 no connection to Internet. CD and PPP lights are steady on

Hi. Thanks for your assistance. It seems that the DHCP was working, but then the connection was dropped after. That is the reason why it was taken out of the routing table. After I set the interface ip to "ip address negotiate" the route stayed in the table, and the connection is now working. I needed to reconfigure my NAT and name servers, but all is working now. Thank you for your assistance.

456
Views
0
Helpful
3
Replies
CreatePlease to create content