Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

877 Routed Interfaces or 1800 series

Hello,

I've been searching for router that can replace the obsolate 1720 that we have. I've started another post asking question about 837 router, but now my questions are about 877 or the 1800 series. The links to the ather post, in case that can help:

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=WAN%2C%20Routing%20and%20Switching&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40.1ddbd0a2

So what i want to do. I want to connect to the Internet with the ADSL router, and have 2 separated LANs. Of these LAN is like DMZ, so i can forward some internet ports to some servers in the 'DMZ'. The router is going to be used of about 10 persons, possible 2 or 3 vpns, almost that...

So I wanted to know what router to take, i found the 877, but i'm not sure if it has 2 routed interface, it has 4 port full managed switch, does it mean, that i can configure like that:

interface FastEthernet1

ip address 100.200.10.1

ip nat inside

interface FastEthernet2

ip address 100.200.20.1

ip nat inside

So that the LAN1 is connected respectively to the port 1 of the switch, and LAN 2 to the port2.

The 877 can do also VLAN, so a similar configuration is possible, right?

So, i'm not sure if i can take the 877 and configure the 4 interfaces separately or with the VLANs or to take other router. Pleace give some advises or propositions.

Here is some port of the configuration of the actual router 1720:

interface ATM0

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode ansi-dmt

no fair-queue

hold-queue 224 in

!

interface ATM0.1 point-to-point

pvc 2/32

encapsulation aal5mux ppp dialer

pppoe-client dial-pool-number 1

!

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

ip nat inside

full-duplex

!

interface FastEthernet0

ip address 100.200.20.45 255.255.255.0

ip nat inside

speed auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

ppp authentication chap callin

ppp chap hostname LOGIN

ppp chap password PASS

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source static tcp 192.168.1.3 8080 SOMEIP 8080 extendable

ip nat inside source static tcp 192.168.1.2 80 SOMEIP 80 extendable

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

ip pim bidir-enable

!

!

access-list 1 permit 100.200.20.0 0.0.0.255

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 2 permit 100.200.20.0 0.0.0.255

no cdp run

Thanks a lot!

Momchil

myanakiev@dia-gr.com

1 REPLY

Re: 877 Routed Interfaces or 1800 series

Hello Momchil,

the FastEthernet interfaces on the 877 router are indeed Layer 2 only, what you need to do is place each FastEthernet interface in a VLAN, and then configure SVI?s for inter-Vlan routing.

In your case, the configuration would look like this:

interface FastEthernet0

switchport access vlan 2

!

interface FastEthernet1

switchport access vlan 3

!

interface Vlan2

ip address 192.168.1.1 255.255.255.0

ip nat inside

full-duplex

!

interface Vlan3

ip address 100.200.20.45 255.255.255.0

ip nat inside

speed auto

The remainder of the PPPoA config is the same as for the 1720, define the dialer interface as NAT outside.

HTH,

GNT

118
Views
0
Helpful
1
Replies