Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

877 Router DSL connectivity issues

I am trying to configure an 877 on my home network in the UK. I have just switched provider to 02 as they will let me use my 877 router & Sky would not. However they do not support the cisco router & are not very helpful with information re the config. I am having issues with IP connectivity, layer 1 is fine & i can do an ATM ping no problem. It appears to be a PPP negotiation problem, but the only info i can get from them is that the username & password should be blank. I have been assigned an IP address, but have also tried configuring the dialer interface for "ip address negotiate".

When i do a show ip int brief, all interfaces are UP UP, except for virtual-access2 that is UP DOWN. Any ideas??

5 REPLIES
Hall of Fame Super Gold

Re: 877 Router DSL connectivity issues

Send relevant config, and output of "debug ppp neg" with "term mon".

New Member

Re: 877 Router DSL connectivity issues

Sorted it now, FYI i have attached the config.

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco877W

!

boot-start-marker

boot-end-marker

!

enable secret xxxxxxxx

!

aaa new-model

!

!

aaa group server radius rad_eap

!

aaa group server radius rad_mac

!

aaa group server radius rad_acct

!

aaa group server radius rad_admin

!

aaa group server tacacs+ tac_admin

!

aaa group server radius rad_pmip

!

aaa group server radius dummy

!

aaa authentication login default local

aaa authentication login eap_methods group rad_eap

aaa authentication login mac_methods local

aaa authorization ipmobile default group rad_pmip

aaa accounting network acct_methods start-stop group rad_acct

!

!

aaa session-id common

!

!

dot11 syslog

!

!

dot11 ssid Cisco877W

authentication open

guest-mode

!

ip cef

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.200.1 192.168.200.5

!

ip dhcp pool dpool1

import all

network 192.168.200.0 255.255.255.0

dns-server 94.192.119.254 87.194.0.51 87.194.0.66

default-router 192.168.200.1

!

!

ip name-server 87.194.0.51

ip name-server 87.194.0.52

ip name-server 94.192.119.254

!

!

!

username colinw privilege 15 secret 5 $1$YMNI$.G2vd.6qw6Lo1b7yUgQgi0

!

!

archive

log config

hidekeys

!

!

!

bridge irb

!

!

interface ATM0

mac-address xxxx.xxxx.xxxx (mac of 02 router)

no ip address

ip virtual-reassembly

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

description ADSL2+ o2broadband

ip address x.x.x.x x.x.x.x

ip nat outside

ip virtual-reassembly

atm route-bridged ip

pvc 0/101

oam-pvc manage

encapsulation aal5snap

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Dot11Radio0

no ip address

!

encryption key 1 size 128bit 0 xxxxxxxxxxxxx transmit-key

encryption mode wep mandatory

!

ssid Cisco877W

!

speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

no ip address

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

bridge-group 1

bridge-group 1 spanning-disabled

!

interface BVI1

ip address 192.168.200.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 x.x.x.x

!

ip http server

no ip http secure-server

ip nat inside source list 102 interface ATM0.1 overload

!

access-list 102 permit ip 192.168.200.0 0.0.0.255 any

no cdp run

!

!

radius-server attribute 32 include-in-access-req format %h

radius-server vsa send accounting

!

control-plane

!

bridge 1 protocol ieee

bridge 1 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

privilege level 15

transport input telnet ssh

!

scheduler max-task-time 5000

end

Hall of Fame Super Gold

Re: 877 Router DSL connectivity issues

So in O2 terms "blank user/pw" means "no PPP is used" - nice to know :)

New Member

Re: 877 Router DSL connectivity issues

It has taken me ages to work that one out, hopefully this config will help someone else.

Hall of Fame Super Gold

Re: 877 Router DSL connectivity issues

Certainly it does and I've rated your post.

141
Views
5
Helpful
5
Replies
CreatePlease to create content