Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

877 router has crc errors but the input errors counter is not incrementing

Hi, I have an 877 router that is configured with an atm pvc facing the wan. The atm0 interface crc errors are incrementing, but these errors are not being reflected in the input errors counter. Does anybody know why this is?

JDI-KBSDAR-CE1#sh int atm0

ATM0 is up, line protocol is up

Hardware is MPC ATMSAR (with Alcatel ADSL Module)

MTU 4470 bytes, sub MTU 4470, BW 640 Kbit, DLY 570 usec,

reliability 255/255, txload 6/255, rxload 8/255

Encapsulation ATM, loopback not set

Encapsulation(s): AAL5 AAL2, PVC mode

10 maximum active VCs, 1024 VCs per VP, 1 current VCCs

VC Auto Creation Disabled.

VC idle disconnect time: 300 seconds

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters 22:42:08

Input queue: 0/224/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: Per VC Queueing

30 second input rate 21000 bits/sec, 7 packets/sec

30 second output rate 16000 bits/sec, 10 packets/sec

957301 packets input, 609662204 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 2040 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

978302 packets output, 164802240 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

When the CRC error counter is incremented the following ATM error is logged when debug atm errors is enabled:

ATM0: AAL5 rx errors (status = 0C110000)

The router ios is: c870-advipservicesk9-mz.124-9.T2.bin

6 REPLIES

Re: 877 router has crc errors but the input errors counter is no

New Member

Re: 877 router has crc errors but the input errors counter is no

Would this cause packet loss? Because i am getting packet loss:

ABC123#ping 10.1.254.101 size 500 repeat 5000

Type escape sequence to abort.

Sending 5000, 500-byte ICMP Echos to 10.1.254.101, timeout is 2 seconds:

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

*May 29 07:00:19 UTC: ATM0: AAL5 rx errors (status = 0C130000).!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!

*May 29 07:00:23 UTC: ATM0: AAL5 rx errors (status = 0C130000)!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

*May 29 07:00:37 UTC: ATM0: AAL5 rx errors (status = 0C110000)

*May 29 07:00:37 UTC: ATM0: AAL5 rx errors (status = 0C110000)

*May 29 07:00:37 UTC: ATM0: AAL5 rx errors (status = 0C110000)

*May 29 07:00:37 UTC: ATM0: AAL5 rx errors (status = 0C110000).!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!

*May 29 07:00:41 UTC: ATM0: AAL5 rx errors (status = 0C110000).!!!!!!!!!!

*May 29 07:00:42 UTC: ATM0: AAL5 rx errors (status = 0C110000)

*May 29 07:00:42 UTC: ATM0: AAL5 rx errors (status = 2C130000)!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Success rate is 99 percent (4997/5000), round-trip min/avg/max = 16/19/192 ms

Re: 877 router has crc errors but the input errors counter is no

Have you checked physical issues on pvc carrier from the wan side.

Check out this case from tac knowledge base

http://www.ciscotaccc.com/kaidara-advisor/atm/showcase?case=K16470263

New Member

Re: 877 router has crc errors but the input errors counter is no

I am pretty sure that there is an issue with the carrier side, however, my question is. Why aren't the CRC errors showing up as an input error on the routers atm interface? Aren't the input errors supposed to be a running count of CRCs, "no buffers", runts, giants, frames, overruns, ignored, aborts and other input-related errors?

Re: 877 router has crc errors but the input errors counter is no

Im goint to look this up, I could be wrong on this one and please someone can correct on this , the input/output statistics would more have to do with the way incoming and outgoing packets are processed withing the router itself, I would assume crc would indicate physical issues, and that is why your input errors are 0 and is not directly related to input/output errors in this case.

Hall of Fame Super Gold

Re: 877 router has crc errors but the input errors counter is no

I do see that on really all my installed ADSL router (and they're quite a number), independently from IOS used, but only when PPPoA is used, and only with certain DSLAM/BRAS.

I cannot tell that is causing any particular problem as I cannot demonstrate packet loss because of this.

You have to know that "show interface" is a bit particular for the way it accounts and sums or not sums errors, for reasons that is impossible to summarize here.

396
Views
0
Helpful
6
Replies