Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

877W ADSL - Exit Interface Failed Test

Hi All,

first time request - hope someone can help...

i have purchased a Cisco 877W some weeks ago. i am trying to set it up over a home user ADSL service in the UK. The service is currently working using a basic netgear router.

i am hoping to replace the netgear to setup and test this router, but once setup the basic's using SDM the router is not able to succeed in all communication tests.

ERROR: no configured route to any of the DNS servers through the selected interface.

WAN Troubleshooting Report

ActivityStatus
Checking interface status...Up
Checking for DNS settings...Successful
Checking interface IP address..Successful
Checking exit interface...Failed

the router is connecting and obtaining a public address through DHCP from the ISP - however i am unable to get internet access from a client (on dhcp) and this DNS /exit interface test fails - (see above).

running config is as follows:

rtr-home-1#sho run
Building configuration...

Current configuration : 2045 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname rtr-home-1
!
boot-start-marker
boot-end-marker
!
enable secret 5
enable password
!
no aaa new-model
!
!
dot11 syslog
no ip routing
no ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1 10.10.10.9
ip dhcp excluded-address 10.10.10.100 10.10.10.254
!
ip dhcp pool ccp-pool1
   import all
   network 10.10.10.0 255.255.255.0
   dns-server 10.10.10.1
   default-router 10.10.10.1
!
!
ip name-server 10.10.10.1
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
interface ATM0
no ip address
no ip route-cache
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$
no ip route-cache
pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
ip address 10.10.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname USERNAME
ppp chap password 0 PASSWORD
ppp pap sent-username USERNAME password 0 PASSWORD
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 ATM0.1 (also tried "Dialer0")
!
ip http server
no ip http secure-server
ip nat inside source list 100 interface Dialer0 overload
!
access-list 100 remark CCP_ACL Category=2
access-list 100 permit ip 10.10.10.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
password PASSWORD
login
!
scheduler max-task-time 5000
end

Everyone's tags (4)
4 REPLIES
Hall of Fame Super Gold

Re: 877W ADSL - Exit Interface Failed Test

Didn't your ISP provide you their DNS server IP address?

New Member

Re: 877W ADSL - Exit Interface Failed Test

ISP provides ip address, dns etc over dhcp. We didn't have to

configure any dns entries for the netgear.

Also as part of the test it establishes ip address and dns addresses

which was ok. The problem is connecting to the dns address's which

might also be why I cant route to the Internet.

I have been suggested to put in "ip routing". But what else do you

recommend?

Thanks

Russ

Sent from my iPhone

On 4 May 2010, at 23:35, leolaohoo

New Member

Re: 877W ADSL - Exit Interface Failed Test

From Test ADSL

I advise you to use public DNS such as OpenDNS (208.67.222.222 and 208.67.220.220) or Google's (8.8.8.8 or 8.8.4.4)


http://www.test-ligne-adsl.com

New Member

Re: 877W ADSL - Exit Interface Failed Test

SOLVED

i believe i have fixed this by the following:

enable ip router:

configure terminal> ip routing

usign SDM ensure that default gateway is "Dialler0"

thanks for your help and assisitance. also useful to know about those open

dns servers...

2385
Views
0
Helpful
4
Replies
CreatePlease to create content