Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

877W, SDM Express and getting it going...

Hi,

I am a network engineer and am trying to commission my very first Cisco - an 877W.

I have run into a major problem with SDM Express.

SDM Express starts up and runs fine. I answer all the questions properly and end up at the confirmation page. Everything is checked and I click 'Finish'.

That's it - one dead router.

It says it takes a while to load, so left it for 30 mins and power cycled it. None of the configuration I entered is in there, it's still a factory default.

Tried it on 2 PCs - Win XP Pro SP2, no firewall, no anti-virus. LAN cable (tried a few of those).

Tried it in IE and Firefox on both machines.

Tried a new power supply.

Tried it on Linux and Mac - doesn't like either of those.

Anyone had the same or got a fix? Is it the router or SDM?

I have had a replacement router - both behave the same way.

(My reseller is foxed and Cisco don't offer support :-()

Thanks,

David

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

Well, you are almost there.

if you paste the below, that will simplify the configuration. radio is keep shut as you are worried about it.

I've put a port forwarding for 8080 outside to 80 inside. If you have more addresses router and what expose a a full host, it's a single line command too.

ip dhcp pool sdm-pool1

no import all

dns-server 195.74.113.58 195.74.113.62

!

!

interface FastEthernet0

spanning-tree portfast

!

interface FastEthernet1

spanning-tree portfast

!

interface FastEthernet2

spanning-tree portfast

!

interface FastEthernet3

spanning-tree portfast

!

interface Dot11Radio0

shutdown

!

interface Dialer0

ppp ipcp route-default

interface BVI1

no ip access-group 100 in

no ip route 0.0.0.0 0.0.0.0 Dialer0

!

no ip http server

no access-list 100

ip nat inside source static tcp 192.168.7.20 80 interface BVI1 8080

The ALGs are all automatic. VPN, can post an example later once you got going.

25 REPLIES
New Member

Re: 877W, SDM Express and getting it going...

?

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

Hi David,

please connect to router with a console cable and terminal program, use exclusively comman line interface. SDM can have bugs, and often doesn;t do what you want.

If you cal tell us what do you want the router to do, we can point to examples.

New Member

Re: 877W, SDM Express and getting it going...

Hi,

Thanks for the fast reply...

All I want to do it the basic setup (LAN, WAN - multiple public IPs, DHCP, Firewall). It doesn't give me a warm fuzzy feeling for Cisco if the tool for initial setup doesn't work.

Later I will want QoS, VPN, DMZ, WLAN, SIP/RTP routing etc.

I was sold this router on the understanding that it had a web interface, I rejected the 1801 cos it didn't :-(

Thanks,

David

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

Sorry, in short, forget about web interface.

What your isp uses ? PPPoA, PPPoA, bridged ?

New Member

Re: 877W, SDM Express and getting it going...

Thanks for the offer.

I am an ISP and was hoping that an 877W could be my higher-end self install option. So it would need a wizard that actually works.

Customers without IT depts are not going to be comfortable with sticking a cable in their COM port and using the CLI. Using a network engineer would put the 877W way out of its price range. It's very expensive for SMBs anyway.

I guess I'll be sending it back.

I know it's cheeky, but does anyone know of anyone else who make a high quality high availability router that can be given to a customer to install themselves?

(Draytek 2800 is our high end business class router atm, but isn't stable enough for some customers)

Thanks,

David

New Member

Re: 877W, SDM Express and getting it going...

If you are an ISP I'm wondering why you're not using a provisioning tool to generate (most of) the config on the fly and deliver the router pre-configured to your customers? Customers that are allowed to make changes in the CPE almost always cause problems with their own connection than they solve (there are exceptions, but they use the CLI anyway). Having the router pre-installed and shipped with all the necessary cables, especially when QoS or MPLS is involved, seems a better option.

New Member

Re: 877W, SDM Express and getting it going...

Hi Patrick,

Not sure what CPE is...

We don't work that way - I doubt many others do either.

We don't want to see the routers... they are supplied by our supplier and delivered direct to our customer before provisioning date.

No wires-only/self-install ISP that I know in the UK ships routers preconfigured, the end user is supposed to put in the details themselves.

If they mess it up, a factory reset and re-configure fixes it :-)

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

No worries. Simply put, cisco products are suitable only if have professionals doing configuration and maintenance.

A consumer-class brand that I can recommend, is Linksys. Some models do support VPN too.

New Member

Re: 877W, SDM Express and getting it going...

Consumer products are not my field... Linksys are quite good for home users though.

Thought a Cisco would be the solution for my higher end customers... obviously not unless you have ridiculous amounts of cash.

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

At some point, distinction between small office and home users is blur. Linksys is actively addressing the SMB market now.

With cisco, look at the 85x (optional w) then. It does almost all what the 87x does costing a bit less.

On your side all required is providing a configuration template in form of a text file that cover 99% of the needs.

New Member

Re: 877W, SDM Express and getting it going...

Thanks for your advice p,

I have decided that Cisco is not going to be a solution for us until/unless they actually manage to create a router with a comprehensible interface that works. I am guessing that the 85* series uses this same SDM that doesn't work.

I actually wanted a highly reliable solution for our office too. Something that I could recommend to my customers.

If I ever get a customer that is prepared to spend several £1000's on a basic internet connectivity solution I will get a Cisco partner in. I was lead to believe that it could be done for £400. It has so far cost a bit more, without factoring in wasted time, high frustration and stress...

Shame really, but I have been warned off Cisco for the whole of my 23 year time in IT. I should have taken the advice for just a bit longer :-)

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

Hi David,

I worked for Cisco almost 10 years and I understand the frustration when a new customer comes and the product is not up to expectations. When it happened I always tried to do whatever the possible to change an impasse into a win-win situation. I know that most of my former coworkers have the same approach.

So in all honesty I believe that in almost all applications, nothing beats Cisco.

So, if you want to try and are willing to take the "CLI challenge", I can guarantee you that the 871w will work and do everything what cisco says, and a bit more perhaps.

If it doesn't, I will buy it from you for a price you set (but no more than what you paid, please :)

Price of my consultancy, zero pounds.

What do you think ?

New Member

Re: 877W, SDM Express and getting it going...

:-)

Very kind...

I am just terrified of it now. Reading through these forums, you Cisco guys use so many terms I have never heard before.

The set up for WPA wireless in completely incomprehensible (probably *because* it is so flexible). How do you set up SSID, tick WPA2, enter a shared Key? Should be easy.

How am I ever going to set up port forwarding for SIP and FTP, modify firewall rules etc etc.

What I asked the cisco partner for was:

Best ADSL, WPA Wireless, SIP ALG, FTP ALG router...

1. TOS / QOS for VoIP etc

2. Multiple Public IP addresses going to several machines on a 255.255.255.248 public subnet

3. One of those public IP addresses for general browsing etc for all other machines.

4. FTP server support behind the firewall/NAT (FTP-ALG)

5. Multiple Asterisk server and SIP Phones support behind firewall/NAT (SIP-ALG)

6. uPnP (nice to have, not essential)

7. facility to bar P2P/bittorrent during certain hours only (*very* nice to have)

8. Strong firewall

9. ADSL modem (ADSL 2+ compatible)

10. Wireless G with WPA/WPA2 support

11. Support for 10+ computers both wired and wireless.

As a replacement for a Draytek 2800G which is a dream to set up but no longer stable or powerful enough.

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

It does all what you said except uPnP.

I need to know from you:

Which encap you use, suppose bridged 1843 ? Which VPI/VCI.

Since I promised, will post an example configuration here. Some points like 4,5 must also be specified exactly, need to know what goes where ?

Note, if need annex-M (high speed upload) you must buy -M models. Regular ones, don't have that.

New Member

Re: 877W, SDM Express and getting it going...

This is what I have got so far...

I think I have set up the WAN (Annex-A Adsl, 0/38)

Can't actually connect to the WAN to test as I have no idea whether my WLAN is live or secure

New Member

Re: 877W, SDM Express and getting it going...

All I need to get going is:

ADSL --> Router --> LAN clients + WLAN (WPA-PSK) clients

Should be simple.

How on earth would you do DMZ, port forwarding, use FTP-ALG, SIP-ALG, VPN (lan-lan), VPN single clients?

This router obviously has more power than I need, how do I just get an overview of how to set it up without reading 100's pages of incomprehensible technical babble?

Having spent 2 whole days on it, I think it's time to give up, pack it in its box and send it back to where it came from...

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

Well, you are almost there.

if you paste the below, that will simplify the configuration. radio is keep shut as you are worried about it.

I've put a port forwarding for 8080 outside to 80 inside. If you have more addresses router and what expose a a full host, it's a single line command too.

ip dhcp pool sdm-pool1

no import all

dns-server 195.74.113.58 195.74.113.62

!

!

interface FastEthernet0

spanning-tree portfast

!

interface FastEthernet1

spanning-tree portfast

!

interface FastEthernet2

spanning-tree portfast

!

interface FastEthernet3

spanning-tree portfast

!

interface Dot11Radio0

shutdown

!

interface Dialer0

ppp ipcp route-default

interface BVI1

no ip access-group 100 in

no ip route 0.0.0.0 0.0.0.0 Dialer0

!

no ip http server

no access-list 100

ip nat inside source static tcp 192.168.7.20 80 interface BVI1 8080

The ALGs are all automatic. VPN, can post an example later once you got going.

New Member

Re: 877W, SDM Express and getting it going...

Really?

I just tried connecting to the internet (quiet at 10pm here) and it connected but could not resolve via DNS from connected clients. (e.g. traceroute www.ibm.com). Couldn't find out how to query the router for its thoughts about DNS, life or anything. Is this fixed by the first 3 lines above? I was expecting the router to give my clients its address (192.168.7.1) as the DNS server rather than my ISPs.

Do I just issue these command in telnet?

WLAN does need to work eventually under WPA2-PSK - docs are a complete mystery - something about a MAC, something about a RADIUS server which I don't have or want.

Going home to get some sleep - 18 hours with the 877W yesterday and about 14 today... no lunch, dinner, coffee for 2 days has taken its toll. (Plus several arguments and discussions with the idiots that sold me this got me really wound up too).

If I die early, Cisco will be to blame ;-)

Supposed to be doing a beta test for the new AVM Fritz!Box firmware today too...that didn't happen.

New Member

Re: 877W, SDM Express and getting it going...

OK.

Thanks for all the help...

I have given up, router being returned.

I won't be installing Cisco anythings until/unless they get the SDM working and create a *secured* wireless network as the default.

I do wonder how Cisco have got so big, same way as Microsoft, I guess.

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

Again, I understand your frustration. If you have decided already, doesn't matter, thank you for the nice rating and good luck.

Now for the issues:

DNS done by the router:

ip dns server

ip domain-lookup

no ip name-server ...

dhcp pool

dns server

int dialer1

ppp ipcp dns request

For WPA/PSK, I can give you a reply later, as I've haven't done this config yet.

New Member

Re: 877W, SDM Express and getting it going...

Thanks P,

It is all packed up and awaiting collection.

The lack of ability to configure, Cisco's unwillingness to release firmware/software updates or provide support, my resellers seemingly high charge for a firmware upgrade, the uncertainty of QoS actually being in there , the fear that I will leave the router wide open and the sort of problems people are reporting on these forums has completely put me off.

Life is too short to have to deal with the Microsoft of the hardware world.

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

Hi David, just let me give some reply to your complaints, without the intent of a sterile discussion, to expose the point of view of Cisco when I was with them, as I don't think it has changed much now:

1. SDM is to be used just for the most basic configuration, anything else must be done by CLI . (Paolo's opinion: SDM is crap and should be avoided).

2. Firmware upgrades and support: It is not free. A support contract must be purchased, even in the initial period. The reason behind that is because the product, being a professional one, has to be installed by a certified cisco partner that has already the necessary knowledge and access to downloads and second/third level support.

3. QoS is absolutely working and as for many other things in networking, cisco was a leader in that. In you case, it was not configured.

4. Years ago, Cisco has aquired Aironet that literally invented wireless ethernet. Then again as provide the broadest range of support for securing wireless. Sorry, it requires training to be used in the full power.

5. Yes, many problems here, but many solutions too, and given for free. Compare to other vendors forums where you see "my router freezes under load and nothing can fix it".

Now, I think that any IT professional has spent time significant time on a product he/she was not familiar with. Usually, the result justifies the invested time. If that was not your case with cisco, is because you had zero exposure to IOS and undertook a task that requires significant experience and knowledge. Consider, there are professionals doing this for a living.

Anyway each one is entitled to his opinion and I wish you best luck. Come back here at any time if you need!

New Member

Re: 877W, SDM Express and getting it going...

It is indeed a shame to return the product as it will do everything you need it to. But Paolo is right, the SDM is not worth using as very little can be configured using it. It is useful for field engineers to make a basic set-up so that the router can be reached from a central location for further configuration.

Cisco products, like certain other professional products, require a level of training SOHO products don't need to install. But the added flexibility and options make it worth it.

New Member

Re: 877W, SDM Express and getting it going...

Hi P,

Sorry, didn't mean to sound ungrateful or rude. I really appreciate the help you have given.

I just was expecting one thing and got something completely different and a reseller who wasn't really used to dealing with customers as inexperienced as us.

You never know, I may well try the 877W again one day if I've had a really long holiday and feeling very relaxed. (I actually think I found the doc that may have helped a lot about 30 mins ago http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/857swcg.html)

Thanks once again.

David

Hall of Fame Super Gold

Re: 877W, SDM Express and getting it going...

Hi David,

Absolutely no rudeness and I appreciate your frank opinions given here. Cisco should learn from cases like you to make the product easier and better documented.

But never waste holiday doing networking :)

859
Views
4
Helpful
25
Replies
CreatePlease to create content