Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

881G+7-K9 3G modem issue

Hi all ,

I can make 3g modem to work , to get ip , or to ping 8.8.8.8

Also on interface cellular 0 i can chose only slip encapsulation. What is the issue ?

here is my config:

chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"

chat-script 3gdata "" "ATDT*98*1#" TIMEOUT 30 CONNECT

!

controller Cellular 0

!

!

interface Cellular0

description WAN towards MTS

no ip address

ip mtu 1452

encapsulation slip

dialer in-band

dialer string 3gdata

dialer-group 1

async mode interactive

!

interface Dialer1

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly in

encapsulation slip

load-interval 30

dialer in-band

dialer idle-timeout 2147483

dialer string 3gdata

dialer-group 1

!

line 3

script dialer 3gdata

login

modem InOut

no exec

transport input all

transport output all

autoselect during-login

autoselect slip

!

ip route 8.8.8.8 255.255.255.255 Dialer1

!

dialer-list 1 protocol ip permit

!

access-list 1 permit any

!

ustanicka#sh cellular 0 network

Current Service Status = Normal, Service Error = None

Current Service = Combined

Packet Service = UMTS/WCDMA (Attached)

Packet Session Status = Inactive

Current Roaming Status = Home

Network Selection Mode = Automatic

Country = SRB, Network = MTS

Mobile Country Code (MCC) = 220

Mobile Network Code (MNC) = 3

Location Area Code (LAC) = 21101

Routing Area Code (RAC) = 1

Cell ID = 32286

Primary Scrambling Code = 140

PLMN Selection = Automatic

Registered PLMN =  , Abbreviated =

Service Provider = mt:s

ustanicka#sh cellular 0 pro    

ustanicka#sh cellular 0 profile

Profile 1 = INACTIVE* **

--------

PDP Type = IPv4

Access Point Name (APN) = gprswap

Authentication = CHAP

Username: mts

Password: 064

  * - Default profile

Configured default profile for active SIM 0 is profile 1.

Thanks

1 REPLY

Re: 881G+7-K9 3G modem issue

Hello.

You configuration is not correct.

You need something like:

interface Cellular0/0
  no ip address
  encapsulation ppp
  load-interval 60
  dialer in-band
  dialer pool-member 1

interface Dialer1
ip address negotiated
  ! ip access-group 100 in

ip nat outside
encapsulation ppp
  dialer pool 1
  dialer string 3gdata

dialer persist

no ip redirects
no ip unreachable
async mode interactive
ppp chap password ...

---

If you are unable to use "encapsulation ppp" under c0 interface - try to update to newer IOS.

238
Views
0
Helpful
1
Replies