Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

887-m drops overnight

Hi All,

I have recently configured a cisco 887-m for a new ADSL connection.
The connection is presented as ethernet from an NTU.
The  first day i put it in, it was working for 2 days then dropped. Turning  the router off and on fixes the issue except twice now it has dropped  again overnight. When i console in i cannot ping google.com from the  router.

Here is the config

ROUTER#sh run
Building configuration...

Current configuration : 2029 bytes
!

version 12.4
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
!

hostname ROUTER
!

boot-start-marker
boot-end-marker
!

!
no aaa new-model
!

!
dot11 syslog
no ip source-route
ip cef
!

!
ip domain name mydomain.com
ip name-server 203.161.127.1
ip name-server 203.153.224.42
!

vpdn enable
!

vpdn-group pppoe
!

!
!

username oiadmin privilege 15 password 7 014357055F065701
!

!
archive
log config
hidekeys
!

!
ip ssh version 2
!

!
!

interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!

interface FastEthernet0
switchport access vlan 2
!

interface FastEthernet1
!

interface FastEthernet2
!

interface FastEthernet3
!

interface Vlan1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!

interface Vlan2
ip address xxx.xxx.xxx.xxx 255.255.255.252
no ip redirects
ip nat outside
ip virtual-reassembly
!

ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 (ISP GATEWAY IP)
!

no ip http server
no ip http secure-server
ip nat inside source list mydomain-ip interface Vlan2 overload
ip nat inside source static tcp 192.168.0.100 9100 interface Vlan2 9100
ip nat inside source static tcp 192.168.0.11 1433 interface Vlan2 1433
ip nat inside source static tcp 192.168.0.11 21 interface Vlan2 21
ip nat inside source static tcp 192.168.0.5 443 interface Vlan2 443
ip nat inside source static tcp 192.168.0.5 3389 interface Vlan2 3389
ip nat inside source static tcp 192.168.0.5 80 interface Vlan2 80
!

ip access-list extended mydomain-ip
permit ip 192.168.0.0 0.0.0.255 any
!

!
!

!
control-plane
!

banner login ^C

********** Router *********

    • WARNING **
      ** Access to this device is restricted to authorized persons only **

^C
!

line con 0
password 7 0256555A0F0B5E2F
login
no modem enable
line aux 0
line vty 0 4
login local
transport input telnet ssh
!

no scheduler max-task-time
end

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

887-m drops overnight

I don't see any line issues, however, if you say that a reboot fixes it then I'm incline to consider a potential IOS bug.

I can see you are using an IOS "T" train.  I'd recommend you upgrade your IOS "M" train.

7 REPLIES
Hall of Fame Super Gold

887-m drops overnight

post the output to the command "sh dsl atm".

New Member

887-m drops overnight

The atm interface is not being used as WAN connection. The connection is coming in through F0 which has switchport access to VLAN2

PER-HL-RTR-01#sh dsl int atm0

ATM0

Alcatel 20190 chipset information

Line has not yet been activated.

Modem Status:    Down (DMTDSL_STOP)

DSL Mode:        Unknown

Interrupts:      4124 (0 spurious)

PHY Access Err:  0

Activations:     0

LED Status:      OFF

LED On Time:     500

LED Off Time:    500

Init FW:         init_AMR-3.0.014_no_bist.bin

Operation FW:    AMR-3.0.014.bin

FW Source:       embedded

DSL: Training log buffer capability is not enabled

PER-HL-RTR-01#

Hall of Fame Super Gold

887-m drops overnight

Turning  the router off and on fixes the issue except twice now it has dropped  again overnight

Can you post the following output commands:

1.  sh int f0;

2.  sh int dial 0; and

3.  sh version

New Member

887-m drops overnight

Router#sh int f0

FastEthernet0 is up, line protocol is up

  Hardware is Fast Ethernet, address is 0026.99c6.721f (bia 0026.99c6.721f)

  MTU 1500 bytes, BW 10000 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 10/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Half-duplex, 10Mb/s

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 3

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 430000 bits/sec, 44 packets/sec

  5 minute output rate 66000 bits/sec, 30 packets/sec

     499701 packets input, 626915803 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 input packets with dribble condition detected

     328793 packets output, 61469934 bytes, 0 underruns

     7 output errors, 8248 collisions, 2 interface resets

     0 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier

     0 output buffer failures, 0 output buffers swapped out

I dont have a dialer interface configured

ROUTER#sh ver

Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version 12.4(15)T10, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2009 by Cisco Systems, Inc.

Compiled Mon 14-Sep-09 23:35 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE

PER-HL-RTR-01 uptime is 1 hour, 45 minutes

System returned to ROM by power-on

System image file is "flash:c870-advsecurityk9-mz.124-15.T10.bin"

This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to

export@cisco.com.

Cisco 877-M (MPC8272) processor (revision 0x400) with 118784K/12288K bytes of memory.

Processor board ID FHK135060A5

MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10

4 FastEthernet interfaces

1 ATM interface

128K bytes of non-volatile configuration memory.

24576K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102

Hall of Fame Super Gold

887-m drops overnight

I don't see any line issues, however, if you say that a reboot fixes it then I'm incline to consider a potential IOS bug.

I can see you are using an IOS "T" train.  I'd recommend you upgrade your IOS "M" train.

New Member

887-m drops overnight

Thanks for your help Leo,

I will update to 151-4.M7 and see how that goes

Hall of Fame Super Gold

887-m drops overnight

I will update to 151-4.M7 and see how that goes

Make sure your DRAM and your router's flash is the right amount.

112
Views
0
Helpful
7
Replies