Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

887va ADSL Configuration

Hi All,

Bare with me here I am very new to Cisco routers.

We have currently bought a new 887va Cisco Router to replace our Zyxel router.

Our hosting provider sent me a configuration file to use for the router (see below), but I can't seem to just get an ip address to work on the router. Literally tried everything. If anybody could help would be great.I was hoping to set up an ip address then hoprfully use a web based graphical interface to set it up.

This is what my hosting provider sent me:

Current configuration : 1488 bytes

!

version 12.4                                                            ***version

information

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ADSLrouter                                                  *** sets

hostname of the router

!

boot-start-marker

boot-end-marker

!

enable password ****           *** sets

password to get into enable mode on router

!

no aaa new-model

!

!

ip cef

!

!

multilink bundle-name authenticated

!

!

archive

log config

hidekeys

!

!

!

!

!

interface ATM0                                                            *** interface

ATM0 information/configuration

no ip address                                                            *** specifies

ADSL connection specific details

no atm ilmi-keepalive

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface BRI0                                                            *** interface

BRI0 information/configuration

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet0                                                  *** interface

FastThernet0 information/configuration

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface Vlan1

no ip address

!

interface Dialer0                                                  *** interface

Dialer0 interface information/configuration

description Dialer for ADSL                                        *** includes all

of ppp authentication details etc

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no keepalive

no cdp enable

ppp authentication chap callin

ppp chap hostname ******

ppp chap password 0 *******

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0                              *** Default

static route for Dialer0 interface

!

!

no ip http server

ip nat inside source list 1 interface Dialer0 overload          *** assigns nat

to the Dialer0 interdace

!

access-list 1 permit 192.168.0.0 0.0.0.255                    *** Specifies

access list

!

control-plane

!

!

line con 0                                                            *** Specifies

details to allow access via Telnet, console etc

logging synchronous

line aux 0

line vty 0 4

password

login

!

end

---------------------------------------------------------------------------------

This is my curent configuration

Current configuration : 3031 bytes

!

! Last configuration change at 09:13:49 UTC Mon Jul 29 2013

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$v7b.$8.3HT4oD8hoRIMs34gSDU1

enable password enablepass

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1390929568

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1390929568

revocation-check none

rsakeypair TP-self-signed-1390929568

!

!

crypto pki certificate chain TP-self-signed-1390929568

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31333930 39323935 3638301E 170D3133 30363130 31313232

  32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 33393039

  32393536 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100DF4C 2F0F7826 4FB77B33 6E0EDEC7 ED8A9E8B E39257ED E54822A4 4E384B5C

  A541A6A1 AAC2F798 09E741C4 D86EFA9F 8FA04B58 51B2EF67 D87F3A4F DE183869

  721AB47D 0E44EDE9 399E0216 E51107ED 9416B110 95A2304B 6159BE5E 2BD83A80

  3C6DF82F A61137B6 4FA02EAD 32E73DDA A0A89C0E F474B5C3 F0F909D8 BEBA87F1

  50A70203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 14036292 33761A9B DD08B78E 98EDE20B CA42038E 99301D06

  03551D0E 04160414 03629233 761A9BDD 08B78E98 EDE20BCA 42038E99 300D0609

  2A864886 F70D0101 05050003 8181005C 85F74002 CEC49B3D AD93C129 D7CA3AB3

  9E740890 77FCF2AB A5F55EDC A223D837 1FA7EE93 82AE9022 B0664457 B887C540

  A932616D 628F87E2 BFCE7D2B 6D45023A 0AB08806 07F3351D 5178300C 19B54782

  828EDAA2 856D7275 3BDF5D36 DCFE6563 2642FF09 3826E013 38C3EF20 9B6D8FBE

  10C13B9E FABE0BBC FFD0C518 D7DA8E

        quit

ip source-route

no ip routing

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

license udi pid CISCO887VA-M-K9 sn FCZ1712C77K

!

!

username admin privilege 15 password 0 13

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

no ip route-cache

shutdown

!

interface ATM0

no ip address

no ip route-cache

shutdown

no atm ilmi-keepalive

!

interface FastEthernet0

description internal interface

no ip address

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

pppoe-client dial-pool-number 1

!

interface Vlan1

no ip address

no ip route-cache

shutdown

!

ip default-gateway 192.168.1.254

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

!

!

!

!

!

!

line con 0

no modem enable

line aux 0

login local

line vty 0 4

privilege level 15

password termpass

login local

transport input telnet ssh

!

end

--------------------------------------------------

On my current config I'm mainly trying to set it up so I can access the router through internet explorer so I can set It up that way.

Many thanks in advance.

Everyone's tags (5)
3 ACCEPTED SOLUTIONS

Accepted Solutions

887va ADSL Configuration

Forget the setup via http!

Go to the console,

"conf t" and paste:

interface ATM0         

no ip address          

no atm ilmi-keepalive

no shut

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

interface Dialer0            

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no keepalive

no cdp enable

ppp authentication chap callin

ppp chap hostname ******

ppp chap password 0 *******

interface FastEthernet3

no pppoe-client dial-pool-number 1

int vlan1

ip address 192.168.0.1 255.255.255.0 (or whatever your internal should be

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1300

Then go out of config-mode, plug the cable to the modem and wait a bit. Then type:

sh controller vdsl 0

and check if it's in sync. If yes, type "sh int di0" and look at line 2 or 3 if you got an IP.

Michael

Please rate all helpful posts

Michael Please rate all helpful posts

887va ADSL Configuration

conf t

int vlan1

no shut

int di0

ppp ipcp dns request

ppp ipcp route default

access-list 150 permit ip 192.168.100.0 0.0.0.255 any

ip nat inside source list 150 interface Dialer0 overload

Then you shoul be fine if you plug your network (LAN) in Port FA0

Michael

Please rate all helpful posts

Michael Please rate all helpful posts

887va ADSL Configuration

conf t

ip cef

ip routing

Your Switch is connected to port FA0?

Michael

Please rate all helpful posts

Michael Please rate all helpful posts
9 REPLIES

887va ADSL Configuration

Forget the setup via http!

Go to the console,

"conf t" and paste:

interface ATM0         

no ip address          

no atm ilmi-keepalive

no shut

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

interface Dialer0            

ip address negotiated

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no keepalive

no cdp enable

ppp authentication chap callin

ppp chap hostname ******

ppp chap password 0 *******

interface FastEthernet3

no pppoe-client dial-pool-number 1

int vlan1

ip address 192.168.0.1 255.255.255.0 (or whatever your internal should be

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1300

Then go out of config-mode, plug the cable to the modem and wait a bit. Then type:

sh controller vdsl 0

and check if it's in sync. If yes, type "sh int di0" and look at line 2 or 3 if you got an IP.

Michael

Please rate all helpful posts

Michael Please rate all helpful posts
New Member

887va ADSL Configuration

Hi Michael,

Thanks for that, this is what it came up with after:

Dialer0 is up, line protocol is up (spoofing)

  Hardware is Unknown

  Internet address is 213.2.98.233/32

  MTU 1500 bytes, BW 56 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP Closed, loopback not set

  Keepalive not set

  DTR is pulsed for 1 seconds on reset

  Interface is bound to Vi2

  Last input never, output never, output hang never

  Last clearing of "show interface" counters 00:25:27

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: weighted fair

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/0/16 (active/max active/max total)

     Reserved Conversations 0/0 (allocated/max allocated)

     Available Bandwidth 42 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     7 packets input, 746 bytes

     20 packets output, 1200 bytes

Bound to:

Virtual-Access2 is up, line protocol is up

  Hardware is Virtual Access interface

  MTU 1500 bytes, BW 960 Kbit/sec, DLY 20000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP Open

  Open: IPCP

  PPPoATM vaccess, cloned from Dialer0

  Vaccess status 0x44

  Bound to ATM0 VCD: 1, VPI: 0, VCI: 38, loopback not set

  Keepalive not set

  DTR is pulsed for 5 seconds on reset

  Interface is bound to Di0 (Encapsulation PPP)

  Last input 00:00:06, output never, output hang never

  Last clearing of "show interface" counters 00:21:19

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     48 packets input, 3206 bytes, 0 no buffer

     Received 0 broadcasts (0 IP multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

     40 packets output, 1636 bytes, 0 underruns

     0 output errors, 0 collisions, 0 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     0 carrier transitions

--------------------------------------------------------------

I tried connecting through the internet and I still couldn't! is there something else I need to change in my config:

Current configuration : 3424 bytes

!

! Last configuration change at 11:20:36 UTC Mon Jul 29 2013

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$v7b.$8.3HT4oD8hoRIMs34gSDU1

enable password enablepass

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1390929568

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1390929568

revocation-check none

rsakeypair TP-self-signed-1390929568

!

!

crypto pki certificate chain TP-self-signed-1390929568

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31333930 39323935 3638301E 170D3133 30363130 31313232

  32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 33393039

  32393536 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100DF4C 2F0F7826 4FB77B33 6E0EDEC7 ED8A9E8B E39257ED E54822A4 4E384B5C

  A541A6A1 AAC2F798 09E741C4 D86EFA9F 8FA04B58 51B2EF67 D87F3A4F DE183869

  721AB47D 0E44EDE9 399E0216 E51107ED 9416B110 95A2304B 6159BE5E 2BD83A80

  3C6DF82F A61137B6 4FA02EAD 32E73DDA A0A89C0E F474B5C3 F0F909D8 BEBA87F1

  50A70203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 14036292 33761A9B DD08B78E 98EDE20B CA42038E 99301D06

  03551D0E 04160414 03629233 761A9BDD 08B78E98 EDE20BCA 42038E99 300D0609

  2A864886 F70D0101 05050003 8181005C 85F74002 CEC49B3D AD93C129 D7CA3AB3

  9E740890 77FCF2AB A5F55EDC A223D837 1FA7EE93 82AE9022 B0664457 B887C540

  A932616D 628F87E2 BFCE7D2B 6D45023A 0AB08806 07F3351D 5178300C 19B54782

  828EDAA2 856D7275 3BDF5D36 DCFE6563 2642FF09 3826E013 38C3EF20 9B6D8FBE

  10C13B9E FABE0BBC FFD0C518 D7DA8E

        quit

ip source-route

no ip routing

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

license udi pid CISCO887VA-M-K9 sn FCZ1712C77K

!

!

username admin privilege 15 password 0 ********

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

no ip route-cache

shutdown

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

description internal interface

no ip address

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

!

interface Vlan1

ip address 192.168.100.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

ip tcp adjust-mss 1300

shutdown

!

interface Dialer0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

no keepalive

ppp authentication chap callin

ppp chap hostname **************

ppp chap password 0 ************

no cdp enable

!

ip default-gateway 192.168.1.254

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

!

!

!

!

!

!

line con 0

no modem enable

line aux 0

login local

line vty 0 4

privilege level 15

password termpass

login local

transport input telnet ssh

!

end

Many thanks for your help.

887va ADSL Configuration

conf t

int vlan1

no shut

int di0

ppp ipcp dns request

ppp ipcp route default

access-list 150 permit ip 192.168.100.0 0.0.0.255 any

ip nat inside source list 150 interface Dialer0 overload

Then you shoul be fine if you plug your network (LAN) in Port FA0

Michael

Please rate all helpful posts

Michael Please rate all helpful posts
New Member

887va ADSL Configuration

Hi Michael,

Don't know if I'm doing something really wrong but it's still not connecting to the internet! Am I missing something, are set up is: ISP(Claranet/U-Net) ------- 887va-Router--------SG100-24-Switch------------10+Computers (Not sure if that will help)

Here's the current config:

Building configuration...

Current configuration : 3595 bytes

!

! Last configuration change at 12:54:53 UTC Mon Jul 29 2013 by admin

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

enable secret 5 $1$v7b.$8.3HT4oD8hoRIMs34gSDU1

enable password enablepass

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1390929568

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1390929568

revocation-check none

rsakeypair TP-self-signed-1390929568

!

!

crypto pki certificate chain TP-self-signed-1390929568

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31333930 39323935 3638301E 170D3133 30363130 31313232

  32325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 33393039

  32393536 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100DF4C 2F0F7826 4FB77B33 6E0EDEC7 ED8A9E8B E39257ED E54822A4 4E384B5C

  A541A6A1 AAC2F798 09E741C4 D86EFA9F 8FA04B58 51B2EF67 D87F3A4F DE183869

  721AB47D 0E44EDE9 399E0216 E51107ED 9416B110 95A2304B 6159BE5E 2BD83A80

  3C6DF82F A61137B6 4FA02EAD 32E73DDA A0A89C0E F474B5C3 F0F909D8 BEBA87F1

  50A70203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 14036292 33761A9B DD08B78E 98EDE20B CA42038E 99301D06

  03551D0E 04160414 03629233 761A9BDD 08B78E98 EDE20BCA 42038E99 300D0609

  2A864886 F70D0101 05050003 8181005C 85F74002 CEC49B3D AD93C129 D7CA3AB3

  9E740890 77FCF2AB A5F55EDC A223D837 1FA7EE93 82AE9022 B0664457 B887C540

  A932616D 628F87E2 BFCE7D2B 6D45023A 0AB08806 07F3351D 5178300C 19B54782

  828EDAA2 856D7275 3BDF5D36 DCFE6563 2642FF09 3826E013 38C3EF20 9B6D8FBE

  10C13B9E FABE0BBC FFD0C518 D7DA8E

        quit

ip source-route

no ip routing

!

!

!

!

!

no ip cef

no ipv6 cef

!

!

license udi pid CISCO887VA-M-K9 sn FCZ1712C77K

!

!

username admin privilege 15 password 0 *************

!

!

!

!

controller VDSL 0

!

!

!

!

!

!

!

!

interface Ethernet0

no ip address

no ip route-cache

shutdown

no fair-queue

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc 0/38

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

!

interface FastEthernet0

description internal interface

no ip address

!

interface FastEthernet1

no ip address

shutdown

!

interface FastEthernet2

no ip address

shutdown

!

interface FastEthernet3

no ip address

!

interface Vlan1

ip address 192.168.100.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

no ip route-cache

ip tcp adjust-mss 1300

!

interface Dialer0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation ppp

dialer pool 1

dialer-group 1

no keepalive

ppp authentication chap callin

ppp chap hostname **************

ppp chap password 0 ************

ppp ipcp dns request

ppp ipcp route default

no cdp enable

!

ip default-gateway 192.168.1.254

ip forward-protocol nd

ip http server

ip http authentication local

ip http secure-server

ip http timeout-policy idle 600 life 86400 requests 10000

!

ip nat inside source list 150 interface Dialer0 overload

!

access-list 150 permit ip 192.168.100.0 0.0.0.255 any

!

!

!

!

!

line con 0

no modem enable

line aux 0

login local

line vty 0 4

privilege level 15

password termpass

login local

transport input telnet ssh

!

end

Many Thanks

887va ADSL Configuration

conf t

ip cef

ip routing

Your Switch is connected to port FA0?

Michael

Please rate all helpful posts

Michael Please rate all helpful posts
New Member

887va ADSL Configuration

Brilliant, Thanks so much Michael,

One other thing I've got an ftp server aswell ip 192.168.100.104

How do I set-up port forwarding to that server on the router?

Thankyou so much for your help.

887va ADSL Configuration

ip nat inside source static tcp 192.168.100.104 21 interface dialer 0 21

Michael

Please rate all helpful posts

Michael Please rate all helpful posts
New Member

887va ADSL Configuration

Thanks Michael,

Can I use the same command for opening http port aswell for the same server?

887va ADSL Configuration

Sure!

Michael

Please rate all helpful posts

Michael Please rate all helpful posts
1078
Views
5
Helpful
9
Replies
CreatePlease login to create content