Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

887VA Router VLAN limitations

I'm configuring an 887VA router's fastethernet0 interface.  What I want to do is trunk all VLAN's from this router to a cisco 2960 switch (or any other access layer switch really).

I'm seeing that there's a limitation on this 887VA of only being able to have 8 VLAN's configured locally on this device which is a little bit of an issue but I can probably work around this.  I've got 7 VLAN's I need to trunk and I'd like to set 999 as my native and shutdown (which would be 8 VLAN's) and then VLAN 1 which can't be removed (which would be 9 VLAN's).

Realistically I can probably not even use VLAN 999  which would get me to the 8 VLAN limit.

Leaving me with the following VLAN's I need to trunk:

999

2100

2101

2102

2104

2105

2106

2108

There are 2 issues I'm running into which is the following:

--------------------------------------

router# show vlans

 

No Virtual LANs configured.

---------------------------------------

Even though I have those VLAN's configured in the router.  I've also configured SVI's for each of those VLAN's so I'm not sure why I see them.

If I do a "show vlan-switch" I see those VLAN's in the list as active status though ??

 

Issue # 2 is the following:

---------------------------------------

router(config)# interface fa0

router(config-if)# switchport trunk allowed vlan 2100

Command rejected: Bad VLAN allowed list. You have to include all default vlans, e.g. 1-2,1002-1005. 

---------------------------------------

I should also state my port configuration for fa0:

switchport trunk native vlan 999

switchport mode trunk

no ip address

I'm not sure why I can't just create a simple trunk port.  I've also tried to apply the command "switchport trunk encapsulation dot1q".  The router gives no feedback and it looks like it takes the command but after a "show run int fa0"  it does not show up in the list of commands.

I could not find any example configurations anywhere for the 887VA.

Any help is greatly appreciated

Everyone's tags (1)
5 REPLIES
Hall of Fame Super Gold

switchport trunk

switchport trunk encapsulation dot1q

This command ain't supported/accepted because the 4-port switch is a dumb down version of a 2960.

To enable the trunk you just need "switchport mode trunk" and that's it.

 

As to your VLANs, the system won't support VLANs 1002 and above.  Like I said, it's a "dumb down" 2960 switch chip.  

New Member

Yikes so there is no ability

Yikes so there is no ability whatsoever to trunk over VLANs higher than 1002 ?  

Hall of Fame Super Gold

Nope.

Depends on your IOS.

 

I've got 890 and I have a number of them running VLANs numbers 2000.

New Member

Ok yeah right now this 887VA

Ok yeah right now this 887VA came with:

c880data-universalk9-mz.152-4.M5.bin

 

I tried updating it to use: c800-universalk9-mz.SPA.153.3.M4.bin

 

however it wouldn't even take it.  It refused to boot so luckily I was able to use the USB port to re-load using the original IOS version.

When I look up on Cisco's software support to download new IOS versions, I don't see anything that has a "c880" of anything else.  I couldn't even find the IOS version that it came with on that site.

Hall of Fame Super Gold

Firmware can be found HERE.

Firmware can be found HERE.  The file you've used, is invalid or is NOT for the 887VA.

325
Views
0
Helpful
5
Replies
CreatePlease login to create content