Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

891 Dynamic NAT not working

Hi All,

I've got a new 891 to replace an old 837 and I'm struggling to get the dynamic nat pool working.

I've successfully configured the dialer etc for PPPoE and when I set up a static NAT translation between my PC and an external address then I can ping hosts on the internet e.g. ping 8.8.8.8 successfully. But when I remove the static translation and try and use the dynamic NAT pool then no NAT translations take place, and show ip nat translations only shows the other static entries.

The relevant bits of the config are below and I've also attached a full (cleaned) config.

I've been at this a few days now so any pointers would be much appreciated

ip nat pool TestPool 81.2.123.226 81.2.123.226 netmask 255.255.255.248

ip nat inside source list 15 pool TestPool overload

! Can only access internet when static route is defined for my PC

! If I remove this line then it doesn't use the dymnamic pool TestPool

ip nat inside source static 172.16.0.11 81.2.123.226

!

! Add static NAT translations for SIP phones and server.

!

ip nat inside source static 172.16.0.2 81.2.123.228

ip nat inside source static 172.16.0.3 81.2.123.229

ip nat inside source static 172.16.0.4 81.2.123.230

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

access-list 15 permit 172.16.0.0 0.0.0.128

Everyone's tags (4)
2 REPLIES

Re: 891 Dynamic NAT not working

Try this and let me know.

Please remove this line.

no ip nat inside source list 15 pool TestPool overload

and apply this instead.

ip nat inside source list 15 interface Dialer1 overload

interface GigabitEthernet0

no ip address

no  ip tcp adjust-mss 1452

interface Dialer1

ip mtu 1492

Thanks

New Member

891 Dynamic NAT not working

Hi,

Thanks, but that didn't make any difference, I made those amendments and as soon as I removed the line

ip nat inside source static 172.16.0.11 81.2.123.226

It failed to apply the dynamic NAT translation.

358
Views
0
Helpful
2
Replies
CreatePlease login to create content