Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

892 and Catalyst 2960 extend LAN over sfp fiber

Hello,

I need to extend the LAN on the 892 to the Catalyst switch via the fiber sfp modules in each unit.  I enabled the GigabitEthernet0 port on the 892 and set the medi-type to sfp.  What do I need to do to make that port part of the inside network?

I will post configs of both devices if neccesary; I guess I was hoping it would just plug and play!

Thanks!

5 REPLIES
New Member

892 and Catalyst 2960 extend LAN over sfp fiber

Yes, post the configs please.

New Member

892 and Catalyst 2960 extend LAN over sfp fiber

Router config below - it appears that the SFP slot on the 892 is for WAN only?  If I try to set switchport mode access on that port, it gives invalid command.

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool ccp-pool

import all

network 10.10.10.0 255.255.255.248

default-router 10.10.10.1

dns-server nnn.nnn.nnn.nnn nnn.nnn.nnn.nnn

lease 0 2

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

isdn termination multidrop

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

no ip address

!

interface FastEthernet5

no ip address

!

interface FastEthernet6

no ip address

!

interface FastEthernet7

no ip address

!

interface FastEthernet8

ip address nnn.nnn.nnn.nnn 255.255.255.252

ip access-group 101 in

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0

no ip address

duplex half

speed 100

media-type sfp

!

interface Vlan1

description $ETH_LAN$

ip address 10.10.10.1 255.255.255.248

ip nat inside

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

ip forward-protocol nd

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list 199 interface FastEthernet8 overload

ip route 0.0.0.0 0.0.0.0 nnn.nnn.nnn.nnn

!

access-list 101 permit tcp any any established

access-list 199 permit ip any any

New Member

892 and Catalyst 2960 extend LAN over sfp fiber

Does the command "switchport" work to enable it for layer 2? What is the show interface details for that interface? 892 is a router correct? A router doesn't carry vlans.

What are you trying to accomplish? Router on a stick?

New Member

892 and Catalyst 2960 extend LAN over sfp fiber

I am able to use the switchport command on the other interfaces (Fa0-7), but not on Gi0.  The 892 is a combination router/switch among other things.  I'm trying to use the sfp port which I have inserted a fiber connector to extend the LAN to a switch in a remote location.  Is there another way to use the Gi0 interface to pass traffic other than switchport?

New Member

892 and Catalyst 2960 extend LAN over sfp fiber

I am going to say, just from reading the product details, that the Gi interface is WAN only which means you need to route your traffic. This would make sense since its a SOHO type router/switch.

161
Views
0
Helpful
5
Replies