Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

A Connected route added to routing table after PPPoE using Dialer interface

Hi All,

There was a strange case rised on my customer environment. On my customer's Cisco 2811 w/ 12.4(10) or 2611XM w/ 12.3(10c), there are two dynamic ADSL line connecting to the WIC1ADSL card which are used with PPPoE settings(Dialer interface) to get internet connectivities. After these 2 lines or one of them dialed up to ISP, they get 2 public IP addresses on dialer interfaces, but I find that there is a connected route added to the routing table, I suspect that the host in the route entry is a host inside the ISP. This route entry is not in existance when the ATM interface goes down. And this case never happened on my other customer. So I would like to ask anyone who knows why a CONNECTED route entry automatically added to the routing table of the router? This case still happens even I reset the router to dummy setting which only serves the PPPoE.

The routing table is like the following:

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

100.x.100.0/32 is subnetted, 1 subnets

C 100.x.100.29 is directly connected, Dialer1

99.0.0.0/32 is subnetted, 1 subnets

C 99.31.47.18 is directly connected, Dialer1

C 192.168.1.0/24 is directly connected, Loopback0

S* 0.0.0.0/0 is directly connected, Dialer1

Note: 100.100.100.29 is the suspected entry. This IP and route entry is constant after both or one of the 2 broadbands dialed up to ISP. 99.x.x.18 is the IP of dialer1 interface.

The following is the dummy settings on 2611XM:

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 2611

!

boot-start-marker

boot-end-marker

!

!

no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

!

!

ip audit po max-events 100

vpdn enable

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

pvc 1/33

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

!

interface FastEthernet0/0

ip address 192.168.0.1 255.255.255.0

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp pap sent-username test password test

!

ip nat inside source list 100 interface Dialer1 overload

ip http server

no ip http secure-server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

access-list 100 permit ip 192.168.1.0 0.0.0.255 any

access-list 100 permit ip 192.168.0.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

!

!

end

Thanks!

Jason

2 REPLIES
Silver

Re: A Connected route added to routing table after PPPoE using D

This is typically the IP of the virtual-template which the ISP has created on the LNS. Not sure why the route is inserted probably for an end-to-end Layer 3 connectivity over the PPP network.

Hall of Fame Super Silver

Re: A Connected route added to routing table after PPPoE using D

Jason

The addition of a /32 route in the routing table is a result of the ppp negotiation that is part of the dialer interface configuration with address negotiated. Inserting the /32 is normal and I do not see that it causes any problem. Is there a reason that you are concerned about it?

I am wondering about this statement:

100.100.100.29 is the suspected entry. This IP and route entry is constant after both or one of the 2 broadbands dialed up to ISP. 99.31.47.18 is the IP of dialer1 interface.

I believe that 100.100.100.29 is the address of the device on the other end of the ppp connection. I do not understand how 99.31.47.18 is the address of the dialer interface. Perhahps you could post the output of show ip interface brief along with the output of show ip route so that we can understand the relationship better.

It might be very interesting and informative if we could see the output of debug ppp negotiation.

HTH

Rick

342
Views
0
Helpful
2
Replies