Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

A point in the right direction..

Hi, I'm hoping someone could point me in the right direction. I work for a very small company so it's down to me to do everything technical, now whilst new things usually come down to me looking on youtube, the current problem has stumpted me totally. I don't know where to start looking.

The situation we have is, BT is puting in a leased line (EFM) connection with a managed router. We (I) have specified we need 90 ip addresses for our customers (1 per customer). What I want to do is forward all traffic from 1 incomming IP address to an internal IP address but I have no idea how to achieve this. I have a couple of Cisco routers 2611xm. Any points in the right direction would be very appreciated.

Regards

Dave.

5 REPLIES
Bronze

A point in the right direction..

Hi Dave,

If those 90 ip addresses are part of a single subnet you can use nat to translate from one public ip to the subnet.

Example

int Fa0/0

ip address 192.168.1.0 255.255.255.128    -it gives you 126 ip addresses for customers

ip nat inside

no shut

int Serial0/0

ip address x.x.x.x x.x.x.x  -public ip assign by ISP

ip nat outside

no shut

access-list 1 permit 192.168.1.0 0.0.0.127

ip nat inside source list 1 interface Serial0/0 overload

The last command allows all customers to use the single ip address configured on serial interface to go outside of LAN. It does that by translating the private ip address to public ip address to go out surfing the big Internet.

Hope this will help you

Eugen

New Member

A point in the right direction..

Eugen that is great thank you so much, I was at such a loss as to how to accomplish it.

I have another question if you can answer this I will be a happy man. I won't go into details of the product because it isn't a cisco product, what I would like to do is virtually the reverse of the solution you previously gave me. What I would like to do is this

point a application to a local IP address which then forwards all traffic to an external IP address and any return traffic route back to the local ip address so the application pointing to it can receive it.  I really hope that makes sense. Can this be accomplished with a router? I would like to be able to have multiple of these re-routes

Regards

Dave.

Bronze

Re: A point in the right direction..

You have to use an extended access list.

Change the access list above to

Example

access-list 101 permit tcp host 192.168.1.1 80 host x.x.x.x eq 80 

it permits port 80 communication between one source and one destination

Eugen

edit

You can find more info here

http://www.cisco.com/en/US/products/sw/secursw/ps1018/products_tech_note09186a00800a5b9a.shtml

New Member

Re: A point in the right direction..

You are an absolute star, thank you so much.

Dave.

Bronze

A point in the right direction..

Glad to help

Eugen

286
Views
10
Helpful
5
Replies