Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

a router and 4 hwic adsl

I have one router 2811 and 4 hwic ADSL, How can I setup these thing with 4 internet ADSL connection efficiently?

my network: core switch 3750 is vtp server and connect to the router 2811.

ty

Everyone's tags (1)
6 REPLIES
Hall of Fame Super Gold
New Member

Re: a router and 4 hwic adsl

oh, so I can load balance 4 ADSL with this method?

Hall of Fame Super Gold

Re: a router and 4 hwic adsl

Yes, statistical load balance.

Please remember to rate useful posts clicking on the stars below.

New Member

Re: a router and 4 hwic adsl

tyvm.I will test it.

I have rated 3 star plus 2 star

New Member

Re: a router and 4 hwic adsl

I have 4 pppoe adsl, only 1 adsl has fix ip

3 adsl have dynamic ip.

I try to setup, 4 lan netwiork connect to Internet, each LAN has 1 adsl connection.


I hope this config will work: ( I use new 2800 IOS advanipservice)


!
interface FastEthernet0/0
ip address 10.10.200.54 255.255.255.252
ip nat inside
ip virtual-reassembly

ip policy route-map NET
duplex auto
speed auto
!
interface ATM0/0/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
pvc 0/35
  pppoe-client dial-pool-number 1
!
!
interface ATM0/1/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/1/0.1 point-to-point
pvc 0/35
  pppoe-client dial-pool-number 2
!
!
interface ATM0/2/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/2/0.1 point-to-point
pvc 0/35
  pppoe-client dial-pool-number 3
!
!
interface ATM0/3/0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
interface ATM0/3/0.1 point-to-point
pvc 0/35
  pppoe-client dial-pool-number 4
!
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp authentication pap chap callin
ppp chap hostname user1
ppp chap password 0 password1
ppp pap sent-username user1 password password1
!
interface Dialer2
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 2
ppp authentication pap chap callin
ppp chap hostname user2
ppp chap password 0 pw2
ppp pap sent-username user2 password pw2
!
interface Dialer3
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 3
ppp authentication pap chap callin
ppp chap hostname user3
ppp chap password pw3
ppp pap sent-username user3 password pw3
!
interface Dialer4
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 4
ppp authentication pap chap callin
ppp chap hostname user4
ppp chap password 0 pw4
ppp pap sent-username user4 password  pw4
!

ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 0.0.0.0 0.0.0.0 Dialer2
ip route 0.0.0.0 0.0.0.0 Dialer3
ip route 0.0.0.0 0.0.0.0 Dialer4
ip route 10.10.179.0 255.255.255.0 10.10.200.53
ip route 10.10.200.128 255.255.255.128 10.10.200.53
!

ip nat inside source route-map NAT1 interface Dialer1 overload
ip nat inside source route-map NAT2 interface Dialer2 overload
ip nat inside source route-map NAT3 interface Dialer3 overload
ip nat inside source route-map NAT4 interface Dialer4 overload
!

access-list 10 permit 10.10.179.0 0.0.0.128
access-list 20 permit 10.10.179.128 0.0.0.63
access-list 30 permit 10.10.200.0 0.0.0.128
access-list 40 permit 10.10.179.192 0.0.0.63
access-list 50 permit any

route-map NAT3 permit 10
match ip address 50
match interface Dialer3
!
route-map NAT2 permit 10
match ip address 50
match interface Dialer2
!
route-map NAT1 permit 10
match ip address 50
match interface Dialer1
!
route-map NAT4 permit 10
match ip address 50
match interface Dialer4
!
!

route-map NET permit 10
match ip add 10
set int Dialer1 Dialer2 Dialer3 Dialer4
exit
route-map NET permit 20
match ip add 20
set int Dialer2 Dialer1 Dialer3 Dialer4
exit

route-map NET permit 30
match ip add 30
set int Dialer3 Dialer1 Dialer2 Dialer4
exit


route-map NET permit 40
match ip add 40
set int Dialer4 Dialer1 Dialer2 Dialer1

Hall of Fame Super Gold

Re: a router and 4 hwic adsl

Nice one.  +5

507
Views
10
Helpful
6
Replies