Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

A simple IOS upgade question

     I have 2851 router running 12.4(4)XC6, I want to upgrde to 12.4-24.T2.  I have both images on my router's flash  I removed the old boot system flash command and created a new one; "boot system flash c2800nm-adventerprisek9-mz.124-24.T2.bin".  When I reboot the router will always return to the 12.4(4)XC6 image.  I'd rather not remove the old code as this is a remote site and it will be a huge problem to get the router restored.  The confreg is set to 0x2102.  Is there a way to force the router to boot to the new image?  Thanks in advance!

dir

Directory of flash:/

    1  -rw-    39715748  Jan 18 2010 10:12:12 -05:00  c2800nm-adventerprisek9-mz.124-4.XC6.bin
    2  -rw-    59455672  Jan 18 2010 15:05:24 -05:00  c2800nm-adventerprisek9-mz.124-24.T2.bin

129748992 bytes total (30572544 bytes free)

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Blue

Re: A simple IOS upgade question

cbreger_breger wrote:

I've tried all suggestions and saved the config several times, the router continues to come back to the old image.  The commands "show boot or show bootvar" do not work on the router.  Any other ideas?

sh run | i boot
boot-start-marker
boot system flsh:c2800nm-adventerprisek9-mz.124-24.T2.bin
boot-end-marker

Is the above output from the actual router ? if so you have a typo ie. flsh instead of flash

Jon

5 REPLIES
Hall of Fame Super Gold

Re: A simple IOS upgade question

Try "boot system flash:c2800nm-adventerprisek9-mz.124-24.T2.bin" OR copy the old IOS to your TFTP, delete the old IOS from the CF and copy the old IOS back.  Make sure the IOS is found BELOW the new IOS.

Cisco Employee

Re: A simple IOS upgade question

Just did a quick test in my lab routers, and I am able to boot it off the new image while leave the old image in the flash. Here is the show output

Rack1R1#sh ver | i System|Config

Copyright (c) 1986-2009 by Cisco Systems, Inc.
ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)
System returned to ROM by reload at 20:58:11 UTC Mon Jan 18 2010
System restarted at 21:00:14 UTC Mon Jan 18 2010
System image file is "flash:c2800nm-adventerprisek9-mz.124-15.T10.bin"
Configuration register is 0x2102


Rack1R1#sh run | s boot

boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.124-15.T10.bin
boot-end-marker

Rack1R1#dir
Directory of flash:/

    1  -rw-    53139536  Sep 11 2009 19:38:06 +00:00  c2800nm-adventerprisek9-mz.124-15.T9.bin
    2  -rw-    53185960  Sep 24 2009 18:48:04 +00:00  c2800nm-adventerprisek9-mz.124-15.T10.bin

256471040 bytes total (150142976 bytes free)
Rack1R1#

My question to you is did you do a wri mem before reboot?

Regards,

jerry

Community Member

Re: A simple IOS upgade question

Hi,

After config boot commad for new IOS do write mem and check the next boot loader

using show boot or show bootvar

this will display the next ios image if it is psssible u can past the outout here we can validate the same

thank you

regards

krishna kumar

Community Member

Re: A simple IOS upgade question

I've tried all suggestions and saved the config several times, the router continues to come back to the old image.  The commands "show boot or show bootvar" do not work on the router.  Any other ideas?

sh run | i boot
boot-start-marker
boot system flsh:c2800nm-adventerprisek9-mz.124-24.T2.bin
boot-end-marker

Hall of Fame Super Blue

Re: A simple IOS upgade question

cbreger_breger wrote:

I've tried all suggestions and saved the config several times, the router continues to come back to the old image.  The commands "show boot or show bootvar" do not work on the router.  Any other ideas?

sh run | i boot
boot-start-marker
boot system flsh:c2800nm-adventerprisek9-mz.124-24.T2.bin
boot-end-marker

Is the above output from the actual router ? if so you have a typo ie. flsh instead of flash

Jon

344
Views
0
Helpful
5
Replies
CreatePlease to create content